LM 16 cinnamon screen blanks and flickers

Hi all.

further to my post ‘new ish laptop’ where Mark and chemicalfan helped me with my wifi, I had installed mint 16 cinnamon, with a view to upgrading to the LTS or installing Peppermint 5 LTS in a few months.

The problem I have is when I resume from suspend, sometimes the screen flickers and sometimes screen goes black, often after 5 mins or so. sometimes for a split second sometimes for 20 seconds or so.
The problem is erratic, sometimes there is no problem, but I’m rapidly losing faith.

I,ve been on the mint forum and it appears many have similar problems, I’ve looked for a solution, which there are loads of suggestions, but I don’t know which is correct for me.

any help would be welcome.


What’s the output from:

sudo lshw -C display


And if you put your PC into suspend with this command:

sudo pm-suspend --quirk-vbe-post

does it resume properly ?
(if that command appears to work … test it a few times to be sure)

If it works, we’ll have to tell the system to use that quirk every time it enters suspend … if it doesn’t work we may have to try some other quirks.

Thanks for the reply Mark
result from 1st command

keith@keith-Lenovo-G550 ~ $ sudo lshw -C display
[sudo] password for keith:
description: VGA compatible controller
product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:46 memory:f4000000-f43fffff memory:d0000000-dfffffff ioport:1800(size=8)
*-display:1 UNCLAIMED
description: Display controller
product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 09
width: 64 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:f4400000-f44fffff

will do the suspend and post results

I’ve done the sudo-suspend a few times and it seems to work ok.
I will have to try it over a longer period to see if it stops the problems.

on resuming from this command, I have to hit a key to bring the screen back on,
when I shut the lid without this command when resuming there is the blank screen with the curser and the screen comes on by itself.

I will post back later


Didn’t know about quirks - every day is a school day! :smiley:

Yeah for now that quirk will only be applied when you enter suspend with the above command … but once you’re sure it works, we’ll (hopefully) apply it system wide :wink:

I know what you mean … but discovering new stuff is the fun of Linux (at least for me) :slight_smile:
(I learned something about “sudo” yesterday that should have been blatantly obvious [the -u option] … but hey, I know it now )

I have tried it on and off all day and I’ve seen no flickers or blackouts,

So I would be grateful for instructions on how to proceed,

then I will give it a couple of days and if no problems, will mark solved,



Open a terminal and run:

sudo gedit /etc/pm/config.d/my-pm-quirk

When a BLANK file opens, make it read


SAVE the file.

Try entering suspend in the normal way, and see if it resumes properly

entered your instructions (copied and pasted)

closed the lid to suspend, when lid was opened it resumed in the old way and flickered

try rebooting, then entering suspend.

If that doesn’t work, try:

sudo gedit /etc/pm/config.d/my-pm-quirk

and replacing what you put in there previously with:


SAVE the file and test again.

tried your 2nd instructions, same result, does not resume correct,
tried rebooting as well,

thought it was going too well.

First let’s change that back, so run:

sudo gedit /etc/pm/config.d/my-pm-quirk

When it opens, make it read


SAVE the file, and close gedit.

Now let’s add the quirk to the ACPI “sleep” script … run:

sudo gedit /etc/acpi/sleep.sh

change the last line from:-



pm-suspend --quirk-vbe-post

SAVE the file.

Close your PC’s lid … then see if resume works.

I’ve changed it back to the original,

ran the acpi in the terminal, which bought up the file with sudo gedit /etc/acpi/sleep.sh, and nothing else, no lines to change,

So what’s the output from:

ls /etc/acpi


keith@keith-Lenovo-G550 ~ $ ls /etc/acpi
asus-keyboard-backlight.sh events powerbtn.sh tosh-wireless.sh
asus-wireless.sh ibm-wireless.sh sleep.sh undock.sh
keith@keith-Lenovo-G550 ~ $

what’s the output from:

dpkg -l | grep acpi

and (if any):

cat /etc/acpi/sleep.sh

outputs from both

keith@keith-Lenovo-G550 ~ $ dpkg -l | grep acpi
ii acpi-support 0.142 i386 scripts for handling many ACPI events
ii acpid 1:2.0.18-1ubuntu2 i386 Advanced Configuration and Power Interface event daemon

keith@keith-Lenovo-G550 ~ $ cat /etc/acpi/sleep.sh
sudo gedit /etc/acpi/sleep.sh
keith@keith-Lenovo-G550 ~ $


sudo rm -v /etc/acpi/sleep.sh


sudo apt-get install --reinstall acpi-support

then post the output from:

cat /etc/acpi/sleep.sh

did the 1st 2 commands

output from 3rd
keith@keith-Lenovo-G550 ~ $ cat /etc/acpi/sleep.sh
cat: /etc/acpi/sleep.sh: No such file or directory
keith@keith-Lenovo-G550 ~ $

BTW Mark
when I suspend by using the terminal, everything runs fine.

when I suspend by closing the lid, I still get flickers and black screen, occasionally,

so if a solution can be found to apply the quirk,I would be grateful,