Locked out of my xubuntu install(s) [Solved]

I’ll abbreviate this or it’s going to rival war and peace. Bottom line is as follows…

I bought an ssd, unplugged the hdd containing my dual-boot of Ubuntu and Xubuntu, installed the ssd. There followed some fiddling about because the ssd wasn’t recognised and suddenly, neither was the sata DVD drive. So I ended up connecting both the ssd and the hdd and playing with the AHCI settings.

I then installed from a Ubuntu minimal install cd (because my PC won’t boot from a DVD). I must have missed the option to choose Xubuntu desktop, because I ended up with just the Ubuntu core - no UI. So I ran sudo apt-get install xubuntu-desktop.

Whilst testing the new installation (which turned out to be corrupt - various things not working), I set it not to require a password at boot-up. And that’s where it all went very wrong. On the next boot, it didn’t go straight to the desktop as I expected. It offered me a dialog with my username, but nowhere to give a password. So I can’t get back in. No problem - all I need to do is wipe the ssd and start again, right?

Wrong! because for some reason I can’t even begin to understand, when I swap the ssd out and the hdd back in (ie: back to ‘normal’), the original installation of Xubuntu, which used to go straight to the desktop, now also asks for a username but no password. If I select the ‘other’ account and type my username and password it keeps telling me the password is wrong, even though I know it’s right!

There’s data in the original Home folder I’d really rather not lose. Not critical, hence no backups, but a lot of stuff that’s hard to replicate. I expected the old installation to remain untouched, and I can’t understand how changes on the ssd have apparently affected the hdd.

Heeelp. Please!

At the login screen hit Ctrl+Alt+F2

Are you able to login in text mode ?

Yes! Mark, you’re a genius.

Do normal terminal commands work in text mode? Is there something I can tweak to get back in with the UI? I’m not great with the command line, but I used to be fine with DoS, so I think I’ll get by well enough to copy off the files I want…

Are you able to log into the Guest account ?

If I had to guess I’d say something in your home folder is borked, so bunging you into a login loop.

Are you up for creating a second user account to test this hypothesis ?

If so, log in in text mode … then run:



ls -l /home

and post back here the output.

Hello Mark,

I did get into the guest account. Also there are 2 other user accounts (which never get used). I can’t log into them, either in text mode (login incorrect) or normally.

mike@xubuntu:~$ groups
mike adm cdrom sudo dip plugdev lpadmin nopasswdlogin sambashare vboxusers
mike@xubuntu:~$ ls -l /home
total 20
dr-x----- 2 helen helen 4096 Aug 16 2017 helen
drwx----- 34 mike mike 12288 Oct 21 23:42 mike
drwxr-xr-x 14 test test 4096 Aug 23 2017 test

Okay log into the mike account in text mode

then run:

sudo useradd -s /bin/bash -m administrator -G adm,cdrom,sudo,dip,plugdev,lpadmin,sambashare,vboxusers

then run:

sudo passwd administrator

and when prompted enter a new password for the new administrator account … you’ll then be prompted to re-enter it.

Once you’ve done that, reboot.

sudo reboot

Once rebooted, see if you can now log onto the new account called “administrator” account with the new password you set for it.

Will do, Mark.

But first I want to copy all the data off onto an external drive, if possible. I’m looking into that now.

I’ll be back…


Okay :slight_smile:

Been struggling half the day with the command line and a live cd to no avail. Damned if I can work out how to copy off the data. I can see it in text mode but I can’t find or mount anything to copy it to.

With the live cd I can see the whole hard drive but haven’t got permission to access any of the users in the Xubuntu partition.

Boot to a Xubuntu LiveUSB, then start the file manager with elevated permissions:

sudo thunar

Now you should have permission (at least in that file manager instance)

Or use a Peppermint LiveUSB … then right-click the folder and select “Open as Root”.

Hello Mark,

You’ve cracked it again! I’m back into the original installation, having set up the administrator account as you suggested. It worked like a charm. Then I reset the password for my own account and am now able to access that too.

I’d already copied off my data via the command line, which I managed to get to grips with this morning. I’m enjoying the command line. Reminds me of my old DoS days (once an old DoS-er, always an old DoS-er).

When I tried the thunar thing, I still got a ‘permission denied’ message. That may be something to do with the fact that I used a Lubuntu livecd, so I had to use PCManFS instead of thunar? Seems unlikely, but I can’t think of any other reason - except that the whole episode is a bit of a mystery considering it began with me installing Xubuntu on a new SSD with the old hdd disconnected…

Anyway, at least I’m now back to square one, with data intact. And I thought the SSD would save me time, not cost me hours of banging my head on the desk!

The next challenge will be to try to clone the Xubuntu half of a dual-boot onto the SSD… I expect I’ll be back quite soon!

Thanks again for your help. Greatly appreciated.


Yeah in Lubuntu you’d need to run:

sudo pcmanfm

or just highlight the folder the go to

Tools > Open as Root

Anyway, glad you got it sorted :slight_smile: