Mint 17.1 installation problem using UNetbootin [SOLVED]

A friend’s old, 32 bit desktop has Mint 10 installed which is no longer supported so I decided upon Mint 17.1 which I guess will be OK on 0.5GB RAM as Mint 10 was fine.
I downloaded the ISO file, checked the MD5sum and used UNetbootin to unpack onto a USB stick. So far so good.

When attempting to install on the desktop, after selecting the right boot option, UNet bootin provided several options including, amongst others:

  • Linux Mint
  • force PAE
  • Linux Mint 17.1 32 bit

Naturally I chose Mint 17 but was confused by the presence of the plain Mint option, and it was trying to run Mint 17 that kept giving an error:
… Can’t open /dev/sr0: no medium found…
and I had the same error on my PCs, too.

In desperation, I tried choosing the plain Mint option with force PAE (without checking it was needed!) and [b]Mint 17.1[/b] began to install! and it's now running well.

The problem I faced might be a consequence of my particular hardware set-up or my choice of using UNetbootin, but users who intend to install Mint 17.1 32 bit using UNetbootin should be aware that it may be necessary to select the plain Mint option rather than Mint 17.

Reading the Mint 17 release notes (somewhat belatedly) I find this:
DVD Playback with VLC
If VLC does not find your DVD player, click on Media->Open Disc, and specify ‘/dev/sr0’ as the disc device.
So it looks like that when asking to boot “Mint 17” the PC attempts to boot from a CD despite the boot source being specified as USB. Selecting “Mint” does boot correctly from the USB.

I don’t think Mint 17 will run properly in only 512mb of RAM :frowning:
If it doesn’t it’ll be seriously slow. You should try Peppermint on it, would be much better. There’s a new Peppermint not a million miles away… (Mark? :P)

You are quite right: it is even too slow for the elderly owner.
Ideally I should upgrade the memory but the old chap is strapped for cash - I’ll see what I can do for him. In the meantime I shall try Peppermint.

Many thanks.

Peppermint will run but the minute you start web browsing you’ll start using swap … websites and browsers have become MUCH more s
resource intensive nowadays … 512MB just doesn’t cut it any more I’m afraid, no matter how light the OS you run the browser on.

Thank you, gentlemen.
I shall either upgrade the memory (if possible) or give the chap one of my “spare” PCs.

I’m grateful for your advice, as usual.

You could try running the Midori browser - it is lighter, but loses a lot of functionality. Might be a solution though, worth a try

I’m all for trying something new but the loss of functionality would be a shame, so I shall upgrade the memory at my own expense (the owner is a nice old boy).
However, I want to be sure I get the right modules, as I’ve had incompatibility problems once before.

The board is a K7N2 with three memory slots and two 256MB modules. I 'phoned MrMemory for prices and discovered that a 1GB module is available. The lady assured me that customers have had no problems upgrading to 3GB ( but the the PC says the capacity is only 1.5GB:

description: System Memory
physical id: 1b
slot: System board or motherboard
size: 512MiB
capacity: 1536MiB

Do you think I am limited to 1.5GB (3 x 0.5GB) or is it safe to buy 3 x 1GB?

That website suggests 3 memory slots, which is really weird! I don’t think I’ve ever seen an odd number of memory slots, apart from the one machine we had with SIMMs & 1 DIMM slot.

lshw should show which slots are occupied, and confirm how many there are (or, you could take the case off and have a look). I’d be inclined to buy either 1x1Gb, or 2x512Mb. Although installing more might be fine (the PC should ignore the extra RAM at BIOS level), it may not boot at all with the extra RAM.

I know the board well as I’ve replanted it into another case. There are indeed just two memory modules and three memory sockets, although one is of a different colour and slightly displaced - photo attached.
Can you explain why there might be a limit of 1.5G set by the BIOS? After all, 32bits should address about 10GB and lshw tells me that the PC supports PAE.


Every site I visit suggests the specs for max ram on that board are 3x1GB

I wouldn’t read too much into what lshw says … dmidecode and the memconf perl script suggest my AA1 can handle 4GB RAM (2x2GB)

sudo dmidecode -t 16
[sudo] password for mark: 
# dmidecode 2.12
SMBIOS 2.4 present.

Handle 0x0014, DMI type 16, 15 bytes
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: None
	Maximum Capacity: 4 GB
	Error Information Handle: Not Provided
	Number Of Devices: 2

one of the slots isn’t a slot as such it’s 512mb soldered to the board, but even that would suggest I could populate the slot with a 2GB SODIMM … wrong, it can only handle a 1GB SODIMM

Interesting to know that one should be careful interpreting lshw. I shall bear that in mind.

Thank you for checking out the board capabilities - I found nothing on the web but I guess one gets used to knowing where to look and what search criteria to use.
I shall get 3x1GB modules.

Many thanks, Mark & ChemicalFan, for your help and advice.

In fact according to Crucial. ALL the K7N2 boards seem to support 3072MB


Many thanks. I’ve ordered the modules.

That’s a weird setup! My guess is that the blue slots are dual channel, and the green one is single channel (they look like the same pin arrangement, so both should take DDR). If my guess is right, in theory the machine should run better with just the blue slots populated and the green one free, but it’s not of significance if there’s only 512MB available. What did you order in the end?

If I’m right, you should move the stick in the green slot to the blue one, and the new stick into the green slot, some boards used to be funny about mixed sizes (i.e. not paired)

You probably are right … I remember a lot of boards with this setup when dual channelling RAM was new and RAM still relatively expensive (so people still tended to buy one single stick)

I guess it was cheaper for the board manufacturer than fitting 2 x dual channel configurations (as became more commonplace later) … even if the memory controller was up to dual channel (simply saving on the socket ?)

I guess they though “nobody will ever need more than 3 in anything but a server, right ?” … I know I did :wink:


I have just installed 3 x 1GB.
lshw indicates that the PC recognises 3GB and system monitor shows that next to no swapping is happening when I run several applications, so all is apparently well…except that the system, although quicker than before, is still very slow.

POST indicates that CMOS defaults are being used which I take to mean that the battery needs to be replaced(?).
Any ideas, gents? I am happy to change the OS from Mint to anything else, such as Peppermint, and I attach lshw cpu & memory output in case that’s helpful.



which will display the top few applications listed by CPU usage … does anything jump out as hogging the CPU ?

Is the hard drive known to be OK ?

What exactly is “slow” ? … this is AFAIK a single core “Athlon XP” processor … don’t expect too much from it :wink:

What exactly is “slow” ? Indeed. Difficult to quantify.
I am now dual-booting with Peppermint 5 which seems noticeably quicker.

Using the top command, Firefox hogs about 90% on Mint 17 but only about 10% on Peppermint 5, so I would go for Peppermint anyway on that basis and leave it a that.

Since the original problem has been resolved (installation is OK and new memory recognised) I shall start another post to resolve a new problem.

Many thanks to Mark & Chemicalfan for helping once again.

Be aware … Peppermint 6 is slated for release June 1st :slight_smile:

Thank you for the info, Mark. I shall wait till then before returning the PC with P6 as the owner is not in a rush.
No doubt I shall have more queries then!

Many thanks again for your advice.