Mounting problems, in need of serious help!

I need some serious help. I’m currently dual booting between Ubuntu 10.09 & Windows Vista. A couple of days ago my Vista decided it wasn’t going to load anymore, and so I can’t even log on, all I get are system hangs (how typical of MS). Anyway, I have a lot of photos, and important files I use for my photography on the Vista partition. Now I used to be able to load the files directly from the partition through Ubuntu but now it won’t mount the whole HDD at all. I can access the local partition relevant to Ubuntu but that’s it. I keep getting this ERROR message.

"Unable to mount Local HDD

Error mounting: mount exited with exit code 13: $MFTMirr does not match $MFT (record 0).
Failed to mount ‘/dev/sda2’: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it’s a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for more details."

Please help, I’ve got files I need to recover before destroying Vista for good, lol. :frowning:

Have you tried running chkdsk from the Vista DVD ?

If you haven’t got a Vista disk, or some kind of recovery partition… You can download a Vista Recovery CD ISO image from here:

They are torrents, but normally download very quickly.

120.5 MB for the 32bit version

148.5 MB for the 64bit version

Then just burn it to CD

Be careful not to let it automatically repair startup (boot) errors, or it will overwrite GRUB and you won’t be able to get into Ubuntu either… just go to the command line, and enter:
chkdsk c: /f
(chkdsk will scan partition c: for filesystem errors and (/f) fix them)

chkdsk c: /f /r
(chkdsk will scan partition c: for filesystem errors and (/f) fix them, then scan for bad sectors and attempt to (/r) recover them)

be aware the /r switch will take a LONG time to complete, so try just the /f first.

Also make sure you have an Ubuntu LiveCD handy, just in case it does screw up GRUB.

Not yet I haven’t, I thought there may be a solution, from which I could do inside Ubuntu, but it looks like I’ll have to go blow the dust of my old friend, the “Vista Repair disc”.

Would I run chkdsk from a CMD?

Yes… I’ve edited the above post.

Be sure to read the bit about not letting it repair the bootloader.

Sorry for the wait…

I can’t even start up the CD. When I switch the laptop on, GRUB appears, I then select the windows to boot… the CD is already in, but it just automatically, goes straight to “start windows normally” because the error boot screen comes up, but i don’t even get the chance to change options. The CD drive is set to boot-up before the HDD, and the disk I have is a Win7 repair disk, so i’d imagine it would work seeing as it has the latest of driver updates and error solutions? I’m on a 3G connection atm, and have a limit of 50MB a day, so downloading the Vista Repair disk, would take far too long not to mention days :frowning: ! Isn’t there anything i can do inside Ubuntu?

Seriously I’d use chkdsk to check the file system… re-burn the Win7 repair CD… or burn it to a DVD, oddly enough I’ve seen plenty of drives that were unable to boot a CDR, but had no problem booting from a DVD+/-R.

Or, remove the drive and bung it in another PC/Laptop that CAN boot the Win7 repair disk, and run chkdsk.

Be sure to ONLY run chkdsk from a Win7 repair disks command line… I wouldn’t let it do a repair of the bootloader, and you certainly don’t want it to replace any of the Vista boot/system files.

Or, remove the hard drive and attach it as a secondary drive to another Windows PC, and scan it from within Windows.

but if you MUST try something from Ubuntu…

sudo apt-get install ntfsprogs


sudo ntfsfix /dev/sdXY

(where X and Y are drive and partition designation)

This may fix the error… it will also schedule chkdsk to be run the next time you boot Windows.

I’ve never used this, so it must be an “at your own risk” kind of thing.

That said, it’s all over the interwebs, just Google “$MFTMirr does not match $MFT (record 0)” … and in particular, here:

“Be sure the partition is not mounted” ← odd suggestion, when that is the issue… but there you go :wink:

Well I can’t run chkdsk in Windows, because I can’t get the disc to boot up, I would’ve Windows would’ve picked up on it as soon as I select Windows from GRUB. I know the disc is fine, because it’s a DVD-R and my disc-drive picks the disc up fine in Ubuntu, it’s just getting the disc to boot up in Windows, because like I said before, as soon as I select it, I don’t have any choice but to start up normally and then it just goes to a system hang and doesn’t budge. I’ll give the sudo command a go, seeing as it’s the worst case scenario. Guess I’d best hope for the best lol.

Have you set the CDROM drive as the first boot device in the BIOS ?

Ofcourse, I doubled checked. I’ve tried the sudo command, it seems to have partly fixed the problem. I can access files again from inside Ubuntu, which isn’t too bad. But I need to fix windows >.< (i just wish MS would corrupt themselves already).

Have you got another CD/DVD drive you could attach, then try the Win7 recovery disk ?


Attach the hard drive to another Vista/Win7 PC, and run chkdsk on it from there.

I do have another CD/DVD drive yeah, it’s in my desktop which is in bits atm, lol. I’m on a laptop atm, I don’t wanna be taking plastics and stuff, since the laptop belongs to my mother. Only borrowing it just now as my pc’s dead :L. I don’t have another Vista/Se7en PC to connect the harddrive atm, so I dunno :confused: