mouse speed

I have loaded v10 Unbuntu on my wife’s Dell Inspiron laptop and she loves it, its fast to boot and it works well
for her online shopping but she has one complaint that is that the mouse is far to sensitive often making it difficult
to click on an item.
I have been into the mouse set up and set everything to its slowest response but with little effect, can anyone
help, when the laptop boots up in windows xp its not a problem

OK, to “Decelerate” your mouse pointer in Ubuntu 10.xx

  1. Open a terminal, and enter:
xinput --list --short

you should get an output similar to:

mark@Mark:~$ xinput --list --short ⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] [b]⎜ ↳ ImExPS/2 Generic Explorer Mouse id=9 [slave pointer (2)][/b] ⎣ Virtual core keyboard id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ Power Button id=6 [slave keyboard (3)] ↳ Power Button id=7 [slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=8 [slave keyboard (3)]

You are looking for your mouse’s id= number… mine is 9 as highlighted in the above example.

  1. back in the terminal, enter
xinput --set-prop 9 "Device Accel Constant Deceleration" 5

(you will have to replace the 9 with whatever YOUR mouse’s id= number was.)

You may need to experiment with the last digit (5) of the above command… the higher the number, the slower the mouse.

HINT 1 - You can see the current “Device Accel Constant Deceleration” setting for your mouse with:

xinput --list-props 9

HINT 2 - You can also turn mouse acceleration OFF completely with:

xinput --set-prop 9 "Device Accel Velocity Scaling" 1

(again, you will have to change the 9 in both of the above commands to YOUR mouse’s id= number)

OK… once you’ve experimented, and found the ideal settings for your mouse acceleration, you are going to have to put them in a script and run it at system startup, or you will have to enter them manually every time you boot your system.

Let’s say the settings you’re happy with are:

xinput --set-prop 9 "Device Accel Constant Deceleration" 5 xinput --set-prop 9 "Device Accel Velocity Scaling" 1

Create a text file in your Home folder, and call it

gedit ~/

add the text:

xinput --set-prop 9 “Device Accel Constant Deceleration” 5
xinput --set-prop 9 “Device Accel Velocity Scaling” 1

(change the bottom 2 lines to whatever settings you were happy with… you can leave the last line out altogether if you don’t need acceleration turned OFF completely)

Save the file.

Make the script executable… open a terminal, and enter:

chmod +x ~/

Now, to run the script at startup…

Go to System>Preferences>Startup Applications

On the Startup Programs tab, click Add and enter the settings:

Name: Slower Mouse
Command: ~/
Comment: Script to slow mouse pointer

Click the Add button.


A bit long winded, but it works :wink:Or you could just try a different make/model of mouse. :slight_smile: