MP3 players

I want to get one eventually- can anyone tell me any brands that work with Linux please? I want to download music from my netbook/laptop to listen to. Cheers.

ANY MP3 player that presents itself to the system as a USB mass storage device … which is pretty much all of them except for Apple products.

OK, I wouldn’t be getting an ipod anyway!

Do you have a smart phone?
I don’t see the point of carrying an extra bit of tech around if you already have a music player in your pocket.
My phone has 80 gig of memory and I have over 2000 songs 100 books and loads of dxf’s and dwg’s PDF’s 350ish photos and still only used about 20% of the available capacity.
And most phones will present as mass storage.

Sent from my GT-I9505 using Tapatalk

Android don’t present as mass storage anymore (not since ICS, definately since JB)
One or two will give you the option, but most just give you MTP or PTP now :frowning:

Still, it’s definately the way forward, get a 32/64Gb SD card, and you’re sorted :slight_smile:

MTP devices will connect “out of the box” from 13.04 onwards … and MTP support can be added to 12.04

@chemical fan
My sgs4 presents as mtp but you have the option of using as camera which is in effect mass storage.
That said.
@ mark greaves
I am running peppermint 4. Can mtp support be added?

Sent from my GT-I9505 using Tapatalk

Peppermint 4 should have MTP out of the box … at least the respin does :slight_smile:

So if you’re using the original version and it didn’t have MTP support out of the box (can’t remember) just install mtpfs:

sudo apt-get install mtpfs

Do you know if it can be added to 10.04?


Should be able to, try:

sudo apt-get install mtpfs

Then connect your device and see how it goes…

Hopefully it’ll work, otherwise there could be some kind of kernel issue going on :frowning:

Edit: 10.04 isn’t supported anymore, you should really move to a new version!

If just installing mtpfs doesn’t work, try also installing mtp-tools:

sudo apt-get install mtp-tools

then read the link below.

I have a feeling that MTP works in 10.04, but it’s not automatic … you may have to add a udev rule and connect/disconnect manually:

Well, and please don’t take this the wrong way… but I am still receiving updates on the two “PC’s” running it !! so…er…? :slight_smile:

Thanks… I will try and install mtpfs, and see how I get on… might take a while, as, having only just moved to an android phone, I am still “arguing” with a certain Blackberry, and recovering MY stuff from it ::slight_smile:

Mark, thanks, and thanks for the link too :slight_smile:

Are you sure you’re getting updates ?

10.04 (Desktop) is most definitely “End Of Life”:

That said, the server edition isn’t EOL yet (April 2015), so you’ll probably be receiving updates that are common to both editions, but there will be NO new updates to the desktop editions kernel and most GUI applications.
In fact any updates common to both editions now stand a risk of breaking the desktop edition … if they need say the new kernel.

Definitely receiving updates - just had two small files downloaded and installed a few mins ago…

They may, as you say be related/common to the server edition - is there an update log I could look at to tell us ?

I tried 12.04 last year, but could not get it to work quickly enough to be usable. You may recall that core temperatures starting climbing, and this was the nail in the coffin of the original HDD…

Don’t ask my opinion of “unity”. ( I think part of the performance issue was that I was running in “classic” mode (?) ).

Log should be at /var/log/apt/history.log

I’m not trying to talk you into moving off 10.04 … if you’re happy there, stay … I was just making sure you understood where 10.04 is as far as support.

If you don’t like Unity, you could always try one of the other desktops …

Maybe try Peppermint or Lubuntu, or Xubuntu … or just stick with 10.04 until April/May when the new versions of those 3 will be released (they will all be long term support editions this time around).

Thanx Mark I’ll try that tomorrow.
I have to say, I loved 10.04 it was rock solid.
I had nothing but trouble after that though with constant freezes and kernel panics, that’s how I ended up moving to peppermint.

Sent from my GT-I9505 using Tapatalk

Pasted from history.log:-

Start-Date: 2014-02-04 15:15:58
Upgrade: libcurl3 (7.19.7-1ubuntu1.5, 7.19.7-1ubuntu1.6), libcurl3-gnutls (7.19.7-1ubuntu1.5, 7.19.7-1ubuntu1.6)
End-Date: 2014-02-04 15:16:00

Having moved back from Ubuntu 12, I intend staying with 10 as long as possible. I have tried other distro’s, but something doesn’t sit right with the nvidia graphics card in this laptop (HP G70). I haven’t the knowledge or time to resolve this at the mo…

Would be nice know what causes the graphics issues - I have some screen shots - I will attach one… This was on peppermint, but it was nothing to do with PM - another distro did something similar…

That screenshot is mad!
Does it behave the same way with different window managers (e.g. KDE)?

Gotta be driver/xorg related if you’ve tried different distro’s.

Probably easily solved by changing from (or updating) the nvidia drivers to open sourced or vice versa.

I agree though … that’s the weirdest graphics corruption I’ve ever seen :o

I haven’t tried KDE, but under ubuntu 12.04,using unity, the effect was similar - in classic mode it was more or less the same, but the whole system was slow beyond belief, and temps were high (80 C). IIRC, the Nvidia driver was version 173(RECOMMENDED). There is some info in a post here:-

I did try PM4, but as you can see from the screenshot, it was unusable, and despite some help, I simply didn’t have the time to sort it out, so went back to Ubuntu 10.04, for simplicity.