Mustek ScanExpress 1200 UB plus scanner install

I have a now elderly Mustek ScanExpress 1200 UB plus scanner. I want to install this in Fedora 11. I’ve done a fair amount of research and have discovered SANE does run this device. My problem is I am unfamiliar with Linux syntax and I am having problems with file permissions. What it would seem I need to do is change a line in the file gt68xx.conf. This I can’t do because file permissions say only the root can do this even though I am logged in as root. I need to remove a hash sign in front of the name of my scanner to get SANE to recognise it and stop complaining about an invalid argument. The file is in /etc/sane.d/gt68xx.conf. I can load this into the text editor and have changed it accordingly. But it refuses to save because of file permissions. I am sure this is pretty elementary, but I’ve tried everything to get Linux to accept the save. It won’t. Does anyone known how to set the file permissions? I’ve tried in Terminal chmod +s /etc/sane.d/gt68xx.conf and this did not report adversely - so what am I doing wrong? All help appreciated.

If your logged in as root you “should” be able to edit it… try this:

If you’re running the KDE desktop

kate /etc/sane.d/gt68xx.conf

now see if it will let you save the changes

Or if you’re running the Gnome desktop

gedit /etc/sane.d/gt68xx.conf

now see if it will let you save the changes

Thanks for the information. I’ve now edited the file and made some progress towards getting to a working scanner. I now need to install a file into a folder that SANE knows where to look. I’ve found the file online and it is saved to my ‘Downloads’ folder. So far so good. But these file permissions in Linux defeat me every time. I am on a network, but only because I have a notebook and a desktop and I want to sync the two. Linux seems to think I should not access any file even though I log in as the root user. I’ve right clicked and copied the file in ‘Downloads’. Now I need to paste into the folder /usr/share/sane/ Linux has greyed out the paste option when I right click again. I do have a Linux for Dummies book as required reading, but these file permissions are really not explained except in outline. Does anyone know how to make this cut and paste? And how do I get Linux to accept actions without recourse to these constant file permissions?

Firstly, DON’T log on as root unless you absolutely need to (learn to work with files from your user account… much safer), and secondly don’t change file or directory permissions unless you NEED to (which is nearly never) and understand the implications.
Logging on as root overrides Linux security… probably one of the reasons you chose Linux.
For a good explanation of why you shouldn’t log on as root, see here:
It covers much more than just viruses/permissions… it explains WHY Linux is much more secure.

OK, Lecture over :slight_smile:

OK, lets say your file is called and it’s saved in /home/meyellowbelly/Downloads

to copy it to /usr/share/sane/ you will need root access (as you do anywhere outside your home directory) so the copy command must be prefixed with sudo or you need to change to root with su (if sudo isn’t installed).

so the command would be either:

sudo cp /home/meyellowbelly/Downloads/ /usr/share/sane/

(if sudo is installed and you are a member of the sudo group)


cp /home/meyellowbelly/Downloads/ /usr/share/sane/

(if sudo isn’t installed or you’re not a member of the sudo group)

REMEMBER… Linux commands ARE case sensitive.

Or you could open your file manger as root, and then copy and paste as normal
I don’t know which Liinux distro or desktop you are using so can’t give an exact command, but I’m using Mint/Gnome so my file manager is nautilus… so the command for me to open nautilus with root access would be:

sudo nautilus

nautilus now opens with root access and I can copy and paste to anywhere.

If you're using the [b]KDE4[/b] desktop, your file manager is probably [b]dolphin[/b] so:
sudo dolphin



Or if you're using the [b]KDE3.x[/b] desktop, your file manager is probably [b]konqueror[/b] so:
sudo konqueror



Or you could create a “Launcher” (icon) on your desktop that always opens your file manager with root access.
see this posting:*linux/msg16132/#msg16132
obvoiusly you may need to change all “nautilus” instances to whatever your file manager is.

The Command: is the important bit :slight_smile:

These instructions are for the Gnome desktop, but I’d be surprised if KDE doesn’t have something similar.

Thanks again for the information. I’ve now moved the file to the directory I earlier indicated, but now I need to create a sub-directory and can’t for the same reason I experienced earlier in copying the file - file permissions. I’ve tried to create a launcher link and have done so - but it won’t work. It all seems the computer does not regard me as an administrator. It seems I am not in the sudoers file (wherever that might be located). (I’ve had this message in Terminal).

Here is what I get when in Terminal I type sudo:

[linux.wd@linux ~]$ sudo
usage: sudo -h | -K | -k | -L | -V
usage: sudo -v [-AknS] [-p prompt]
usage: sudo -l[l] [-AknS] [-g groupname|#gid] [-p prompt] [-U username] [-u
username|#uid] [-g groupname|#gid] [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C fd] [-g groupname|#gid] [-p
prompt] [-u username|#uid] [-g groupname|#gid] [VAR=value] [-i|-s]
usage: sudo -e [-AknS] [-r role] [-t type] [-C fd] [-g groupname|#gid] [-p
prompt] [-u username|#uid] file …
[linux.wd@linux ~]$

I really need to sort these file permissions because I can’t change any files outside of my home directory.

Can anyone please help?

Which Linux distro and desktop are you using?

You can’t type sudo on its own… it must be followed by a command


sudo su


sudo gedit


but if your user account isn’t in the sudo group you will have to either add your user to the group or use su from the command line to change to super user.

If you need to add your account to the sudo group

cp /etc/group /etc/group.backup
adduser username admin

change the username part of the last command to whatever your user account is called. (from your last posting it looks like your username is linux.wd)

Some success everyone - at least with the scanner. I now have it working in Fedora 11 (Gnome desktop). The SANE software supports my elderly peripheral, but requires a file I found on the Internet. This file has to be in a specified folder (which I have had to create) for my scanner to be supported. If anyone else out there is trying to get a Mustek ScanExpress 1200 UB Plus to work in Linux then it is supported by SANE, but you need to do this: search the Internet for the file sbfw.usb. When you find this create a folder gt68xx in /usr/share/sane. Copy the file you found on the Internet into this folder. Your scanner will then work. (Try this Internet site: SANE GT68xx Backend Homepage)

While my scanner is now working I am still struggling with permissions. I’ve been in System/Administration/users and groups. I’ve put myself in everywhere. Yet I still can’t cut and paste or use right click. I’ve tried the su command to make the entries (given in the earlier reply -many thanks again) , but I still find myself locked out of my own computer unless I use the command line (it’s been a while since I needed to do this). I am slowly getting up to speed in Terminal, but it is a tortuous process. I can understand the need for a genuine network to be bullet proofed, but my network is only for my use with a desktop and notebook (to keep in sync) and an elderly desktop (running Ubuntu 9) for backup when Windows messes up my HDD.

Thanks once again for your help.

if you are now in the sudo group… start you filemanager with the sudo command prefixed

sudo nautilus

or gksu (gksu must be installed)

gksu nautilus

or install nautilus-gksu (if your talking about the GNOME desktop and Nautilus file manger)… or create a launcher as previously described.

the nautilus-gksu package will allow you to right-click ANY folder and open it “As root” from within nautilus… you should then be able to copy and paste to your hearts content :wink:

nautilus-gksu package description: The gksu extension for nautilus allows you to open files with
administration privileges using the context menu when browsing your
files with nautilus.

Thanks for posting the mustek scanner instructions, may help others in the future :slight_smile:

Many thanks for your invaluable help. I’m using Fedora 11 and this does not seem to offer the Nautilus - gksu package, but I’ve found what I think is something similar - Beesu.

I’ve installed this and given it an initial try out and it does seem to do the job. I’m still having to run it from Terminal, but once there Nautilus is more right clickable than it was. But I still need to do some more setting up with it.

Many thanks for the information - I would never have found this without your help. Thanks once again.