My WiFi won't connect (Solved)

I switched the computer on this morning and the WiFi won’t connect.
I have a Virgin Media superhub.
The WiFi works ok in Windows on this computer

take care
Don W

What’s the output from:

sudo lshw -C network


iwlist scan




rfkill list

if the output from that last command says “yes” anywhere in the list, try running:

sudo rfkill unblock all

and see if that makes a difference.

Hi Mark,
The command lshw -C network gives
Sorry I will need to come back to this as this pile of xxxx won’t read/copy/paste etc.
I have attached the first 2 files

Hi Mark,
The other 2 files are

Can you please not attach files unless absolutely necessary (their content is not searchable) … better to post text output in the body of the posting, and if images to host them somewhere like

Sorry about that Mark.
I had to copy the files from the other computer to this one. :-[

OK, everything seems to be working properly …

Have you simply tried restarting your router and PC ?

Have you tried deleting your current wireless connection in networkmanager, then reconnecting ?

Hi Mark,
Sorry about that. :-[ I had to transfer the files from my Linux computer to the Win7 machine and nothing would go right.
I switched the Linux machine off and waited a couple of minutes. After switching on again, it tried to connect twice before the icon with the broken connection appeared. I switched it off, waited, switched it on and it reconnected first time.
I am now using the Linux machine. Many thanks. :wink:

weird :o

I switched the computer on yesterday afternoon as well, and I had to switch off, wait a while and switch on again before I was connected.
Is there something loose ? When I look in Menu>System Tools>Network I get on the
General tab Host Name ldwatson
DNS tab
Hosts tab has a list of IP Addresses and Aliases
All the information on these tabs is greyed out.

Hi Mark,
I switched on this computer after tea and I didn’t get an Internet connection.
It took 3 goes at switching on before I got connected.
Summat seems a bit flakey :frowning: Can this be fixed ?

Have you tried what I suggested above ?

I don’t know how to delete the current wireless connection in network manager and reconnecting :frowning:

OK, open a terminal and run:

gksudo nm-connection-editor

enter your password when prompted.

Click on your wireless connecton so it’s highlighted, theen click the “Delete” button.

Click the “Close” button.

Click the networkmanager icon by the clock … then in the list of available wireless networks, click on YOUR wireless network to connect.

When prompted, enter your wireless key.

Done :slight_smile:

Thanks Mark,
It is working ok at the moment.
I will mark it solved in the morning.
Thanks again

No problem … glad to hear it’s working :slight_smile:

Hi Mark,
Started ok this morning. Will mark topic solved.
Thanks again

You’re most welcome :slight_smile:

Same problem occurred this afternoon.
I was working on the computer when friends arrived. We had a cuppa and a choccy biscuit.
When I got back to the machine it had shut down and when I moved the mouse the login screen showed.
I logged in and the WiFi tried a couple of times to connect with no success.
I logged in and out 3 times before I got a connection.
Any clues ?

If this is only happening after the PC goes to sleep, next time it happens (with the wifi dead) can you post the output from:

nmcli nm

Then see if running this command brings networking back to life:

sudo service network-manager restart

If not, try running this command and tell us if wireless springs back to life

nmcli nm enable false ; nmcli nm enable true

If that doesn’t work can you tell us if a REBOOT (as opposed t a logout/login) re-enables wireless first time.