Hi guys! My brother sent me a Macbook Pro that he’s put Ubuntu on ( he doesn’t know which version for sure, but he thinks it’s the latest version). I am used to Peppermint so it took me a bit of looking around to find out how to add new software ( in Peppermint it’s via the software manager). it took less than 5 mins to install VLC. It all looks fine ( I have that on my Peppermint netbook) but I cannot figure out how to play a DVD from the external DVD player I have. I admit I had trouble figuring it out on the netbook when I first tried, and I cannot remember what I did to make it play, but it played great. I even had my big monitor connected so I had a big screen ( the netbook is teensy). This Macbook has quite a big screen so it’d be good if I could watch DVDs on it.

Is there another DVD player software I could install? VLC seems a bit tricky really.

Thanks in advance for any advice.

P.S My main laptop is my Chromebook, but of course it has no facility for external DVD players ( no codecs).

Hello Matilda - and welcome to the Forum.

VLC player is generally very good but if you are having problems with it you might like to try “MPV Media Player” which is available in the Software centre.
You can set the default video player in System-settings/Details/Default-applications. If you have difficulty doing that, just come back here.

By the way: Are you using Ubuntu’s default Unity Desktop (with the large icons down the left hand side)? If so you might prefer “Classic view” which is much easier to navigate. If you want to try it do ask.


Hello Keith, I have been on this forum since 2011. For some reason it changed my name when I logged in (I was “Melissa”) and have been a Linux user since then. I’ve had a few laptops/netbooks running on Linux. As I said, mostly on Peppermint. I used to get a lot of help from the late great Mark Greaves. My first Linux computer was a little Dell netbook on Ubuntu. I took it to a local Linux group and the chaps put Mint on it because the Ubuntu was an older one, so I haven’t used Ubuntu since then. I am not even sure what a default Unity Desktop is!

If you like I could take a photo of the desktop so you can see what my bro put on there.

I can’t see software centre on the Macbook. What I see is a folder called Unbuntu Software. To be honest with you Keith I cannot even remember how I managed to download VLC!

I also have another problem. My bro put Firefox as the browser, but I don’t like it. I want to put Chrome on it and delete Firerfox. I have tried to download Chrome; firstly by trying the software folder, but I couldn’t do it there.

I then went to Google Chrome for Ubuntu page and it downloaded a 62 bit folder to my downloads folder. The instructions said to double click and an install box would come up. The folder was there but double clicking then resulted in a circle going round endlessly but nothing else.

There was also some sudo commands one cpould try instead but putting them into the terminal resulted in it saying those commands were wrong, and then to try another one. When I put my password to log into my Macbook it said it was not the right one.

I am at a loss on what to do next!!!

P.S I think perhaps that it was my Chromebook that did something to my log in here because after being out all day in town, I powered up the Cheomebook and instead of instantly coming on as it always does, it went to a black screen and said it was “repairing” itself and after a few minutes it had wiped off all my folders! i had to then re set it up. I lost some files, but was able to recover some from “recent.” I didn’t have that many ( most of my folders and files are in Google Drive) but it was kinda spooky and annoying that the Chromebook just did what it wanted!

Oh I meant to add that in Peppermint to download a software it was using gthe package manager/software manager and pretty easy. Ubuntu seems a littletrickier, but hopefully with your help I’ll get to grips with it!

I have a netbook running on Peppermint that Mark Greaves put on for me.

Hi Melissa,

If you having problems with sudo (account login password incorrect) then either you are not member of sudo group
Test it by:

sudo whoami

enter your password, then it should say

If you get an error saying “user is not in the sudoers file”, it means that the user doesn’t have sudo privileges.

In that case you need the root password (I assume your brother set that up) to add yourselves to the sudoers.

Yes, it did say root when I did that SeZo. I think my brother would know I’d want to be able to use the terminal. :slight_smile:

How can I install Google Chrome ?

OK guys: I did search on the Ubuntu software file and the media player came up and I have installed it. I tried again with Google browser. It didn;'t show up; then I remembered that to install it on Peppermint it was called “Chromium.” I did find it and when I clicked install I got this message: Unable to install Chromium: status-code=409 kind=snap-change-conflict message=snap “chromium” has “instal snap” change in progress

I think that is trying to install a snap version.
To install from command line, open the Terminal and run this command:


run this command to install Chrome using the offline installer:

sudo dpkg -i google-chrome-stable_current_amd64.deb

If you get errors about any missing dependencies you can force install them

sudo apt -f install

Then launch the app

Forgot to add that you may need to install wget:

sudo apt install wget

Thanks SeZo. I’ll try that later. Got the MacBook off at the moment.

Thanks Sezo- got Chrome on the Macbook!