Need help with Ndiswrapper

Hi guys

I’ve installed the latest Linux Mint on an old Sony VAIO machine and it runs great, but am having trouble getting my Netgear WG111T Wireless Dongle to work. [But I’ve temporarily plugged in an ethernet cable so I’m able to download stuff if necessary]

I downloaded the drivers linked to from this SourceForge Wiki page, extracted them to my Documents folder, and used ndiswrapper to install athfmwdl.inf and netwgt11t.inf as instructed.

When I open ndiswrapper it now tells me I have two installed Windows Drivers: aathfmwdll Hardware present: Yes and netwg11t Hardware present: No.

I have absolutely no clue what to do next, but am pretty certain I still can’t access my WiFi.

A little help, please? :slight_smile:

Ok, before we go into trying to diagnose the current issue, based on your method I’m assuming you’ve not tried ndisgtk ?

If you go to the package manager (synaptic? I’m assuming Mint is the same as Ubuntu) click on the Search button, enter ndisgtk and then Search, it should return one result. Right click, select ‘mark for installation’, then hit ‘Apply’ on the toolbar.

This will install a new program in the menus … can you give that a try and see if it helps?

Mad Penguin is right, you need ndisgtk but this should be installed by default in Mint… Menu>Administration>Windows Wireless Drivers

You ONLY have to use the netwg11t.inf file, BUT the one in the ndis5 folder NOT the one in the main folder.

So open Menu>Administration>Windows Wireless Drivers, click Install New Driver browse to the netwg11t.inf file (the one inside the ndis5 directory), and click Install.

or try the latest drivers, which can be found here:
WG111T Software Version 1.2 98/2k/xp
WG111T Software Version 2.0 2k/xp/vista
WG111T Software Version 2.1 2k/xp/vista

Instructions here:

Thanks for the input. :slight_smile:

Okay, I installed WINE and followed those instructions, and the hardware now seems to be detected as the blue LED is flashing - a good sign!

However I’m not quite online yet. I was expecting some sort of “here is a list of all the wifi networks we could pick up” interface but haven’t been able to find anything like that. I tried manually adding the connection by clicking on the network icon and clicking ‘Edit Connections’ and manually inputting the network name and key and got a spinning ‘I am trying to connect’ icon, but no victory as of yet. :frowning:

I’m with SKY Broadband if that’s any help. Not sure what encryption/security they use.

Sky routers, by default use WPA2 encryption… if you single left-click the “Network Manager” icon (by clock) it usually displays detected networks.

You “may” find connecting easier if you change to WEP in the router, although you will then have to reconfigure ALL PC’s that use wireless to connect with the router.

It DOES say that WPA is supported in that driver though.

One other thing… if it asks for a “keyring” password… leave it blank, even if it complains… and make sure you tick the “Connect Automatically” and “Available to all Users” boxes. (if this is what you want)

I was in Islington (Holloway) a couple of weeks back and ended up having to wait in my car for a little while parked on a residential street. After discovering I’d forgotten my 3G Dongle, I idly thought I’d see if there were any local / open WiFi’s there were within range … (residential area, just off the Holloway road, not far from the prison)

Go on, guess how many overlapping networks? :stuck_out_tongue:

When you said you were in Holloway the other day… :slight_smile: … anyway, high population density, affluent area, so supposing some will be 802.11 “N” with a better range… 7 ??.. any open?

I’m pretty much in the “sticks”… small row of houses, middle of nowhere, and there’s 4 here, 2 of which have no security… AND as a matter of interest “Default” router log-in and passwords.
Kinda lucky, as my router died last night :slight_smile: … (note the IP change)… neighbour won’t mind and i’ve since asked permission, and locked down his wireless.


~ 20-25, although it was fluctuating a little … only two open!