Need help with Ubuntu in Asus x55u


I have a friend’s computer wich he gave it to me because it was too messed up… It had W7 on it and I formatted, try to do all over again but it still had some problems I did not know how to fix. Therefore since I started to use Linux (Ubuntu) on my laptop I also installed on his pc and completely removed windows 7.

ATM I have a current problem with wireless internet… I CAN NOT access internet via wireless… I had this problem in windows 7… I tried to install the drivers but it didn’t work… so now I guess I don’t have the driver installed… I’m not actually sure…

Also I am a BRAND NEW Linux user so I do not know a lot of things about this… But I am having some sort of “classes” about it…

Can anyone help me to make the wireless connection work? ( Asus X55U)

Thank you

Hi nubix and welcome to the forum.

First, can you edit the 17th word in your posting please :wink:

Then can you connect to your router with an ethernet cable, then open a terminal and post the output from these 3 commands

uname -a


lshw -C network


lspci -vnn | grep -i net

Be Aware, Linux commands ARE case sensitive, so that’s a capital C in the second command.

Sure, sorry for the bad language :stuck_out_tongue:

Yes I am connected through cable.

So, the output:

maa10@X55U:~$ uname -a
Linux X55U 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


maa10@X55U:~$ lshw -C network
WARNING: you should run this program as super-user.
description: Ethernet interface
product: AR8161 Gigabit Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:01:00.0
logical name: eth0
version: 10
serial: 08:60:6e:50:27:ad
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:46 memory:fea00000-fea3ffff ioport:e000(size=128)
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.


maa10@X55U:~$ lspci -vnn | grep -i net
01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Thanks for the edit :slight_smile:

Your wireless hardware isn’t being detected AT ALL by the system…

a) are you sure there is a wireless card present

b) is it internal or USB

c) if you’re sure it’s present and internal … is it disabled in the BIOS ? or possibly by a hardware switch ?

d) are you sure it’s not broken … eg. have you seen itk working in say Windows ?

That is the real problem because the laptop is not mine and I don’t really know what happened.

What I know is that my friend doesn’t know anything about computers but he had wireless connection before so I assume the wireless card is present and it is internal.
I don’t have much details about (or if) something happened. But Im pretty sure he did something that he did not intend or did not know…

I can check in BIOS if it’s disabled or not, but I’ve seen it working on W7 yeah, but when he gave it to me it wasn’t working. But before Linux I formatted the laptop with windows 7 and I tried to install the wireless driver and it didn’t work either.

I never opened this laptop so Im not 100% sure it isnt broken

If it didn’t work in Win7 either, and it’s not disabled in the BIOS, you’d have to assume the wireless card is dead.

It would have been handy to know if Windows detected the hardware or not (eg. if it was listed in device manager)

The only thing I know it’s that my friend had wireless connection for some times… then he just said that “it stopped working” then he delivered to me, and I couldn’t had wireless connection… I used the “fn” f2 wich turns on the wireless capability and nothing happened, I tried to troubleshoot and it was also a dead end… Didn’t work updating and instaling the driver again… so yeah its most likely dead… I guess

Is there anyway I could check if it is dead or not?

Only three ways to do that

a) install Windows, then look in device manager to see if the hardware is listed (even if it’s not working)


b) replace it with a known working adapter and see if it’s detected


c) remove the adapter and test it in another laptop

But at the moment the system isn’t seeing a wireless network adapter at all … so my guess would be that the wireless adapter died.
(it’s not just that the drivers aren’t loaded, it’s as if the wireless adapter isn’t present at all)

Alright, thank you for your help :slight_smile:

I will investigate the problem and see If i can solve it in anyway

You can delete this thread/post aswell

There is one other thing you can do…


dmesg > ~/Desktop/dmesg.txt

you’ll then find a file on your desktop called dmesg.txt

can you attach that to your next post … I’ll look through it for any signs that the kernel is seeing the wireless adapter but disabling it for some reason (I doubt ths is the case, but it can’t hurt to look).

There is nothing in the dmesg output that you wouldn’t want other to see.