Netgear wg111t

Yes Mark, will log back on brb

Ok I switched pc off, didn’t remove dongle and started up again in ubuntu.
Typed lsmod in before issuing other commands
result: villain@villain-pc:~$ lsmod
Module Size Used by
nls_iso8859_1 3249 1
nls_cp437 4919 1
vfat 8933 1
fat 47767 1 vfat
binfmt_misc 6587 1
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
vga16fb 11385 0
vgastate 8961 1 vga16fb
snd_ca0106 31531 2
snd_ac97_codec 100646 1 snd_ca0106
ac97_bus 1002 1 snd_ac97_codec
snd_seq_dummy 1338 0
snd_seq_oss 26722 0
snd_usb_audio 75765 1
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70694 4 snd_ca0106,snd_ac97_codec,snd_usb_audio,snd_pcm_oss
snd_usb_lib 15801 1 snd_usb_audio
snd_seq_midi 4557 0
snd_rawmidi 19056 3 snd_ca0106,snd_usb_lib,snd_seq_midi
snd_hwdep 5412 1 snd_usb_audio
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
radeon 675160 3
snd_timer 19098 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ttm 49943 1 radeon
drm_kms_helper 29297 1 radeon
snd 54180 18 snd_ca0106,snd_ac97_codec,snd_seq_oss,snd_usb_audio,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_hwdep,snd_seq,snd_timer,snd_seq_device
ndiswrapper 184677 0
ppdev 5259 0
drm 162409 5 radeon,ttm,drm_kms_helper
pwc 78244 0
soundcore 6620 1 snd
snd_page_alloc 7076 2 snd_ca0106,snd_pcm
k8temp 3056 0
videodev 34361 1 pwc
v4l1_compat 13251 1 videodev
agpgart 31724 2 ttm,drm
i2c_algo_bit 5028 1 radeon
parport_pc 25962 1
i2c_nforce2 5199 0
lp 7060 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
hid 67032 1 usbhid
usb_storage 39553 1
ohci1394 26950 0
forcedeth 49556 0
sata_nv 19376 0
pata_amd 8766 2
ieee1394 81181 1 ohci1394
floppy 53016 0

Then I typed in the command sudo modprobe -r ar5523 && sudo modprobe ar5523 and the keyring box opened so enterd pass and the dongle started and I was connected.

I will try those other commands you asked for and brb :slight_smile:

Ok Mark, after tyoing the first command I got nothing, it just did what it does without showing any added text.
The second cammand opened a gedit window named ndiswrapper.conf but noithing was in there.

Does this help ?

OK, don’t worry about ndiswrapper, the output from those commands tells you the earlier ndiswrapper setting were removed… and it doesn’t appear to be getting loaded until the ar5523 drivers are loaded, so I reckon it’s a dependency of one of the 3 modules ar5523, mac80211, or cfg80211

Also see the edits to the above posting -
I’ve included the bit about adding thos 3 modules to the /etc/modules file.

It might be worth you keeping this URL for future reference :slight_smile:

Having tried numerous methods over several months to make a Netgear WG111T work in ubuntu, all to No avail, I can confirm that the instructions in the above post SOLVED my issue. Many thanks for taking the time to set this solution out in such clear and concise terms.

Netgear WG111T
Acer AMD Turionx2 aspire 5535
ubuntu 64bit 10.4 lucid 2.6.32-28-generic

Well done… cheers

For those of you that were having problems with the module assistant not building the driver module from the ar5523-source package in 10.10 (Maverick Meerkat), or 9.10 (Karmic Koala)…
(ie. the sudo m-a a-i ar5523-source command failed)

Modified instructions can now be found here:

Now updated with ar5523-source packages for Karmic, Lucid and Maverick.

or you can just add the PPA repo mentioned in the post.

Don’t panic if you installed the wrong one… you can either just install the correct version, which will update the old version, or remove the old version first from within the Ubuntu Software Centre, by searching for ar5523-source, clicking it, then selecting “Remove”.

using a WG111Tv1
according to the instructions at this post
I am unable to even use a keyboard (Alt+PrintScreen+k) to logout after I plug that adapter in, computer completely freezes up, and the CAPSLOCK indicator light as well as some other light blinks. When I force a shutdown by holding down the power button I am able to shutdown. Then I wait a few seconds (counting in my head at this time), push the power button to begin the boot up process… I get a checking disk 1 of 2 ( 0%…100%), then the computer reboots again. I get to a login screen again, but keyboard is not responding. Hard reset again. Same. Unplug the adapter. Restart. Get to a login, keyboard works YAY!!, plug the adapter in, FREEZE up again.
Rinse and repeat.

Either the instructions are bad, the driver is bad, it doesn’t work for mexicans, or all of the previous.

I used ndiswrapper with ndis5 driver… ¡Viola!
Although a simple restart NO WIRELESS. Cold reboot I get WIRELESS connection.

I will try with Debian instructions from the ar5523 - Debian Wiki using Debian squeeze in XFCE after I move the desktop 20m closer to the router for a cat5 to reach.

Thanks for the feedback, but which of the 3 drivers (ar5523-source*) did you try, and with which distro/version/kernel revision ? … this info would help other people in the future, and may aid in finding a resolution.

It’s pointless ‘just’ saying the instructions or drivers are “bad”, as they have worked for other people, BUT, AFAIK (so far) the people who have reported success where all using Lucid Lynx and the corresponding driver (as I’ve only just updated the page with links to the Karmic and Maverick versions)… so feedback on the drivers for Karmic and Maverick would be helpful.

Following the instructions at the Debian link, should work, at least on Debian based distros, and probably others as you will be compiling from source.

Feedback from anyone trying the above drivers on Ubuntu 9.10 (Karmic) and Ubuntu 10.10 (Maverick) would be most welcome… as would feedback from anyone trying compiling their own from the Debian link… but can you please let us know your Distro/Version/Kernel revision, and which of the drivers you tried.

Indeed, it would also be helpful to know who got the Windows drivers to work with ndiswrapper and how well they worked… again with as much info about distro/version/kernel revision as possible.

Thanks in advance.


Distro Ubuntu Maverick i386
Kernel: Linux 2.6.35-28-generic

I tried the ar5523, and have computer freeze.

Now using ndiswrapper, it works most of the time.

       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:18:4d:35:27:9c
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+netwg11t driverversion=1.56+NETGEAR,01/07/2005, ip= link=yes multicast=yes wireless=IEEE 802.11g

I used the debian instructions and that panned out quite well on the Debian Squeeze Box, although if I unplug, then plug back in, I get a lockup at the keyring… using Debian with Gnome 2.33 Desktop as well. Although it should not matter the operating system and/or desktop environment… This is a hardware & drivers issue and NETGEAR will never get another penny from me if they don’t get LINUX printed on the box.
Two adapters one Linksys, one Netgear both fail to work like they do on WinBLOWS. I would rather have a stable wireless connection with a heap of security using my favorite LINUX distro, but the WG111T is simply not working.

Thanks for the info, I haven’t got a WG111T so can’t test them myself, so it’s handy to hear from people who have tried them.

I agree about Netgear’s Linux support.

Debian 6 (Squeeze) uses the 2.6.32 kernel, as does Lucid, so I wonder if it is just an issue with 2.6.35

Did you try following the instructions on the Debian page and compile the drivers yourself in Maverick ? … I just tried it, and they compile, though I can’t test them… the only things I needed to change from the Debian instructions were - I needed to install the quilt package… available in the main Ubuntu repo, apply the kcompat-2.6.35.patch so module assistant could build them for the 2.6.35 kernel, and change where the uath-ar5523.bin firmware file got moved to… so I just modified the Debian instructions to:

sudo apt-get install build-essential subversion wget wireless-tools quilt
svn co svn:// ar5523
tar xf ar5523.tgz ar5523/uath-ar5523.bin --strip 1
cd ar5523
patch < debian/patches/kcompat-2.6.35.patch
dpkg-buildpackage -us -uc
sudo dpkg -i ../ar5523-source*deb
sudo m-a a-i ar5523
sudo mv ../uath-ar5523.bin /lib/firmware

then modprobe the driver:

sudo modprobe ar5523

and add the line:


to /etc/modules if needed.
(ie. if they work, but don’t get loaded automatically at boot up)

It still may not work, as I said I can’t test it, and at a guess, that’s probably what the guy who packaged the drivers for Maverick did anyway, but he may have built them for an earlier kernel revision… give it a go if you wish… if you do, can you let us know if they work please.

Anyway, glad you got them working with nndiswrapper :slight_smile:

Thanks again for the feedback.

Hi guys,
Found this thread via search engine, could you please tell me if these install instructions are good for Ubuntu 12.04 LTS ? If so, should I just use the latest version of the package, ie: For 10.10 (Maverick Meerkat) ?

Thank you

Sorry, I can’t say for sure … but if I were going to try it, I’d get the latest ar5523-source (for 12.04 Precise) from here:

Here’s the actual PPA if you’re interested:

As listed here:

Giving that a shot now, many thanks Mark.

No worries … let us know how you get on, or if you need help … oh, and welcome to the forum :slight_smile:

Thanks for the welcome.
The above didn’t work I’m afraid, I still have no wireless. I’ve tried inserting the USB dongle prior to boot and while logged in but nothing.

If makes any sense at all; when I tried previously to install it using ndiswrapper, in ‘Windows Wireless Drivers’ it appears as:
Hardware present: Yes’ when I tried using v.2.1 of the Netgear software (wg111t.inf)
Hardware present: No’ when I tried using v.1.2 (netwg11t.inf).
Just something I noticed.

I should also mention that this is a fresh install with nothing to loose, so even if a reinstall (or anything else not-so-drastic) is necessary I’m happy to give it a try. :slight_smile:


OK, let’s start from the beginning :slight_smile:

Can you open a terminal and send the output from:

sudo lshw -C network





and just in case

rfkill list



sudo lshw -C network

description: Ethernet interface
product: 82566DM Gigabit Network Connection
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 02
serial: 00:19:bb:db:24:00
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiatio n
configuration: autonegotiatio n=on broadcast=yes driver=e1000e driverversion=1.5.1-k firmware=1.1-0 latency=0 link=no multicast=yes port=twisted pair
resources: irq:41 memory:f0500000-f051ffff memory:f0524000-f0524fff ioport:1000(size=32)

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 040b:2000 Weltrend Semiconductor
Bus 004 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 003: ID 1516:8628 CompUSA Pen Drive
Bus 001 Device 004: ID 1385:4251 Netgear, Inc WG111T (no firmware)

Module Size Used by
uas 17699 0
usb_storage 39646 1
dm_crypt 22528 1
bnep 17830 2
rfcomm 38139 0
bluetooth 158438 10 bnep,rfcomm
parport_pc 32114 0
ppdev 12849 0
snd_hda_codec_ realtek 174055 1
snd_hda_intel 32765 3
snd_hda_codec 109562 2 snd_hda_codec_ realtek,snd_hda_intel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 80845 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25424 1 snd_seq_midi
snd_seq_midi_e vent 14475 1 snd_seq_midi
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28931 2 snd_pcm,snd_seq
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 62064 15 snd_hda_codec_ realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 14635 1 snd
snd_page_alloc 14108 2 snd_hda_intel,snd_pcm
hp_wmi 13652 0
mei 36570 0
sparse_keymap 13658 1 hp_wmi
psmouse 72846 0
serio_raw 13027 0
mac_hid 13077 0
ndiswrapper 192268 0
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
i915 414603 3
usbhid 41906 0
hid 77367 1 usbhid
floppy 60310 0
drm_kms_helper 45466 1 i915
drm 197692 4 i915,drm_kms_helper
wmi 18744 1 hp_wmi
e1000e 140005 0
i2c_algo_bit 13199 1 i915
video 19068 1 i915

rfkill list

eth0 Link encap:Ethernet HWaddr 00:19:bb:db:24:00
RX packets:56 errors:0 dropped:0 overruns:0 frame:0
TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7734 (7.7 KB) TX bytes:14460 (14.4 KB)
Interrupt:19 Memory:f0500000-f0520000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:97 errors:0 dropped:0 overruns:0 frame:0
TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6464 (6.4 KB) TX bytes:6464 (6.4 KB)

Thanks for helping Mark

OK, with the gtk ndiswrapper (ndiskgtk) … and from the 1.2 Windows drivers … try adding both netwg11t.inf AND athfmwdl.inf at the same time (as in the pic below)

does netwg11t.inf say the hardware is present now ? (you may have to unplug/replug the WG111T)

If you’ve lost the 1.2 Windows drivers, you can get them from here:

Ok the system wasn’t too happy about my doing that as it froze up on the second file when I clicked ‘install’. However, I logged out and back in again and when I checked, the drivers say the opposite as in your image:
athfmwdl: Hardware present: Yes
netwg11t: Hardware present: No

Odd … what’s the output from:

sudo lshw -C network

now ?

Also send the output from:

uname -srp