Netgear wg111t

Hello, first post for me, hopefully get myself onto linux finally.
I have loaded mint and then ubuntu , the latest version but I cannot seem to connect via my wireless netgear dongle.
I have been trying for a few days now, have looked at support everywhere I can think of, and have followed certain instructions I have come across but to no avail.
I really want to start using Linux so I am thinking , would it be better to install a new linux compatable wireless dongle and if so can anyone recommend one that will work.

Thanks in advance



IMPORTANT notice -

For future readers… DO NOT use ndiswrapper as stated in this post… go to this posting:


for the correct procedure for installing the “Linux native” drivers for a Netgear WG111T USB wireless adapter in Ubuntu 9.10 (Karmic), Ubuntu 10.04 (Lucid) or 10.10 (Maverick):

[End Edit]

Have you tried loading the Windows drivers with ndiswrapper ?

Plug your PC into your router with an ethernet cable… Open a terminal, and enter:

sudo apt-get install ndisgtk

hit enter, and your password when asked.

When it’s finished installing ndisgtk and you’re back at a $ prompt…

Follow the instructions here (from step 4)

or here:
Most people seem to say use the 1.2 drivers which you can get from here:

Thank you very much, I shall attempt it ASAP.


Better Instructions for ndiswrapper

  1. Connect your PC to your router with an ethernet cable (so you have an active internet connection)

  2. run this command in a terminal:

sudo apt-get install ndisgtk

hit enter, and enter your password when asked.

  1. got to here:
    and download the file to your desktop.

  2. right-click on the file and select “Extract here” (you should now have a directory called WG111T_re1.2_rc1 on your desktop)

  3. go to System >Administration>Windows Wireless Drivers

  4. when the “Windows Wireless Drivers” application starts… click “Install New Driver”… in “Location:” navigate to the ndis5 directory (that’s contained inside the WG111T_re1.2_rc1 directory on your desktop), and select the netwg11t.inf file… click “Open”… click “Install”

  5. click the “Configure Network” button… then the “Wireless” tab… then “Add”

8.) enter your wireless settings.

BE SURE to navigate to the ndis5 directory for the netwg11t.inf file, as there are 2 of them… you MUST use the one on the ndis5 directory.

Hello again.
I am at the editing wireless connection 1 screen.
Mode drop down menu has infrastructure in there at the moment
Device MAC address
Cloned MAC address
MTU: automatic

I have no real idea as to what to enter in these boxes.

Is there somewhere I can get this information from ?



Leave all those as they are except for SSID… this is the station identifier of your router.
(or Service Set IDentifier… if you want to be exact :wink: )

Before trying to find this out… try this:

The ssid in my netgear is ThomsonWireless :slight_smile:

I have got to the point where I feel I am being a pest.
I have clicked on the internet icon next to the clock but it isn’t showing a preferred wireless network to connect to.
The Wired network is greyed out. I can see the auto etho and it says connected. I can see a disconnect option and a VPN connections tag.
THats all.
My netgear dongle is not Flashing either, so I reckon something is still amiss with this.

I have tried to go down this route several times and still come up against a brick wall.
Maybe I should stop wasting my time and yours and but a compatable wireless card.
But I really want to solve this, but I feel awkward keep asking for more help. I do appreciate your time.


No need to feel awkward… help is what we’re here for… if we didn’t enjoy helping, we wouldn’t do it :wink:

I could do with the output from a couple of commands:



sudo lshw -C network

(remember Linux command ARE case sensitive… so that’s an upper case C)

the reason I ask is because there seems to be some confusion as to which chip the WG111T uses.
(depending on the adapter version, it could be a realtek, an atheros, or a prism chip)

obviously, run these commands with the WG111T plugged in.

I think we are getting there :slight_smile:

Well after a lot of shennanigans and down to a lot of effort from Mark I have eventually been able to connect wirelessly on ubuntu :slight_smile:
We have a few little things to iron out but I would like to thank Mark for his patience and valuable time.


I’ll be posting the procedure for getting a Netgear WG111T wireless card working, as soon as I get time to type it up, and work out the last 2 little issues.

  1. Reload the drivers automatically after a reboot… normally easy, but this ties in with…
  2. work out why the drivers (when modprobe(d) )won’t work after a reboot, unless you unplug the device and reinsert it.

Anyone know of a way of restarting a USB device without unplugging it ?

Ok thanks Mark, will await instruction :slight_smile:


OK, the procedure for installing and using “Linux native” drivers for Netgear WG111T USB wireless adapter in Ubuntu 9.10 (Karmic Koala), 10.04 (Lucid Lynx) and 10.10 (Maverick Meerkat)…

Open a terminal and type:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install build-essential linux-headers-generic module-assistant

Hit Enter after each line, and enter your password when asked.

Download ONE of the following packages:-
(or add this PPA repo - PPA for logari81 : logari81 then install ar5523-source from your package manager)

For 9.10 (Karmic Koala):

For 10.04 (Lucid Lynx):

For 10.10 (Maverick Meerkat):

Double-click the downloaded package to install it.

Back in a terminal, type:

sudo m-a a-i ar5523-source
tar xf ar5523.tgz ar5523/uath-ar5523.bin --strip 1
sudo mv uath-ar5523.bin /lib/firmware

Hit Enter after each line, and enter your password when asked.

now you need to add 3 lines to /etc/modules so open a terminal, and enter:

sudo gedit /etc/modules

and add these 3 lines to the bottom of the file:


Save and exit.


[End EDIT]

The driver is now installed and should “just work”, so configure your connection in NetworkManager… if you have any issues with it, read on…

[EDIT 2]
The “Additional Info” section (below) shouldn’t be needed now, as after adding the 3 lines to /etc/modules the drivers should survive a reboot… but I’ll leave the section intact for clarity.
[End EDIT 2]

Additional Info - At the moment the driver seems to work fine, BUT requires a certain amount of work on your part…

  1. Don’t boot with the WG111T plugged in… wait till the system has booted, insert the WG111T, then in a terminal enter:
sudo modprobe ar5523

wireless should now work.

  1. If you DO boot with the WG111T plugged in… unplug it, re-insert it, then in a terminal enter:
sudo modprobe ar5523

wireless should now work.

  1. If you’ve booted with the WG111T plugged in, and run the “sudo modprobe ar5523” command without unplugging and re-inserting first… you’ll find wireless doesn’t work, but DO NOT just unplug it, your system may freeze… follow this sequence -

a) remove the ar5523 driver module by opening a terminal and entering:

sudo modprobe -r ar5523

b) now it’s safe to unplug the device and re-insert it… so do it :slight_smile:

c) now re-load the ar5523 driver module by opening a terminal and entering:

sudo modprobe ar5523

wireless should now work.

This isn’t an ideal situation, but it will get your WG111T working… when I find a better way of loading/unloading the driver module, and overcome the need to unplug/replug the device… I’ll post them here. (See Edits above)

It would be easy to script if it wasn’t for the need to unplug/replug the WG111T (USB) device, so if anyone knows how to “restart” a USB wireless device without unplugging, I would appreciate your input.

See here:

Much appreciated Mark.
Thank you

Hello. I haven’t had to unplug my netgear wg111t the last few times I have started ubuntu. I do enter the command in the terminal and it works.


Which command are you running?

Sorry am on windows at the moment and cant get the actual command, it’s the one you gave me to unload and then relaod the drivers. The one with the && in.
Three tikmes now I haven’t had to unplug the dongle :slight_smile:


Just as a matter of interest can you boot the PC with the WG111T plugged in, but before you run the “sudo modprobe -r ar5523 && sudo modprobe ar5523” command, can you run this:


and post the results.

I’m trying to work out why the module needs removing first.

Hello Mark, if I just do a restart without a reboot I actually cannot connect, but from a clean reboot I can connect without removing the dongle.
Is this what you require ?

villain@villain-pc:~$ sudo modprobe -r ar5523 && sudo modprobe ar5523
[sudo] password for villain:
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
villain@villain-pc:~$ lsmod
Module Size Used by
aes_i586 7268 1
aes_generic 26863 1 aes_i586
arc4 1153 2
ar5523 14641 0
mac80211 205402 1 ar5523
cfg80211 126528 2 ar5523,mac80211
binfmt_misc 6587 1
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
vga16fb 11385 0
vgastate 8961 1 vga16fb
snd_usb_audio 75765 1
snd_ca0106 31531 2
snd_pcm_oss 35308 0
snd_ac97_codec 100646 1 snd_ca0106
ac97_bus 1002 1 snd_ac97_codec
snd_mixer_oss 13746 1 snd_pcm_oss
snd_seq_dummy 1338 0
snd_pcm 70694 4 snd_usb_audio,snd_ca0106,snd_pcm_oss,snd_ac97_codec
snd_seq_oss 26722 0
snd_usb_lib 15801 1 snd_usb_audio
snd_hwdep 5412 1 snd_usb_audio
snd_seq_midi 4557 0
snd_rawmidi 19056 3 snd_ca0106,snd_usb_lib,snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
radeon 675160 3
snd_timer 19098 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ttm 49943 1 radeon
ndiswrapper 184677 0
drm_kms_helper 29297 1 radeon
snd 54180 18 snd_usb_audio,snd_ca0106,snd_pcm_oss,snd_ac97_codec,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_hwdep,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm 162409 5 radeon,ttm,drm_kms_helper
ppdev 5259 0
pwc 78244 0
agpgart 31724 2 ttm,drm
i2c_algo_bit 5028 1 radeon
k8temp 3056 0
soundcore 6620 1 snd
snd_page_alloc 7076 2 snd_ca0106,snd_pcm
videodev 34361 1 pwc
v4l1_compat 13251 1 videodev
parport_pc 25962 1
i2c_nforce2 5199 0
lp 7060 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
hid 67032 1 usbhid
ohci1394 26950 0
ieee1394 81181 1 ohci1394
floppy 53016 0
pata_amd 8766 2
sata_nv 19376 0
forcedeth 49556 0

Couple of things…

a) I needed you to run lsmod BEFORE loading the module with the modprobe command… I wanted to know if it was getting loaded automatically at boot time.

b) Why is ndiswrapper getting loaded… I thought we’d removed the drivers from “Windows Wireless Drivers”, so that may need fixing.

Can you post the output from:

ls /etc/ndiswrapper

and the contents of the /etc/modprobe.d/ndiswrapper.conf file

gedit /etc/modprobe.d/ndiswrapper.conf

If both drivers are getting loaded, this might explain the drivers instability.