Network manager icon missing in Ubuntu 18.04

ASUSTeK P6-P5G41E running Ubuntu 18.04

This machine doesn’t have a wireless card so before donating it I bought a USB wireless adapter (Bonest USB 3.0 ) as it mentioned Linux in the blurb. I ignored the installation disk and plugged it in with no response from the system, which surprised me. Indeed, the network manager told me that no dongle was detected.
Next I tried installing the Linux software from the disk but the extract command resulted in a message that I didn’t have sufficient privileges to do the extraction. So I abandoned that to return the dongle to Amazon.
At this point I noticed that the wireless manager icon had disappeared from the tray at top right. Hmm! I plugged in a very old, spare USB wireless adapter which connected me immediately, but still no icon.
Looking on-line for possible solutions, I tried the following with no success:

keith@asus:~$ sudo service network-manager stop
keith@asus:~$ sudo rm /var/lib/NetworkManager/NetworkManager.state
keith@asus:~$ sudo service network-manager start

keith@asus:~$ killall unity-panel-service
unity-panel-service: no process found

keith@asus:~$ sudo apt-get install indicator-applet-complete
Reading package lists… Done
Building dependency tree
Reading state information… Done
indicator-applet-complete is already the newest version (12.10.2+17.10.20170425- 0ubuntu1).
indicator-applet-complete set to manually installed.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

keith@asus:~$ sudo apt-get install --reinstall network-manager network-manager-gnome

Not having the icon is no real problem as I can always get to the network manager via the menus but it’s a nuisance if I am giving the machine to a friend and I would be grateful for advice.

does running


make the panel applet appear (as long as the terminal stays open) ?

Perfect! And it remains even when the terminal is closed.
You’re a star!