Networked Canon Pixma MG3250 Printer

Ok . . . well new printer, first wireless one I’ve owned and only the second I’ve ever used on linux. . . . so the derp is strong …

I’ve had a ‘trying day’ as I’d put it, but got it working/printing via USB, that’s all good, scanner I can’t get working at the moment, but after much head scratching I got it ‘live’ and working on my virgin superhub and I have an IP of i can see it I can log into it but how the hell do I print from it from the laptop downstairs?
I’ve wracked my brains and it’s late so I’ve given up for today - I’m thinking it’s just some permission somewhere but even after getting a successful home network working via ssh this has got me stumped lol … answers on a postcard please . . . and I’ll come back after a sleep :slight_smile:

Hi daveinuk

Hope this helps


First of all it would be a VERY good idea to give your printer a static IP address (and remove that IP address from your DHCP pool) otherwise when your printer gets a different IP it will likely stop working.

Anyway, for the Printer driver…

Create a folder on your desktop called canon-mg3250

download these 2 files into it

MG3200 series IJ Printer Driver Ver. 3.80 for Linux (debian Packagearchive)

MG3200 series ScanGear MP Ver. 2.00 for Linux (debian Packagearchive)

Now open a terminal and run:

sudo apt-get install libtiff4


cd ~/Desktop/canon-mg3250


tar xvf cnijfilter-mg3200series-3.80-1-deb.tar.gz


tar xvf scangearmp-mg3200series-2.00-1-deb.tar.gz


cd ~/Desktop/canon-mg3250/cnijfilter-mg3200series-3.80-1-deb



You will be prompted to make sure your printer is switched ON and connected to your router, then to hit enter to continue

then enter “2” for “Network” and press enter

It should search and find your printer.

Then follow the on screen instructions.

OK, that’s the printer drivers loaded…

Now for the scanner…

back in a terminal run:

cd ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb



and follow any onscreen instructions.

When finished, see if “Simple Scan” can find your scanner … or install xsane:

sudo apt-get install xsane

and look for XSane in your menu’s

would be a VERY good idea to give your printer a static IP address
I'll come back to that,

Mark, should I remove the packages I’ve dabbled with already before starting this? I found and installed these tinkering and trying to get it going -
cnijfilter-mg3200series-3.80-1-deb.tar.gz and scangearmp-mg3200series-2.00-1-deb.tar.gz

They show up in synaptic so if I need to uninstall them I will.

Edit: they’re the same packages I downloaded. . .

How did you install them previously ?

Mark I downloaded the files from canons site and when i opened them I chose the .deb packages and installed them that way, I must have missed something though… right, I’m up to here . . . . for the record:

dave@dave ~ $ sudo apt-get install libtiff4
[sudo] password for dave: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libtiff4 is already the newest version.
libtiff4 set to manually installed.
The following packages were automatically installed and are no longer required:
  libmotif-common libxm4
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dave@dave ~ $ cd ~/Desktop/canon-mg3250
dave@dave ~/Desktop/canon-mg3250 $ tar xvf cnijfilter-mg3200series-3.80-1-deb.tar.gz
dave@dave ~/Desktop/canon-mg3250 $ tar xvf scangearmp-mg3200series-2.00-1-deb.tar.gz
dave@dave ~/Desktop/canon-mg3250 $ cd ~/Desktop/canon-mg3250/cnijfilter-mg3200series-3.80-1-deb
dave@dave ~/Desktop/canon-mg3250/cnijfilter-mg3200series-3.80-1-deb $ ./

Canon Inkjet Printer Driver
Version 3.80
Copyright CANON INC. 2001-2012
All Rights Reserved.

Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.80-1_amd64.deb
Selecting previously unselected package cnijfilter-common.
(Reading database ... 184603 files and directories currently installed.)
Unpacking cnijfilter-common (from .../cnijfilter-common_3.80-1_amd64.deb) ...
Setting up cnijfilter-common (3.80-1) ...
Processing triggers for libc-bin ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg3200series_3.80-1_amd64.deb
Selecting previously unselected package cnijfilter-mg3200series.
(Reading database ... 184621 files and directories currently installed.)
Unpacking cnijfilter-mg3200series (from .../cnijfilter-mg3200series_3.80-1_amd64.deb) ...
Setting up cnijfilter-mg3200series (3.80-1) ...
Processing triggers for libc-bin ...

#  Register Printer
Next, register the printer to the computer.
Connect the printer, and then turn on the power.
To use the printer on the network, connect the printer to the network.
When the printer is ready, press the Enter key.

#  Connection Method
 1) USB
 2) Network
Select the connection method.[1]2

Searching for printers...

#  Select Printer
Select the printer.
If the printer you want to use is not listed, select Update [0] to search again.
To cancel the process, enter [Q].
 0) Update
Target printers detected (MAC address  IP address)
1) Canon MG3200 series (18-0C-AC-F8-5F-B8
Currently selected:[1] Canon MG3200 series (18-0C-AC-F8-5F-B8
Enter the value. [1]1

#  Register Printer
Enter the printer name.[MG3200LAN]Dave-Printer
Command executed = sudo /usr/sbin/lpadmin -p Dave-Printer -m canonmg3200.ppd -v cnijnet:/18-0C-AC-F8-5F-B8 -E

#  Set as Default Printer
Do you want to set this printer as the default printer?
Enter [y] for Yes or [n] for No.[y]y

Installation has been completed.
Printer Name : Dave-Printer
Select this printer name for printing.
dave@dave ~/Desktop/canon-mg3250/cnijfilter-mg3200series-3.80-1-deb $ cd ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb
dave@dave ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb $ ./

ScanGear MP
Version 2.00
Copyright CANON INC. 2007-2012
All Rights Reserved.

Command executed = sudo dpkg -iG ./packages/scangearmp-common_2.00-1_amd64.deb
Selecting previously unselected package scangearmp-common.
(Reading database ... 184812 files and directories currently installed.)
Unpacking scangearmp-common (from .../scangearmp-common_2.00-1_amd64.deb) ...
Setting up scangearmp-common (2.00-1) ...
Processing triggers for libc-bin ...
Command executed = sudo dpkg -iG ./packages/scangearmp-mg3200series_2.00-1_amd64.deb
Selecting previously unselected package scangearmp-mg3200series.
(Reading database ... 184857 files and directories currently installed.)
Unpacking scangearmp-mg3200series (from .../scangearmp-mg3200series_2.00-1_amd64.deb) ...
Setting up scangearmp-mg3200series (2.00-1) ...
Processing triggers for libc-bin ...
Installation has been completed.
dave@dave ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb $ sudo apt-get install xsane
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libmotif-common libxm4
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
Suggested packages:
  hylafax-client mgetty-fax gv gocr
The following NEW packages will be installed
  xsane xsane-common
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,162 kB of archives.
After this operation, 5,575 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 saucy/universe xsane-common all 0.998-5ubuntu1 [1,850 kB]
Get:2 saucy/universe xsane amd64 0.998-5ubuntu1 [311 kB]
Fetched 2,162 kB in 0s (3,283 kB/s)
Selecting previously unselected package xsane-common.
(Reading database ... 184871 files and directories currently installed.)
Unpacking xsane-common (from .../xsane-common_0.998-5ubuntu1_all.deb) ...
Selecting previously unselected package xsane.
Unpacking xsane (from .../xsane_0.998-5ubuntu1_amd64.deb) ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Setting up xsane-common (0.998-5ubuntu1) ...
Setting up xsane (0.998-5ubuntu1) ...
dave@dave ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb $ 

Graeme, that’s me on the virgin forum, I don’t normally post there but I made an exception last night out of desperation lol. . . .

Anywhooo’s My printer comes up in the menu as it did before, I actually have 3 listed, no big deal, xsane shows as does simple scan, neither works and appears to think I don’t have a scanner attached, i do, via USB.

I now gather I need to install those same software packages for the printer on the laptop, I didn’t know that, thought it did it solely via the network, that’ll be the starting point of why that wouldn’t work then . . . :expressionless:

Hi dave

I think the best thing would be for you to follow Marks instructions meantime, following the instructions on the link I posted might just confuse the situation further

I didn’t realise that was your post on the Virgin site when I posted the link so obviously it wasn’t much help I’m sorry

Good luck


I am doing graeme, I’ll pop back this afternoon, gotta go out and I have an easy enough time confusing myself so I’m trying his methods by the book lol ::slight_smile:

First of all … ANY of this will most likely be worthless unless you give the printer a static IP FIRST

After giving it a static IP and making sure that IP is NOT in the routers DHCP pool … delete all printers, uninstall the .deb’s you manually installed, and run again.

forget the scanner … we’ll get too that later … printer first.


Why is everyone suddenly getting Canon Printers, are they having a sale or sommat ? … if you want an easy setup for your AiO in Linux, get an HP

Mark, I already uninstalled the packages I’d downloaded, so I’m gathering I won’t need to go through most of the above?

How do I assign a static IP address? Log into the printer ? I’ve never done that before but i can see the address it has now and the facility to change the details here : Is this the right place?

Get IPv4 address automatically is checked.

Use following IPv4 address:
IPv4 Address:
IPv4 Subnet Mask:
IPv4 Default Gateway:

In the routers DCHP part i can see this:

	Check to enable or uncheck to disable DHCP
IP Address 	192.168.0. 	2	to  	254

it is currently ‘checked’ , hope this makes sense how do I progress from here then . . .

OK, on the printer UNtick the “get address automatically”

and set it to

IPv4 Address:
IPv4 Subnet Mask:
IPv4 Default Gateway:

in the router , leave DHCP ticked, but you need to change the pool to

IP Address 192.168.0. 2 to 200

Let me know when you’ve done that.

I can change the printer ok, the router however -

where it says - the 2 is in a box that can be changed - the “to 254” can’t. . . . in other words i can only set it from 3,4,5 etc TO 254

There’s a bit below that in the settings says DHCP Reservation

Add Reservation
Device Name 	
 MAC Address : : : : :
 IP Address 192.168.0.

Will this help?

Edit2: Cancelled changing the printer to “201” it seemed to have hung, I guess cos that’s not possible on reflection?

Edit 3: Take that back it did and has changed . . .

Edit: to answer your earlier question about the sudden surge of Canon printers, no idea, I’ve never had one always had Epsons but they seem to go to the dogs on me after a while, printing wise goes crappy, even ‘decent’ refill inks fail, HP’s Ive liked but the inks are ridiculous price wise, even the copies are dear IMO and Canons seem somewhere in-between price wise, I looked up drivers and support and it seems to get good press, the thing flies when printing and the qualities fantastic, I’m pretty blown away, Just need to get it working lol :wink:

Partial success: just changed the IP on the printbot app on my android to and the protocol to LPR and it works ! It was on IPP no idea what the difference is but that works for my phone at least . . .

Why do some f&*king routers have to play awkward …

OK, you’re going to have to change the routers DHCP pool to:-

IP Address 192.168.0. 10 to 254

once you’ve changed that you may have to reboot all the PC’s and devices that are already connected (and/or restart the router)

the printer will now need to be set to

IPv4 Address:
IPv4 Subnet Mask:
IPv4 Default Gateway:

Let me know when you’ve done that.

Done. . . . just waiting for the changes to take effect, it whirred round for a few minutes last time when I cancelled it but it still worked, i’ll test it on my phone to check, assume all’s well in 5 minutes . . .

Remember, you may need to restart the router and any pc/device currently connected to it.

In the immortal words of Borat “GREAT SUCCESS!”

I just added the software in the same fashion as you first described to my laptop and bugger me if it hasn’t just gone and worked. . . . . one daft thing I noticed that may be obvious to others but not to me was when in the terminal it will prompt - enter the name of the network printer [MG3200series] to which I was typing dave-printer and MG 3200 series printer and then getting errors cos the names not right, not knowing I had to type the one it was OFFERING in brackets . . . .

This is where I often come unstuck in terminal, but i tried all sorts before i posted so hardly surprising, one laptop to go, phone’s done too, I’m on a roll . . . . .

Next stop the scanner if you’re heads not too cabbaged lol :o

So have you installed the scanner drivers yet by running:

cd ~/Desktop/canon-mg3250/scangearmp-mg3200series-2.00-1-deb