New hard disk not recognised [Solved]

My PC has died. RIP.
I have resurrected a very slow 1998 PC and was surprised to be able to load it with Ubuntu V12, so at least I can tell you about it. Slowly.
I discovered that the hard disc from the dead PC had a mechanical fault, but by holding it at just the right angle was able to copy the files to the 1998 PC via the USB. I then bought a new Western Digital HD and fitted it to the dead PC, expecting to be able to load Ubuntu easily.
Ha! Not even a POST display. The VDU is fine; I’ve replaced the PSU; replaced the 3V motherboard battery; and shorted the BIOS reset pins as per the manual. Not a dicky bird. I would be grateful for any ideas, short of buying a new PC.
The motherboard is an ASRock 775i65G.

Is there power on the MB? Any led’s lit up?
Does the fan starts on the processor heatsink?

Thank you for your reply.
Yes: all the lights are on and the CPU fan is working.

Unplug everything that’s not necessary to get a POST screen.

eg. HDD’s, CD/DVD’s, floppy, card readers, add in graphics card, etc.

connect to the onboard graphics adapter

Does it POST ?

if not also remove the RAM … does it beep when turned on without RAM installed ?


The BIOS reset isn’t still shorted is it ?

No, the BIOS is not shorted.
I disconnected everything and when the RAM is removed, there is a repeated sequence of three beeps.
Still no POST.

Did you also disconnect all external devices such as mouse and keyboard ?

Have you tested the monitor on another PC ?

Have you connected the square 4 pin lead from the new PSU to the motherboard ?

have you got an add-in graphics card you can try ?

Mouse/keyboard: Yep: nothing but the monitor connected.
Tested the monitor: Yes: it’s the one I have to swap between the dead one and this slow one.
4-pin lead plugged in: Yes, I have - I just copied the connections used by the old PSU. Perhaps I ought to try the old one again.
Add-in graphics card: I removed it for the other tests but shall try it again and report the result.

Replacing the add-in graphics card had no effect.
The PSU comes with two 12V, 4-pin leads so I changed them over, replaced the memory and - Hey Presto! The BIOS demanded that I select a valid boot device.
I shall persevere and report back. Thank you for your advice so far.

What were the simptoms of the (original configuration) PC dying?

OK, bung it all back together and see what happens :slight_smile:

You can’t beat a good bung! (Shades of Silvio Berlusconi) The system is now up and running with V12 installed. :slight_smile:
I would be surprised if changing the 12V lead was really the problem as the PSU is brand new, but I guess I just needed the impetus of your suggestions to keep waggling the connections!
My thanks as ever for everyone’s generous help - sorry if I’ve been wasting your time.

There’s no guarantee that both 12v leads are working … but whatever it was, I’m happy to hear it’s now solved :slight_smile:

Ah, that’s interesting! I shall check it when tidying up all the kit.
Thank you, Mark.