No audio over HDMI lubuntu 12.10

Hello all,

new problem of the day:

No audio over nvidia hdmi, I have looked at alsamixer and it recognises there is audio on my gfx card but I cannot change the volume, it is always set to 00.

I am trying to set this box up as an XBMC unit for my TV.

I went through a few tutorials I found online and still no luck.

Having to make this breif as my daughter is trying to type on my keyboard so sorry for any typos.

oh and the card is an NVIDIA 8400GS to be precise this one:



What’s the output from:

aplay -l

and if you run:


then hit F6 … what’s listed ?

Hi Mark

aplay -l:

xbmc@xbmc-lounge:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

alsamixer and F6:

0 HDA Intel
1 HDA nvidia

What happens if you fire up:


Hit F6 … then select 1 HDA nvidia

Also if you run:


and go to “Output Devices” … can you select the HDMI output there ?

alsamixer-can’t change the volume but it is visible (there appear to be 4 volumes that can’t be changed)

installed pavucontrol and it tells me there is something wrong with the pulse server (it may not be installed)

do i need to instal pulse audio?


sudo apt-get install --reinstall pulseaudio pulseaudio-utils pavucontrol

The I think you need to reboot.

ok, so reinstalled pulse audio and extras, only shows the “built in analogue stereo” as the only output.

Had a play around to see if I could find any additional options but to no success.

Will continue having a look until you reply at another time :slight_smile:


Which nvidia drivers are you using ?

what’s the output from:

sudo lshw -C display

is there NO audio through HDMI at all … or is there only no audio from XBMC ?

Can you also run this command:

wget -O && chmod +x ./ && ./

hit “Enter” to select
hit the “Left Arrow” key to select <UPLOAD / SHARE> … and hit “Enter
hit “Enter” to select
hitr “Enter” to select

Then post the link that’s reported in the terminal.

Hi Mark,

I have just discovered that there is a pre-made xbmc distro (xbmcbuntu) that I completely forgot about.

I will install that and see if this helps (I have installed it once already but it somehow copied across the previous config from lubuntu)

I will report back and let you know what the new results are :slight_smile:


OK, final conclusion to this…for some reason the bios on this machine has an audio controller that can disable audio to different areas of the machine.

Moral of the story, its not always a problem with linux, just the way HP designs this shizzle.

Cheers guys,


Oh well, at least you solved it :slight_smile:

and got to try XBMCbuntu at the same time ?

Yeah, I am quite impressed with XBMCbuntu, good speed, works really well out of the box and very refined, lots of customization directly from the Desktop Environment, gets the drivers for everything on install.

Have to say 9.5/10.