No Ethernet connection with OpenSuse 10.3

OS Information
Linux i686
Current user:
openSUSE 10.3 (i586)
3.5.7 “release 72”

Processor (CPU): AMD Athlon™ Processor
Speed: 1,095.40 MHz
Memory Information
Total memory (RAM):
504.1 MB
Free memory:
6.1 MB (+ 306.1 MB Caches)
Free swap:
760.9 MB

Ethernet Network Card (not connected)
Device Name: eth-eth-bus-pcmcia
Started automatically at boot
IP address: DHCP+AUTOIP, subnet mask

Network Card
Hangzhou Silan Microelectronics Ethernet controller
Class(spec) Ethernet controller
Device ID:73777
Active: Yes
Modprobe: Yes
Modprobe sc92031
Hwcfg Bus pci
Kernel Driver: sc92031
Model:as 1st line
Old Unique Key: ySqm.xAakld7jbtE

Second attempt to get online with this computer with Op Suse 10.3. Ethernet worked fine with OS 11.1 until that went odd. 11.1 would not reinstall from CD so I loaded 10.3 again, which works well on my other PC (except on that one I cannot activate sound card!)

Failure report.
Ethernet Network Card (not connected)
BusID : 0000:00:11.0
Unable to configure network card because kernel device is not present
So what is a kernel device and where do I fiind one?

Below is a screen shot of the Hardware Info concerning Network Card.
NB this card works no probs with XP.
OOps screen shot won’t copy.

It seems the ‘Hangzhou Silan Microelectronics Ethernet controller’ is a fake Realtek RTL8139, and there were a lot of problems with this chip on kernels before 2.6.21, but should be OK on 2.6.22

Can YaST see and configure the card?

Can you post the output of

lspci -v



Can you also post the contents of /etc/modprobe.conf

Does anything get returned if you enter

modprobe sc92031


modprobe -l | grep sc92031

in a terminal?

What happens if you enter:

insmod /lib/modules/

in a terminal?.. is the network card discovered?.. if not post back with the results

If it is discovered, and the network card works (and ONLY if it works), check to see if it is still there after a reboot, if not add
insmod /lib/modules/
to the /etc/init.d/network file.

is sc92031.ko in your /lib/modules/YOUR-KERNEL-VERSION/kernel/drivers/net/

if this command (also shown above):

modprobe -l | grep sc92031

returned nothing

Download the driver from:

unpack it and read the ‘readme.txt’ file for instructions on how to compile and install the driver.

I run lots of boxes with 8139’s and there were a number of issues with them. I would strongly recommend either a kernel upgrade or pick a distro with an up-to-date (ish) kernel. 2.6.22 is (from memory) getting on a little (18 months+?) , currently I’m on 2.6.31-20 … don’t typically see any network problems at all, even on very odd/cheap 8139 cards …

Thanks for ideas
I took the easy way out and got a recent 11.2 DVD and that installed perfectly on cleared partition.
System recognised network card instantly and I was straight on line. I am delighted with OS 11.2 and it does more or less all that I want. However, I do still have to use Windows for some things. If I cant sort them If will come back here.
As a 67 year old with little computer savvy, all this console stuff is pretty scary and is definitely non intuitive.

If you want to learn a little about the command line,232.msg782.html#msg782

Some of these are Ubuntu specific, but still ‘generally’ apply to other distros

all this console stuff is pretty scary and is definitely non intuitive.

Mmm, I’m guessing you’ve not done much with DOS then? :wink:

This week I fixed a CD-ROM drive for a mate, it’d been driving him crazy (as a Windows vet) for a month … he’d swapped CD drives, IDE cables etc etc, couldn’t make it work. Apparently it’s a common problem with registry corruption (not hardware at all) that required some messing with regedit to fix. If you don’t like the Unix command line you’ll love Windows regedit … gimme a Linux shell anyday … :slight_smile:

Hehe… the wonders of the windows registry :slight_smile:

I might use ‘wonder’ in a different context … when they were designing Windows and came up with idea of “a registry” … I ‘wonder’ what they were smoking … ?! :wink:

I was being sarcastic… but you put it so eloquently :slight_smile: