NO Internet connection Mint 18.3

Running mint 18.3 64bit system.

I connect via a cable LAN to the internet.

The LAN is working just fine can connect to all equipment on the LAN.

But CAN NOT connect to the internet. Anything that needs to connect to the internet is not working.

Also tried via Wi-Fi and get connected to the modem but no connection to the internet.

Tried using a Live USB of mint 18.3 and everything works just fine.

What’s the output from

ping -c 5


ping -c 5


userone@Office ~ $ ping -c 5
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=48 time=35.6 ms
64 bytes from icmp_seq=2 ttl=48 time=37.2 ms
64 bytes from icmp_seq=3 ttl=48 time=36.2 ms
64 bytes from icmp_seq=4 ttl=48 time=35.4 ms
64 bytes from icmp_seq=5 ttl=48 time=35.5 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 35.455/36.055/37.280/0.695 ms
userone@Office ~ $

userone@Office ~ $ ping -c 5
ping: unknown host
userone@Office ~ $

Okay looks like DNS isn’t working.

Have you tried first rebooting your router ?

and if that makes no difference, manually setting your DNS servers in network-manager ?

Try these settings:-
from here,2027.msg19758.html#msg19758

Rebooting made no difference.

Setting the DNS server also makes no difference.

Network manager is getting DNS settings.

Hi so many issues keep popping up have gone for a clean installation.

So this is what happens when you up grade your hardware on a duel boot system with Win7 OEM.

Have finally ditched the Win7.

Thanks for your help.

Sometimes using a sledgehammer to crack a walnut is the easiest (and often the quickest) way :slight_smile:

You can faff about for days trying to be surgical … or just nuke and pave in a couple of hours … sometimes (specially when you’re in a hurry) the thermonuclear option just makes the most sense.

Glad you’re back up and running.