No internet with static IP

Hi guys

I’ve just installed Peppermint 6 on a new ssd hard drive and everything is fine except when I set my network for static ip I can’t access the internet, although I can access my NAS shares on the network, if I set it for DCHP and reboot the internet is restored,

the other odd thing about this issue is that my NAS (Openmediavault) appears to be having the same problem as it isn’t offering updates unless I set it to DHCP.

My own thoughts was that this is a router issue but my wifes PC is set to static IP on the same network and it’s fine

Any help or advice would be much appreciated


So what would happen if you set the static IP address and DNS, Gateway etc. same as you had with that obtained with DHCP?

So what would happen if you set the staticP address and DNS, Gateway etc. same as you had with that obtained with DHCP?
I get the same results, dhcp ste the ip address at which works fine but if I set to that statically internet drops out


Did you also set the DNS, Gateway etc the same as the DHCP?

What are your DNS and Gateway settings ?

ok that seems to be working now, but i did try that earlier with the exact same settings and I swear it didn’t work, but that said since then I deleted the connection and rebooted

The settings now are
IP Address:
DNS: & (Virginmedia

It’s now also working with DNS: & (Opendns) which I also tried earlier so I don’t know what the hell happened

It looks like my problem with the NAS is not related but I’ll keep my eye on that meantime

sorry I wasted your time guys


Normally I’d set the DNS to the routers IP … but I’m not sure that works with the (not so)Superhub

What MP said.
I’ve never had a problem with the pc (well actually I did but that was an IPV6 issue) but I did have trouble setting my xbox and server to static ip’s and that was a dns issue.

The recommended solution is to set all your devices for DHCP, then take a look at your router and somewhere there will be an option to make it re-issue the same dynamic addresses to specific devices, i.e. tell it that once it’s issued an ip to a device , that IP is essentially a static.

It’s standard option on most kit, certainly supported by BT ADSL routers …

If you mess with static’s, not only is there always a chance of an overlap / conflict with DHCP range (unless you limit the range) but new devices support “upnp” which is capable of doing some pretty clever stuff - but typically only on addresses it’s issued. For example if you run a PLEX server, you don’t need to set a reverse NAT port-forward on your router to accept incoming PLEX requests from the Internet, PLEX will talk UPNP to your router and set up the incoming port for you … automatically … :slight_smile:

Ditto with games consoles, it should be able to set stuff up automatically if you use DHCP, so there’s no need to set port forwardings for online games … something we used to need to do to get the best performance out of peer-to-peer stuff …