no network [Solved]

problem with network, please help, I have UBUNTU 11.04 no connection when I type ‘dmesg * grep eth * less’
1.738570 e1000e 0000:00:19.0: eth0: (PCI Express:2.5GB/s:width x1) 00:1c:c0:0a:74:cf
1.738574 e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
1.738598 e1000e 0000:00:19.0: eth0: MAC: 6, PHY: 6, PBA No: fffffff-0ff
9.996822 ADDRCONF(NETDEV_UP): eth0: link not ready

the numbers at the start of each line should be in sq brackets, I have used * replacing the pipe sorry, I’m using my mobile.
H was told by ‘virgin’ i did’nt need an IP address do’s this mean it’s DHCP connection ?

This is going to be a bit awkward for you on a phone, but here goes…

I take it it’s a “wired” connection ?

can you send the output from:

sudo lshw -C network




lsmod | grep e1000

I’ll have to send in 2 files, I’used the # to replace the equalls
description: Ethernet interface
product: 82566DM Gigabit Network Connection
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 02
serial: 00:1c:c0:74:cf
capacity: 1GB/s
Width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000-fd autonegotiation
configuration: autonegotiation#on broadcast#yes driver#e1000e driverversion#1.0.2-k4 firmware#1.1-0 latency#0 link
no multicast*yes port#twisted pair
resources: irq:45 memory:50400000-5041ffff memory:50424000-50424ffff ioport:20c0(size#32)

Can I have the output from the other commands ? … Also, have you checked the ethernet cable (patch lead) ?

Things to try…

sudo ifconfig eth0 down


sudo ifconfig eth0 up

Does the connection come up ?

Also set the IPv6
for the wired profile in network manager … then do:

sudo ifconfig eth0 down


sudo ifconfig eth0 up


Does the connection come up ?

Is the IPv4 set to Automatic (DHCP), and not Automatic (DHCP) Address only.

is there a tick in “Connect Automatically” (there should be).

After you’ve ruled out a bad ethernet cable, try plugging it into another port on the router.

Are you sure the DHCP server in the router has enough addresses available (try making sure this PC is the only one switched on, then reboot).

Have you tried turning off the router, waiting 5 secs, then switching it back on ?

is DHCP enabled in the router ?

eth0 Link encap:Ethernet HWaddr 00:1c:c0:0a:74:cf
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Memory:50400000-50420000
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr:1/128 Scope Host
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1668 (1.6 KB) TX bytes:1668 (1.6 KB)

lsmod * grep e1000
e1000e 132956 0

See above :wink:

Also, is the dhclient being run ? … What happens if you run:

sudo dhclient

Have you tried setting a static IP and seeing if it will connect ?

Is it telling you the cable is unplugged ?

I tried both the suggestions from last night they both returned the prompt on output ?

If you mean -

sudo ifconfig eth0 down


sudo ifconfig eth0 up

Then YES, that’s all that will happen in the terminal, but did the network become active ?

Have you tried the other suggestions ? … no amount of Linux commands are going to fix this if it turns out to be a cable issue, or a router setting :wink:

and what is the output from:

sudo dhclient

The drivers appear to be loaded, so it’s likely a hardware issue, or a configuration issue.

At some stage I could do with the contents of /var/log/dmesg

So can you also run:

cp /var/log/dmesg ~/dmesg

You will then find a file called dmesg in your home folder… can you email it to me… I’ll send you the email address in a PM

Do you know your routers IP address ? … what is it ?

If so, what happens if you attempt to ping it ?
ping -c 5 <ip.address.of.router>

ping -c 5

Does the ping get returned ?

Listening on LPF/eth0/00:1c:c0:0a:74:cf
sending on LPF/eth0/00:1c:0a:74:cf
sending on Socket/Fallback
DHCPDISCOVER on eth0 port 67 interval 3
there 7 lines all exectly the same the numbers following interval
8 10 11 14 11 4
No DHCPOFFERS received.
still no connection after switching off counting 5 and checking cable

Can you ping the routers IP ? … do you know the routers IP ? … what is it ?

I don’t understand what you mean by set IPv6 to ignore I can’t find a setting ?

right click the network manager (top panel) icon, by the clock, and select, “Edit Connections”, on the “Wired” tab, highlight the connection, and select “Edit”, in the window that opens select the “IPv6 Settings” tab… in the “Method:” drop menu, select “Ignore”… click “Apply”.

Whilst in there, make sure the IPv4Settings tab has Method: Automatic (DHCP) and also there is a tick in Connect automatically.

Just in case you can’t find the network manager icon… it can also be opened by entering this in a terminal:


2 things
(1) No I don’t know the routers IP address, I pinged the -c comand it just returns the options, am I doing it right ?
(2) I can’t set the IP address, can get as far as the add button in the tab page (network connections)

NO, not if you aren’t entering the routers IP :o

Have you got a Windows PC that will connect to the router ? … If so, open a “Command Prompt”, and enter:

ipconfig /all

hit enter, then post the output back here.

unfortunatly I don’t have Dos/Windows, I don’t know the IP Address of the router virgin tell me there don’t keep them there automatic, I’ve tried config up and down they just return the prompt both before and after the settings(network connections)

I’m going to take a guess here… try this:

sudo ifconfig eth0 netmask


ping -c 5

and post the output.

  1. Has the router got a make/model number on it somewhere ?

  2. Have you tried another cable yet ?

I’ll see if I can get another cable, when i ping your command it returns network is unreachable, when i do the ifconfig it returns unknown host, the modem has on it the address if i put in ifconfig it returns 'error fetching interface info: device not found. the modem is netgear wireless and cable gateway VMDG280

My fault, I missed out the eth0 interface part of the command (now fixed) … try:

sudo ifconfig eth0 netmask


ping -c 5

(can you also try the fixed commands in my last posting again)

What I’m hoping for is an output similar to this…

mark@Mark:~$ ping -c 5 PING ( 56(84) bytes of data. 64 bytes from icmp_req=1 ttl=255 time=0.919 ms 64 bytes from icmp_req=2 ttl=255 time=0.543 ms 64 bytes from icmp_req=3 ttl=255 time=1.28 ms 64 bytes from icmp_req=4 ttl=255 time=0.626 ms 64 bytes from icmp_req=5 ttl=255 time=0.494 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 0.494/0.773/1.283/0.294 ms

and where “Destination Host Unreachable” is NOT mentioned.

  1. are there any flashing lights on the router next to the numbers 1 through 4 when you run this ?

  2. do any of the lights 1 though 4 EVER flash… specifically the number who’s port the cable is plugged into.

the modem looks just like mine but there is no lights on beside the numbers just the 3 below, I’ve got another cable but won’t get home till late 2night about 9, its not a new cable I borrowed from it at work ? I’ll try the commands when i get home

It do’s look like i had a faulty ethernet cable i have a light were the cable is pluged in but not online, the password seems very slow i have to wait till the cursor changes from a hollow to solid box but it usaully rejects the passwd anyway, can i do it in the GUI ? It only happens in the terminal passwd