No sound from speaker

Installed MInt 15 on my desktop after a reasonably good experience with my Lenovo laptop.
No such luck this time though. Worst thing wrong is that I have no music from speaker - an absolute showstopper for me. (and needless to say it works perfectly on Win XP).
drive manager prompted me to change driver to nvidia-310 (on NVIDIA G86 (geForce 8400 GS). still no luck. Someone said elsewhere (this seems a worryingly common problem) to run
lspci | grep -i audio and smod | grep snd

the output follows. Can anyone help me on this - really don’t want to have to go back to windows

wayne-System-Product-Name wayne # lspci | grep -i audio
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
01:06.0 Multimedia audio controller: C-Media Electronics Inc CMI8738/CMI8768 PCI Audio (rev 10)
wayne-System-Product-Name wayne # lsmod | grep snd
snd_hda_codec_realtek 63791 1
snd_cmipci 35020 2
snd_mpu401_uart 13865 1 snd_cmipci
snd_opl3_lib 18651 1 snd_cmipci
gameport 15016 1 snd_cmipci
snd_hda_intel 38307 2
snd_hda_codec 117580 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13272 2 snd_hda_codec,snd_opl3_lib
snd_pcm 80890 3 snd_hda_codec,snd_hda_intel,snd_cmipci
snd_page_alloc 14230 2 snd_pcm,snd_hda_intel
snd_seq_midi 13132 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_rawmidi 25114 2 snd_mpu401_uart,snd_seq_midi
snd_seq 51280 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 14137 4 snd_seq,snd_rawmidi,snd_opl3_lib,snd_seq_midi
snd_timer 24411 3 snd_pcm,snd_seq,snd_opl3_lib
snd 56485 20 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_mpu401_uart,snd_seq_device,snd_cmipci,snd_opl3_lib
soundcore 12600 1 snd
wayne-System-Product-Name wayne #

brief update
-is this something to do with preferences within sound. I did somehow get some music out, but it sounded like someone was singing through a cup of water!
in sound > prefencces I have

  • Built in Audio - analoogue stero output
  • CM18738/CM18768 PCI (IEC958 output)

Only with the latter do I get a positive result with speaker test.
But when I close and repoen, the hardware tab has reverted to Built In Audio, although the output tab remains at CMI etc.

I reiterate this is a brand new install, I have edited no files thro’ terminal etc

What’s the output from:

aplay -l

Hi there
I get…

wayne@wayne-System-Product-Name ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738-MC6 [C-Media PCI IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

OK, that’s a bit baffling.

Do you have 2 sound cards installed … possibly one on the motherboard, and the other an add-in card ?

What’s the output from:

sudo lshw -C multimedia

I’m pretty sure there is no onboard sound - always tried to avoid it…
for sudo lshw -C multimedia I get

wayne@wayne-System-Product-Name ~ $ sudo lshw -C multimedia
[sudo] password for wayne:
description: Multimedia audio controller
product: CMI8738/CMI8768 PCI Audio
vendor: C-Media Electronics Inc
physical id: 6
bus info: pci@0000:01:06.0
version: 10
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: driver=snd_cmipci latency=64 maxlatency=24 mingnt=2
resources: irq:19 ioport:d800(size=256)
description: Audio device
product: MCP61 High Definition Audio
vendor: NVIDIA Corporation
physical id: 5
bus info: pci@0000:00:05.0
version: a2
width: 32 bits
clock: 66MHz
capabilities: pm msi ht bus_master cap_list
configuration: driver=snd_hda_intel latency=0 maxlatency=5 mingnt=2
resources: irq:22 memory:dbef8000-dbefbfff

Have you got an nvidia graphics card with an HDMI socket ?

What happens if you run:

sudo modprobe -r snd_hda_intel

does that error?

if not, does audio now work from the CMI card ?

Hi there
I get
wayne@wayne-System-Product-Name ~ $ sudo modprobe -r snd_hda_intel
[sudo] password for wayne:
FATAL: Module snd_hda_intel is in use.

the graphics card is quite old and certainty doesn’t have HDMI on it

However…setting sounds > preferences > output to CMI8738/CMI8768 now does work. I get sound!!! BUT its still unlistenable, both in VLC and in that dreadful Banshee app. (Background vocals are particularly bad and the output thro headphones is as bad as the speaker)
Ive set sounds > preferences > hardware for CMI8738/CMI8768 to various settings but none of it seems to improve…

I’m going tto guess you DO have an onboard sound card … even if there are no obvious external audio sockets, it may have required a cable attached to a header on the motherboard.

Is there ANY option in the BIOS to disable onboard audio

Wow - that was some diagnosis.
You were absolutely correct, there WAS onboard sound!! Ive disabled this in the BIOS and it has duly vanished form sounds > preferences.
However…once disabled, the sound is still wrong, both in VLC and BAnshee…

is there anything else I can do?

what do you mean by “wrong” ?

the sound is tunny and fuzzy, with background vocals sometimes hardly present. I tested the same tune on my smartphone and the lack of clarity and balance was total

you lost me there … are you saying it’s a problem with the file as it also sounds crap on your smartphone ?

no, the other way around, it sounds great on my android but terrible on Mint

What’s audio like if you play this

can hardly hear it…

and thats with the volume at 100% thro headphones

but it plays perfectly on my Lenovo X60 laptop also running Mint 15

Are you sure you have the speakers plugged into the green audio socket

trying with headphones - i can hear it, faintly, but definitely there, so the phones are plugged in correctly. But here I hear it faintly at 100% volume, whereas on my laptop it blows my head off at 50%