No sub folders in network shares

Hi guys

A while back Mark (PCNetSpec) help me add network shares to my /etc/fstab file so they would mount at startup which worked perfectly since then I’ve used the lines he gave me to set up other PC’s on this network and it’s always worked perfectly until now,

I bought another PC for the missus and I’m setting it up for her I copied the lines as usual and added them to the /etc/fstab file but although the directories show up in /mnt it shows no sub directories I don’t know what I could have done wrong I did nothing different than what I’ve done before I’ve checked the /etc/fstab file against another PC on the network and they seem identical

Having given this some thought I did do one thing different which was during installation I set it to not ask for password at login and I think that may have something to do with it because I cant change it to ask and during boot I’m getting a message saying Plymouth cannot start but I can’t read it all because flashes up too quick also a lot of cifs errors saying “no username specified”

Any help would be much appreciated

Many thanks


can you show us the fstab contents

and mention the distro/version

Peppermint 4

# /etc/fstab: static file system information. # # Use 'blkid' to print the universally unique identifier for a # device; this may be used with UUID= as a more robust way to name devices # that works even if disks are added and removed. See fstab(5). # # # / was on /dev/sda5 during installation UUID=c51f8aa9-c72c-4127-b0aa-86a83773025a / ext4 errors=remount-ro 0 1 # swap was on /dev/sda6 during installation UUID=d0a4f8fa-45e3-4adc-a07a-f80846e6510a none swap sw 0 0 // /mnt/multimedia cifs guest,uid=1000,iocharset=utf8 0 0 // /mnt/movies cifs guest,uid=1000,iocharset=utf8 0 0 // /mnt/graeme cifs guest,uid=1000,iocharset=utf8 0 0 // /mnt/pat cifs guest,uid=1000,iocharset=utf8 0 0 // /mnt/utilities cifs guest,uid=1000,iocharset=utf8 0 0 //\040tree /mnt/family-tree cifs guest,uid=1000,iocharset=utf8 0 0 //\040(all\040drives) /mnt/backup cifs guest,uid=1000,iocharset=utf8 0 0

if it means anything I’m having a problem accessing anything that needs sudo privileges such as the Software Manager & Network Manager

Can you explain that please

Are any of the working PC’s using Peppermint 4 ?

What’s the output from:

dpkg -l | grep cifs

the software manager wont load the screen shows up but it just cycled endlessly and I have no way of closing it, to stop it I have to completely reboot,

I tried setting the network to static IP and although i can enter the settings it wont allow me to save (“Save” is greyed out)

Sorry I didn’t see your request for this output

pat@Linux2 ~ $ dpkg -l | grep cifs pat@Linux2 ~ $

It’s just dawned on me I don’t have cifs-utils installed could that be the problem ?

Install it and find out:

sudo apt-get install cifs-utils

is it only those 2 things that give you admin problems … or can’t you access ANYTHING that requires an admin password in the GUI ?

is it only those 2 things that give you admin problems .. or can't you access ANYTHING that requires an admin password in the GUI

These are the only things I know about, but I’ve installed cifs-utils and thats solved the network shares problem and the Network Manager problem But I still have a login problem insofar as I can’t get it to prompt for a password and during boot a message pops up saying Plymouth cant load splash screen etc etc but I cant make out the rest because it flashes off too quick, I haven’t tried the software manager again but I’ll do that now and reboot and try to make out the rest of the Plymouth message

The plymouth message is probably not important … it’s just the splash screen at bootup … it may be the fact that it’s still trying to connect to the cifs shares because the network hasn’t come up yet that’s stopping the plymouth splash screen from loading.

but it could also be a graphics driver issue … so what’s the output from:

sudo lshw -C display

Software manager still wont load it asks for a password the screen pops up but it just cycles endlessly, I gave it over a minute then rebooted, I just cannot see the Plymouth error message it’s just off the screen too fast I tried the Pause/Break but it doesn’t stop it is there any other way I can stop it long enough to read it ?

I case it means anything I installed the proprietory nvidia driver

pat@Linux2 ~ $ sudo lshw -C display [sudo] password for pat: *-display description: VGA compatible controller product: G72 [GeForce 7500 LE] vendor: NVIDIA Corporation physical id: 0 bus info: pci@0000:01:00.0 version: a1 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress vga_controller bus_master cap_list rom configuration: driver=nvidia latency=0 resources: irq:16 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:fc000000-fcffffff memory:febe0000-febfffff pat@Linux2 ~ $

IIRC, the nvidia drivers quite often kill plymouth

are there any hints in

gedit /var/log/boot.log


It’s quite a large file and most of the log refers to mounting network shares so I’ve only pasted this section hope that’s ok

* Stopping log initial device creatione[74G[ OK ] * Starting configure network device securitye[74G[ OK ] * Starting save udev log and update rulese[74G[ OK ] * Starting set console fonte[74G[ OK ] * Setting sensors limits * Stopping save udev log and update rulese[74G[ OK ] e[80G e[74G[ OK ] * Stopping set console fonte[74G[ OK ] * Starting userspace bootsplashe[74G[ OK ] * Starting Send an event to indicate plymouth is upe[74G[ OK ] * Starting configure virtual network devicese[74G[ OK ] * Stopping Send an event to indicate plymouth is upe[74G[ OK ] * Starting Bridge socket events into upstarte[74G[ OK ] * Stopping userspace bootsplashe[74G[ OK ] Starting printer spooler: lpd. * Stopping System V initialisation compatibilitye[74G[ OK ] * Starting NTP server ntpd e[80G e[74G[ OK ] * Starting System V runlevel compatibilitye[74G[ OK ] * Starting e[74G[ OK ] * Starting e[74G[ OK ] * Starting ACPI daemone[74G[ OK ] * Starting anac(h)ronistic crone[74G[ OK ] * Starting e[74G[ OK ] * Starting e[74G[ OK ] * Starting save kernel messagese[74G[ OK ] * Starting e[74G[ OK ] * Starting e[74G[ OK ] * Starting regular background program processing daemone[74G[ OK ] * Stopping anac(h)ronistic crone[74G[ OK ] * Stopping CPU interrupts balancing daemone[74G[ OK ] * Stopping save kernel messagese[74G[ OK ]

Try this…


sudo gedit /etc/initramfs-tools/conf.d/splash

When a BLANK file opens, add a sngle line that reads:-


SAVE the file, and close gedit.

Back in the terminal run:

sudo update-initramfs -u

now reboot to test the plymouth boot screen displays.

Be aware - this may slow the boot sequence a bit

Just the same I’m afraid, still get the Plymouth error message and no splash screen, boot time wasn’t noticeably slower

OK, let’s undo that first

sudo gedit /etc/initramfs-tools/conf.d/splash

remove that line … SAVE the file and close gedit.


sudo update-initramfs -u

Now I’m afraid you’re going to need to go through all the log files at /var/log
and search for anything to do with “plymouth”

possibly try syslog first

What happens if you start the mintinstall software manager from the command line

gksu mintinstall

any errors ?

BTW, if necessary:

sudo killall mintinstall

should terminate it.

I left it running for over a minute this is all I got

pat@Linux2 ~ $ gksu mintinstall add_categories took 27.813 ms build_matched_packages took 0.373 ms 20843 add_packages took 6412.031 ms add_reviews took 2428.730 ms

syslog is huge and that’s only one file anyway it’s getting late I’ll try to check through it tomorrow, alternatively would be worthwhile going back to the open source graphics driver because it looks like there’s a good chance the nvidia driver is causing this issue ?

Well we can generate a plymouth-debug log if you want:

Are you bothered about the boot splash screen if we can get the software manager to work ?