old thin client as Htpc - Which linux...


I have an old HP GT7720/25 which used to use for music rip, store, replay and server. However, i now want to use it for living room media player for TV. Hardware should be more than capable of providing 1080 replay. Turion 2.3ghz dual core, 2gb ram and ATI RS780G and in place of the OS Flash rom card I have a kingfast 128gb ssd to act as main OS hard drive.

Media is all on a server so was thinking of plex, Kodi and similar software’s.

I have touched on linux and bsd a few times but not huge knowledge. Anyway first I try Ubuntu 16 and had a few issues. Firstly Kodi wouldn’t install no matter how i tried. Next issue is i read it seems to have issues with ATI drivers in latest version (at least older ones).

Next I try Debian stretch. Seems i can’t use Ati drivers but got video via firmware-amd-graphics. Got all software installed. Video worked great but no sound to TV over the Ati dvi-HDMI adapter (which specs say it should have). The sound device wasn’t showing up in the OS at all, even on -L list. So i figure needs proper Ati drivers. Selected right version for card but that doesn’t work as stopped it booting into desktop.

So next i try earlier version of ubuntu which should work with Ati driver and the Ati driver stops it booting into desktop.

So after 3 different installs and loads of time spent trying to solve issue i am now pulling my hair out and tbh ready to fling thing into field out back.

Can someone please give me a clue what distro I should pick to best get me easy access to latest builds of Kodi, plex other media apps etc and properly support the Ati RS780G Gpu/Chipset and work with the correctly with the correct age of ati driver to get full support for the hardware (sound over HDMI - CEC would also be nice as supposed to support it but less bothered if it doesn’t work).

Really appreciate some help and advice if anyone has it cos tbh another fail or two and it will just get consigned to a cupboard.

Thanks a million.

What exactly were the graphics “issues” you had with Ubuntu 16.04 ?

Ati official fglrx is depricated and they suggest open source alternatives and seems i probs still need official drivers to get Sound over HDMI on that chipset. Had open drivers on debain stretch as well and no sound on HDMI (not even detection it existed)

Okay what exactly was the problem with 14.04 ? … you say FGLRX stopped it booting, how exactly ? … black screen ?

Did you try the “nomodeset” kernel boot parameter ?

Like i say my knowledge is lowish so not tried a nomodset and not sure what one is ?

Seems like thr drivers have poss killed desktop environment as it just sits with a blank pink/burgady screen also tried the recovery mode boot option and it also sits at the same screen.

Also i am using a proper Ati dvi/hdmi adapter on the dvi-d output so shouldn’t be an issue there.

The blank burgandy screen is after normal one with u into logo and red dots below it :wink:

Had a quick look and will try the nomodeset and see if it helps me get back in :slight_smile:

Added nomodeset in grub boot menu and booted to command line login only.

Removed Ati drivers but still no dice. Freezes on Ubuntu splash screen with the red dots.

Can you hit Esc or maybe Tab whilst the dots are onscreen and see text onscreen ?

Will try but goes too fast to see much of use :wink:

Too fast to see but i suspect it looks like a bit of a loop. However with escape pressed it eventually drops to command line login.

I’m hoping to see the last thing it did before it stalls.

Also, when it freezes, are you able to hit Ctrl+Alt+F3 and drop to a text console ?

Ctrl alt f3 works… Trying to see last line now

Nope canny see. Just seems to be a long old list or loop of starting and stopping lines. It then either drops back to ubunto load screen frozen or drops out to command line login but without the last line staying on screen.

If Debian 9 or ubunto 14 or 16 or whatever are best options for me to use I am happy to start from scratch.

Maybe i did something wrong last time or there is a confog option in Debian for firmware-amd-graphics that i need to tweak to tell it it has HDMI sound.

Apart from sound issue debain was closest i got to a nice system but DVD’s aren’t much use without it ??

In Ubuntu 14.04 what is returned if you hit Ctrl+Alt+F3 … log in in text mode, then run:

sudo service lightdm restart

Stop: Unknown Instance
Start: Job failed to start

have you tried running:

sudo dpkg-reconfigure -phigh xserver-xorg

from the text console ?

You might also want to try the


kernel boot parameter with the open source radeon drivers in any of the distros

Err says its not installed ???

Installed it and desktop is back :wink: