Only able to boot Linux Mint 32 bit on a 64 bit machine?

Hi all,

So I’ve been attempting for about a week to try out Linux Mint 17.3 - mostly because I’m completely at my wits end with Windows!

I’m attempting to boot live from a USB, and my laptop is an HP Pavillion running Windows 10, 64 bit (upgraded from Windows 8.1).

I’ve changed BIOS settings to Legacy, disabled Fast Boot and Secure Boot. I’ve tried multiple USB drives, and multiple software to prepare the bootable drives (LiLi, UniversalUSB and Rufus). I’ve even tried using Mint 17.2. Yet for some reason, regardless of what I do, I cannot get Linux Mint to boot as 64 bit edition - I get the notification ‘Unable to find a medium containing a live file’.

I have managed, however to boot the 32 bit version, which is progress! When I run the inxi -Fxz command in Terminal, this is what I get:

System:    Host: mint Kernel: 3.19.0-32-generic i686 (32 bit gcc: 4.8.2)
           Desktop: Cinnamon 2.8.6 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17.3 Rosa
Machine:   System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0976110000405E00000620180
           Mobo: Hewlett-Packard model: 216B v: 30.23
           Bios: Insyde v: F.13 date: 11/21/2013
CPU:       Quad core AMD A8-4555M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 12776
           clock speeds: max: 1600 MHz 1: 1300 MHz 2: 1300 MHz 3: 1300 MHz
           4: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7600G]
           bus-ID: 00:01.0
           Display Server: X.Org 1.17.1 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.1hz
           GLX Renderer: Gallium 0.4 on AMD ARUBA
           GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network:   Card-1: Realtek RTL8188EE Wireless Network Adapter
           driver: rtl8188ee port: 3000 bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
           Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 1031.3GB (0.1% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB temp: 24C
           ID-2: USB /dev/sdb model: Ultra size: 31.1GB temp: 0C
Partition: ID-1: / size: 3.6G used: 35M (1%) fs: overlay dev: N/A

RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors:   System Temperatures: cpu: 37.4C mobo: N/A gpu: 37.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 162 Uptime: 12 min Memory: 287.1/7282.9MB
           Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28

Can anyone please help, and tell me what’s going on here? I’ve posted in another forum, and so far help has been sparse!

Thanks in advance ;D

Re-enable UEFI (disable Legacy BIOS)

Leave Secureboot disabled.

Insert the LiveUSB into a slot on your PC

Turn on the PC and immediately hit F9

You should be presented with a list of bootable devices … is the Mint USB stick in the list ?

and if so, what happens if you select it and hit enter ?

Hi Mark, I followed your steps and I get the standard start-up option screen, where I select 'Boot from a USB device (UEFI).

I then get a notification saying ‘Boot Device Failed - select OK to continue’. So I select ‘OK’ and press enter, then get taken to the Boot Option Menu, where there’s no option to boot from the USB device - just ‘OS Boot Manager’ and ‘Boot from EFI File’

OK let’s start from the beginning

I take it you have a Windows PC, and the Mint 17.3 64bit ISO (MUST be 64bit) ?

If so, download this:
unzip it and use Win32DiskImager to write the ISO image to the USB stick.

Then see if your PC can boot from it. ?

I do have Windows 64 bit, and 64 bit Linux Mint 17.3 ISO…

I installed your software and attempted to boot from the USB - same issue. I get the option to select from Linux Mint 17.3, LM 17.3 Compatibility Mode, or to check the integrity of the medium. I select the full version, hit enter, then get a few minutes of the Linux Mint logo on the screen, followed by this:

'Device not accepting address 2 (then 3,4), error -62 ’

Then 'Unable to find a medium containing a live file system ’

Okay, this is *probably being caused by faulty hardware, too much current being drawn through the USB port, or possibly a bad/loose connection.

Follow the instructions here:

Unplug all USB devices from PC, turn power off, and wait a minute or two. Plug everything back and boot into Linux

if you’re still getting the same problem, either try another USB stick, or a different USB slot.

If none of that helps, let us know and we’ll try this:

Can you also provide the FULL model number of your HP Pavilion.

So I followed the instructions - no joy :frowning: Also tried a different USB stick, and a different port. Nothing.

I checked out the thread you mention - which part are you referring to please?

Also, my model number is 15-n278sa

Cheers :slight_smile:

Well I have 2 HP 15’s so can assure you that Linux flies onto them, so there MUST be a hardware problem somewhere.

Googling “15-n278sa linux” also return plenty of people who’re discussing which graphics drivers to use and how to overcome dropping wireless … so there’s no problem with that specific model.

The part I was referring to was adding the:-


kernel boot parameter … do you know how to try that ?

That’s all great to know about the hardware Mark! Gives me hope :slight_smile:

I looked at the “usbcore.old_scheme_first=1” part, but not sure how to do it?

  1. Boot the live DVD and as soon as you see anything Mint related, hit the Shift key … to access the GRUB menu

  2. Once at the GRUB menu, hit the ‘Tab’ key to edit the boot command line.

  3. Use the cursor keys to navigate to “quiet splash”, and add usbcore.old_scheme_first=1 after quiet splash … so it now ends:
    quiet splash usbcore.old_scheme_first=1

  4. then hit Ctrl+X to boot.

Still no joy with this Mark. I tried it on both USB sticks too.

I’m wondering, since you mentioned a hardware fault - could it be the USB drives I’m using? One is a SanDisk Ultra 3.0, the other an old micro SD USB converter.

I have a standard SD card here and SD slot - could I try booting from that somehow?

There’s a good chance the SD card reader won’t work … I tried one before and it didn’t for me.

Cant say about the sandisk USB stick … is it USB 3.0 ?

Maybe you could try another … might also be a good idea to use the USB 2.0 port on your PC instead of a USB 3.0 port

The other option would be to burn the Mint ISO to a DVD for installation :wink:

Ok, so I’ll get hold of another USB and give it one more try… To be honest though the whole reason I wanted to try LM out was with a view to installing it alongside Windows! From the brief experience I’ve had with the 32 bit version - I really like it :slight_smile: So I’ll need to create a bootable DVD first?

You’ll want the 64bit version of Mint, not the 32bit … only the 64bit version supports UEFI


Gseat - I’ll give it a go and report back! Thanks for all your help :slight_smile:

No problem Cheiro, good luck :slight_smile:

Hi, I am a very experienced Windows user but a complete novice for Linux. I want to move to Linux to avoid the ever closer clutches of Microsoft with Windows 10 and later releases. Today I downloaded a Linux Mint ISO file and burnt it to a DVD, intending to try a test-drive before getting serious with re-partitioning my disc etc. When I boot into Mint I get the same issue as Cheiro, which does not seem to have been resolved. I have no idea what any of the suggestions are saying, so I don’t know where to go from here! Think of it like this - I want to learn to drive but I can’t even turn the engine on, so it’s no use telling me about umpteen technical things that could be wrong because I don’t know my head gasket from my water pump! I just need the car to be in working order! No criticism intended folks, honestly, but please could somebody tell me in simple but complete steps, from scratch, how to create a bootable DVD that will take me into the Mint desktop automatically at bootup? I am running Windows 7 on a 64 bit system with two large hard drives.
Thank you.

How did you burn the ISO image to the DVD ?

And did you check the ISO images MD5 checksum before burning it, to make sure the download didn’t become corrupt ?
(if you’re unsure how to do this, just ask)