openBVE (Problem Solved)

I installed OpenBVE to give it a try but I can’t see how to run it. Can anyone help ?

How did you install it ?

The OpenBVE download page will give a clue :wink:
As it requires mono to run it you would do something like this:

cd /path/where/mono/is/installed 
mono /path/where/openbve/is/installed/OpenBve.exe

And as Microsoft just acquired Xamarin (therefore Mono) you may need to watch this one.
I personally always purge Mono off my systems :slight_smile:

@Mark, via Synaptic
@SeZo, should I just abandon it then ?

No, I am not suggesting to abandon it. :slight_smile:

SeZo, I never saw this page and haven’t a clue what it is saying. I thought if I downloaded from Synaptic it would just run ?

if you installed it via synaptic, what happens if you open a terminal and run:


if it’s anything like my system mono will segfault ?

don@ldwatson ~ $ openbve

at <0xffffffff>
at (wrapper managed-to-native) System.Drawing.GDIPlus.GdipLoadImageFromFile (string,intptr&) <0xffffffff>
at System.Drawing.Image.FromFile (string,bool) <0x0005b>
at System.Drawing.Image.FromFile (string) <0x00013>
at OpenBve.formMain.LoadImage (string,string) <0x0003b>
at OpenBve.formMain.formMain_Load (object,System.EventArgs) <0x00d83>
at System.Windows.Forms.Form.OnLoad (System.EventArgs) <0x00075>
at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs) <0x0007f>
at System.Windows.Forms.Form.OnCreateControl () <0x00053>
at System.Windows.Forms.Control.CreateControl () <0x0011f>
at System.Windows.Forms.Control.WmShowWindow (System.Windows.Forms.Message&) <0x00167>
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message&) <0x002d3>
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message&) <0x0001b>
at System.Windows.Forms.ContainerControl.WndProc (System.Windows.Forms.Message&) <0x0005b>
at System.Windows.Forms.Form.WndProc (System.Windows.Forms.Message&) <0x00253>
at System.Windows.Forms.Control/ControlWindowTarget.OnMessage (System.Windows.Forms.Message&) <0x00025>
at System.Windows.Forms.Control/ControlNativeWindow.WndProc (System.Windows.Forms.Message&) <0x00036>
at System.Windows.Forms.NativeWindow.WndProc (intptr,System.Windows.Forms.Msg,intptr,intptr) <0x00310>
at System.Windows.Forms.XplatUIX11.SendMessage (intptr,System.Windows.Forms.Msg,intptr,intptr) <0x003f3>
at System.Windows.Forms.XplatUIX11.MapWindow (System.Windows.Forms.Hwnd,System.Windows.Forms.WindowType) <0x001df>
at System.Windows.Forms.XplatUIX11.CreateWindow (System.Windows.Forms.CreateParams) <0x00bab>
at System.Windows.Forms.XplatUI.CreateWindow (System.Windows.Forms.CreateParams) <0x0001f>
at System.Windows.Forms.NativeWindow.CreateHandle (System.Windows.Forms.CreateParams) <0x0003f>
at System.Windows.Forms.Control.CreateHandle () <0x00069>
at System.Windows.Forms.Form.CreateHandle () <0x0002b>
at System.Windows.Forms.Control.CreateControl () <0x00087>
at System.Windows.Forms.Control.SetVisibleCore (bool) <0x00083>
at System.Windows.Forms.Form.SetVisibleCore (bool) <0x002ef>
at System.Windows.Forms.Control.set_Visible (bool) <0x00032>
at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control.set_Visible (bool) <0xffffffff>
at System.Windows.Forms.Application.RunLoop (bool,System.Windows.Forms.ApplicationContext) <0x002fb>
at System.Windows.Forms.Form.ShowDialog (System.Windows.Forms.IWin32Window) <0x008ab>
at System.Windows.Forms.Form.ShowDialog () <0x00013>
at (wrapper remoting-invoke-with-check) System.Windows.Forms.Form.ShowDialog () <0xffffffff>
at OpenBve.formMain.ShowMainDialog () <0x0005f>
at OpenBve.Program.Main (string) <0x00bc7>
at (wrapper runtime-invoke) .runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

/usr/bin/cli() [0x4b73d8]
/usr/bin/cli() [0x50f13b]
/usr/bin/cli() [0x423d22]
/lib/x86_64-linux-gnu/ [0x7f9bc7ac2340]
/usr/lib/ [0x7f9bbf69b5ca]
/usr/lib/ [0x7f9bbf67e67a]

Debug info from gdb:

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

don@ldwatson ~ $
OK Mark ? What you expected ?

egg-zactly as I suspected :wink:

It seems there’s a bug/incompatibility with the version of libgdiplus in 14.04 (trusty) … it works if you downgrade libgdiplus to the version from 13.10 (saucy)

If you want to do that, open a terminal and run the following commands in sequence:

mkdir ~/libgdiplus-downgrade


cd ~/libgdiplus-downgrade

The next two steps are dependant on your architecture (so only download and install the correct package for your architecture)…

If you’re running 32bit Ubuntu 14.04 / Mint 17 / Peppermint 5 or 6


OR if you’re running 64bit Ubuntu 14.04 / Mint 17 / Peppermint 5 or 6


then run either

sudo dpkg -i libgdiplus_2.10-3ubuntu1_i386.deb


sudo dpkg -i libgdiplus_2.10-3ubuntu1_amd64.deb

depending on which file you downloaded.

Now see if openbve runs:


if it does, put a hold on the libgdiplus package so it’s not upgraded

sudo apt-mark hold libgdiplus

if at a later date you want to remove the hold on libgdiplus and upgrade it back to the default … just run:

sudo apt-mark unhold libgdiplus


sudo apt-get install libgdiplus

Thanks Mark,
I have carried out your suggestions and copied and pasted the last 2 commands to a file ‘just in case’
I will mark this as Solved over the weekend after I have tried to muck it up :wink:

You’re welcome Don … good luck :slight_smile:

I have had a go at this but there is a distinct lack of tutorial for downloading.
I am rubbish at driving a train but it is a very interesting programme and I am well satisfied with it.
Thanks for help chaps.

take care
Don W

Yeah, had a quick go myself … ended up entering Birmingham New Street at 175kph with the train on its side.

Applying for a train driver job Monday :slight_smile:

Not quite sure what the purpose of this post is, but still!
Information if nothing else :slight_smile:

Development on the original version of openBVE stalled in ~2012 when the original developer (Michelle) left.
Relatively recently, I and a bunch of other people have been working very hard on restarting development.

Nightly builds are being posted here:
Full source code available here:

This bug (And plenty of others) have been properly fixed, rather than the nasty hack of downgrading libgdiplus that you performed.
libgdiplus is part of Mono, and it’s not something I’d really advise downgrading, too many places it’s used.

Techincal details on the bug in question:
libgdiplus doesn’t like the compression of some of the UI images used. Off the top of my head, it was the route icon and a couple of others :slight_smile:

Hopefully this version (Fork??) will work for you without needing any libraries downgrading, but if not, please open a bug on Github, and we can investigate properly.


Chris Lees

Cheers for the info leezer3 … always nice to have a “proper” fix, and great to see the project resurrected :slight_smile:

Welcome to the forum :slight_smile:



You in Cornwall too ?

Once upon a time, yes :slight_smile:

Grew up in a little village near Callington (Higher Metherell), and the parents are still there.

These days, I’m in Norwich, but I still build BVE routes based upon where I grew up.

The main site:

(FWIW: I’m actively bug-hunting at the minute. I ran into this post looking for posts about bugs I don’t know about yet, and whilst we know about this one, I decided that it was new enough to leave a comment on :slight_smile: )

Well we headed in (kinda) opposite directions then … I’m from the Midlands but now in St Austell (well Nanpean really).

I’ll give your nightlies a whirl as soon as I get time, and if I find any issues I’ll post em to your github repo.

Thanks again for posting the info :slight_smile: