Peppermint 11 not installing

I have PEPPERMINT 10 RUNNING ON THIS OLD LAP TOP. Now I am trying to install peppermint 11.

I have tried both a 64bit and 32bit install because it is an old machine but in both cases I go through the install process when I click on Install nothing happens and I am returned to the live USB desktop.

Any help would be welcome.

Hi Tramlink

The problem could be your video driver, but the first thing I think would be to find out for definite exactly what architecture your PC is can you post the output of


cjh@user4:~$ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Address sizes: 36 bits physical, 48 bits virtual
Byte Order: Little Endian
CPU(s): 2
On-line CPU(s) list: 0,1
Vendor ID: GenuineIntel
Model name: Intel(R) Pentium(R) Dual CPU T2310 @ 1.46GHz
CPU family: 6
Model: 15
Thread(s) per core: 1
Core(s) per socket: 2
Socket(s): 1
Stepping: 13
CPU max MHz: 1467.0000
CPU min MHz: 800.0000
BogoMIPS: 2926.30
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2
ht tm pbe syscall nx lm constant_tsc arch_perfmon pe
bs bts rep_good nopl cpuid aperfmperf pni dtes64 moni
tor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm pti d
Caches (sum of all):
L1d: 64 KiB (2 instances)
L1i: 64 KiB (2 instances)
L2: 1 MiB (1 instance)
NUMA node(s): 1
NUMA node0 CPU(s): 0,1
Itlb multihit: KVM: Mitigation: VMX unsupported
L1tf: Mitigation; PTE Inversion
Mds: Vulnerable: Clear CPU buffers attempted, no microcode
; SMT disabled
Meltdown: Mitigation; PTI
Mmio stale data: Unknown: No mitigations
Retbleed: Not affected
Spec store bypass: Vulnerable
Spectre v1: Mitigation; usercopy/swapgs barriers and __user point
er sanitization
Spectre v2: Mitigation; Retpolines, STIBP disabled, RSB filling,
PBRSB-eIBRS Not affected
Srbds: Not affected
Tsx async abort: Not affected

Sorry I’ve been awhile responding my own PC went into meltdown, I’ve been looking online for some clues to your issue and coming up blank, from your last post it’s definitely a 64 bit system, so you can try burning the ISO to a different drive and try again, what may give us a clue would be to run the installer from the terminal instead of the desktop icon and see if it reveals any output we can work on


also can you post the output of

inxi -F

Do you have Fast Boot disabled?

Have tried all peppermint 11 versions - even tried installing as admin always the same just will not install.

Have tested other light systems and installed one of these.