Peppermint 5 Updates (SOLVED)

Hi Mark,
I have been working away here trying to sort out digital and video pictures.
I am using Shotwell as the programme and it seems to be ok.
While working today I had to use the AltGr+SysRq reisub thingy to get me out of a hung screen.
I have noticed that there are Software Updates almost on a daily basis which leaves me with the question should I install a more robust Linux ?
I have plenty of room to install what I want would you recommend a beefier Linux that I can’t break ?
Do I need a stronger setup ? Just wondering. :-\

You’re not really going to get a more “robust” Linux than Ubuntu-based, short of going Debian Stable.

Btw, the SysRq method was probably overkill unless X had frozen - you might have been able to get to a terminal using Ctrl-Alt-F1, logging in, then using “sudo top” to work out which process was hogging the resouces, then “sudo kill -9 xxxx” where xxxx is the PID listed by top. Then use Ctrl-Alt-F7 to get back to your desktop session (I think it’s F7, might be F6 or F8, I usually try them all! :-[)

Thanks chemicalfan,
I have taken a note of your reply.
The SysRq is my normal ? response and is a bit of an overkill, but typical of my sledgehammer>nut attitude :o

Daily updates are quite normal in the linux world … you can look at it two ways

a) there are problems that need fixing
b) Hey, it’s good to know they’re on top of things

They’re nothing to worry about :wink:

Remember, even in the Windows and Mac world there are daily updates … they just tend to save them up and release them in dollops (patch tuesday) … I’d prefer to have them as soon as they’re ready.

Also be aware that some of these updates (unlike Windows/OS X) will be APPLICATION updates, as Linux also updates those automagically for you.

FYI … chemicalfan was right the first time … Ctrl+Alt+F7

How often does the system appear to hang ? … it might be worth trying to figure out what’s causing it.

What are you normally doing when it hangs ?

What are the symptoms … eg. can you move the mouse around the screen but not click anything, or perhaps the opposite, keyboard shortcuts work (such as Ctrl+Alt+T to open a terminal) but the mouse/touchpad doesn’t work ?
Is the hard drive activity light going nuts during this freeze ?
Are you able to drop to a console (Ctrl+Alt+F3) and log in in text mode during these freezes ? (remember Ctrl+Alt+F7 will get you back to the graphical desktop).

This thread has lead me to ask a question I’ve been thinking about asking anyway

Since installing Peppermint 5 (when it was first released) haven’t been offered one update is that normal ?


Did you do a clean install, or an update from PM4? If you upgraded from PM4, it’s possible your sources list wasn’t updated, and it’s still pointing at PM4 repos (which, even if they were still online, would have older versions of packages than PM5).

It was fresh install


No it’s not normal

Have you got updates available in “Software Updater” … or have you been running this manually quite often ?

I just tried running the updater and I get an error “Failed to download repository information, check your internet connection” but the internet connection is ok"


After my last post I clicked on “Setting” the updates box opened up, (none of the boxes under the Updates tab was ticked) so I closed without changing anything the the updater ran again automatically and now it’s saying “Updated software has been updated since Ubuntu 5 was released, Do you want to install it now” and now there’s a huge amount of updates available

Ubuntu 5 ??

Heh … I’ve never noticed that, Probably “Ubuntu” from the updater itself, and “5” from the Peppermint version in lsb-release :slight_smile:

I would have expected at lleast “Security updates” to have been ticked by default … I’ll have to check on a clean install.

Hi Mark,
I can’t remember what I was doing at the time, but I could move the mouse, but when I clicked it nothing happened.

Is this the only time it’s happened?

No. At least twice today

It’s probably only the app that crashed, so the method I posted earlier should work (the app might not be top of the list in “top”, so look for it)

It is working fine at the moment but I have taken note and will apply remedy when (if) it happens again.

With regard to Emegra’s comment about updates, mine was a clean install of Peppermint 5 alongside a Ubuntu 12.04, I have had plenty of updates since the install and as a matter of interest there was an “Ubuntu 5” reference on at least some of them, though I don’t remember how many, just recall thinking it was a bit odd but as everything seemed to be working ok I just carried on regardless.


Thanks for that Degsy

I thought there was something wrong and I was always intending to post about it but it wasn’t until I read through this thread I realised there was definitely a problem with my system,

if you get a chance would you mind going to your System Updater then when the box appears clicking on “Settings” and under the “Updates” tab tell me if any of the boxes are ticked and if so which ones, all mine are unchecked

many thanks


At least he top 2 (trusty-security and trusty-updates) should be ticked (AFAIK by default) … the others 2 (proposed and backports) really up to you.

At least he top 2 (trusty-security and trusty-updates) should be ticked (AFAIK by default) .. the others 2 (proposed and backports) really up to you.

Ok I’ll check the to 2, do you think that’s been the reason for it not updating automatically