Peppermint 6 for acer Aspire One

Hi All,

I used to be a member and then lost my log on details.

My acer aspire one is running on the original syatem and I am trying to upgrade it to peppermint 6.

I have followed the instructions given by Mark and the usb installer comes up as a grey cog wheel and won’t run to allow me to uninstall and reinstall the peppermint 6 any thoughts please.

thank you


You’ve lost me Roy … comes up as a cog where ?

Have you managed to install Peppermint to the USB stick … and just can’t boot it ?


Can’t you install Peppermint to the USB stick ?

Is there any reason you’re trying Peppermint 6 rather than 8 ?

Are you using the 32bit version ?

How did you write the Peppermint ISO to the USB stick … which app, and in Which OS ?

Hi mark

When I downloaded the USB driver to the stick the icon is a silver grey cog wheel and it won’t open. I didn’t know 8 was available I have downloaded the 6 to the stick but can download 8 if it’s better. Cheers Roy

Hi Mark

Sorry I don’t know a lot about the operating systems so please bare with me.

I am using a acer aspire one with the linpus Linux lite v1.0.9.e that is not good and keeps asking for verified security certificates over and over again.

the bios version is v0.3310.

I downloaded peppermint 6 from your blog and the usb install pen driver. The peppermint seems ok but the usb driver just has the fault I mentioned in the last post.

I really want to get this little gem up and running properly again I have 2 of them and cant leave them alone.

Thanks in advance

Okay, are you downloading Universal USB Installer from pendrivelinux and trying to run it in Linux ?

That’s a Windows application, so need to be run in Windows.

Have you got access to a Windows PC ?

Hi Mark,

Yes i have a windows PC, do i just open it and run?



Okay the best bet would be to use Rufus in Windows to write the Peppermint ISO image to the USB stick … see here:,4350.0.html
should work for Peppermint 6 too.

Thanks Mark,

I will give it a try, do you think i would be better loading peppermint 8? how do i know if i need the 34 or 64bit download?

If you’re using an Aspire One (zg5), you definitely need the 32bit version of Peppermint (it’s Intel Atom N270 is not a 64bit CPU).

Peppermint 6 Vs Peppermint 8 … this is harder to answer in this case.

If you only have the base 512MB RAM I’d probably not recommend either any more … if you have maxed out the RAM to 1.5GB, probably Peppermint 8

Peppermint 6 will be lighter, but only has about 11 months of support left.

Thanks Mark,

Where if the best place to get the 8 from? annnd do you have any magical instructions like i had last time for installing it please?

Thanks again

You can get Peppermint 8 32bit from here:

And after creating the LiveUSB with Rufus, you can still follow the Peppermint 6 instructions here:,2118.0.html

Skip stage 1 as you already made the LiveUSB with Rufus

Do stages 2, 3, 4, 5 as they are

In stage 6 change the second command to

sudo apt-get install firefox libreoffice thunderbird && sudo update-apt-xapian-index

In stage 7 only do the top part, DO NOT do the bit after the word “java

Skip stage 8 because there is no longer a Skype version for 32bit Linux … though you can use their web client in an ICE SSB later if Skype is important to you.

And finally, in stage 9 start with this command

echo "options acerhdf interval=5 fanon=60000 fanoff=55000 kernelmode=1" | sudo tee /etc/modprobe.d/acerhdf.conf

everything before it is no longer necessary.

Hi Mark, i have completed the installation process and it has restarted. When its restarted it has the clock etc in the top right hand corner and 3/4 of the screen from left to right has blue red and grey lines at the top with 3 lines of unreadable white writing. hope this makes sense

Okay this seems to be a bug with that kernel and the intel graphics on netbooks.

Are you able to open a terminal by hitting Ctrl+Alt+T at the same time ?

If so run:

sudo xed /etc/default/grub

enter your password when prompted, then hit enter.

when a text file opens, add a NEW line at the bottom that reads


SAVE the file and exit the text editor.

Back in the terminal run:

sudo update-grub

enter your password if/when prompted, and hit enter.

When that’s done, reboot to test.

Hi Mark,

I wont let me open anything with ctrl+alt+t

Okay we’ll have to do this the hard way…

Hit Ctrl+Alt+F2

This should drop you you to a text console.

In the text console, type in your username and hit Enter.

type in your password and hit Enter.

Now you’re logged on in text mode, run:

sudo nano /etc/default/grub

hit Enter, type in your password when prompted, and hit Enter again.

In nano, scroll to the bottom using down arrow key.

Add a NEW line at the bottom that reads:


then hit Ctrl+X … then Y then Enter (to save and exit nano)

Now you’re out of nano and back at the normal $ prompt, run:

sudo update-grub

and hit enter.

Now reboot with:

sudo shutdown -r now


Ctrl, alt and f2 opens something up but due to the page being so scrambled i cant see anything and cant type is it worth trying to reinstall peppermint 8?

Okay the even harder way…

Boot to the Peppermint LiveUSB, connect wirelessly (or via an ethernet cable to your router), open a terminal and post back here the output from running these 2 commands:

sudo fdisk -l


sudo blkid

and I’ll post you some instructions.

is it worth trying to reinstall peppermint 8?

probably not, the same thing would likely happen … probably best to just fix this install.

Hi Mark

Sorry its taken so long to reply.

I have tried both sets of instructions and it still wont let me do anything.

I hit the ctrl+alt+f2 and it has changed the screen to blue/red/white thin stripes at the top of the screen 3/4 way across from left to right and 2 lines of little dots which I think should be words but isn’t due tot the screen.#

I have also tried to install the whole peppermint 8 again and the same thing has happened …I need help please.

Thanks again

peppermint@peppermint ~ $ sudo fdisk -1
fdisk: invalid option – ‘1’

fdisk [options] change partition table
fdisk [options] -l [] list partition table(s)

Display or manipulate a disk partition table.

-b, --sector-size physical and logical sector size
-B, --protect-boot don’t erase bootbits when create a new label
-c, --compatibility[=] mode is ‘dos’ or ‘nondos’ (default)
-L, --color[=] colorize output (auto, always or never)
colors are enabled by default
-l, --list display partitions end exit
-o, --output output columns
-t, --type recognize specified partition table type only
-u, --units[=] display units: ‘cylinders’ or ‘sectors’ (default)
-s, --getsz display device size in 512-byte sectors [DEPRECATED]
–bytes print SIZE in bytes rather than in human readable format

-C, --cylinders specify the number of cylinders
-H, --heads specify the number of heads
-S, --sectors specify the number of sectors per track

-h, --help display this help and exit
-V, --version output version information and exit

Available columns (for -o):
gpt: Device Start End Sectors Size Type Type-UUID Attrs Name UUID
dos: Device Start End Sectors Cylinders Size Type Id Attrs Boot End-C/H/S
bsd: Slice Start End Sectors Cylinders Size Type Bsize Cpg Fsize
sgi: Device Start End Sectors Cylinders Size Type Id Attrs
sun: Device Start End Sectors Cylinders Size Type Id Flags

For more details see fdisk(8).
peppermint@peppermint ~ $ sudo blkid
/dev/sda1: UUID=“b556679c-50c2-468e-9122-94b32048946f” TYPE=“ext4” PARTUUID=“69012f06-01”
/dev/sdb1: LABEL=“PEPPERMINT” UUID=“1C9A-8CD9” TYPE=“vfat” PARTUUID=“3449fb09-01”
/dev/loop0: TYPE=“squashfs”
/dev/sda5: UUID=“9f636e72-011e-4770-91b9-9a7165422b3d” TYPE=“swap” PARTUUID=“69012f06-05”
/dev/zram0: UUID=“7e245819-7ea4-4f5c-a999-b506c9063ef1” TYPE=“swap”
/dev/zram1: UUID=“827f3c79-4b5b-401f-881d-88ae35fcd29b” TYPE=“swap”

That’s a lower case L in the first command, not a 1 :wink: