Peppermint 8/9 live USB not responding [SOLVED - used Mint non-PAE]

Having found a very old laptop (Dell 505, 32 bit, 2GB RAM) with Peppermint 3 on it, I thought I would upgrade it and donate it to a friend who has need of one.

I downloaded the Peppermint 8, 32 bit ISO and checked the md5sum - OK.
Then I used UNETBOOTIN to create a live USB.
I have tried it on both my Lenovo T500 (64 bit) and the Dell 505 with the boot orders set to boot from the USB first, but it always boots into the installed OS on both machines.
The Lenovo boots successfully into an 64 bit Ubuntu live USB and the Dell tries but naturally tells me politely that it’s the wrong architecture.

I would be grateful for any advice.
Thank you.

Are you using Linux or Windows to create the LiveUSB ?

If Linux … Which distro/version ?

I am using Ubuntu 16.04 on my Lenovo T500 to create Live USBs.
Both the T500 and D505 recognise the Ubuntu Live USB but neither recognise the Peppermint one.

In Ubuntu, download this:
https://launchpad.net/~peppermintos/+archive/ubuntu/p8-release/+files/mintstick_1.3.4+peppermint0.0.1_all.deb
and double-click it to install.

Once installed look in your menu’s for 2 tools

USB Stick Formatter
and
USB Image Writer

Use the USB Stick Formatter to format the USB stick as FAT32

Then use the USB Image Writer to write the Peppermint ISO image to the USB stick.

Do I want the ISO image on the USB stick? Surely I use UNETBOOTIN to unpack the ISO to a USB?
Excuse my ignorance.

USB Image Writer will do just that … it’ll unpack the ISO onto the USB stick
(it doesn’t just move the ISO there)

Unetbootin is currently not working with Peppermint ISO’s … so either use the tool I just mentioned, or Etcher.

Gotcha. I thought that the unpacking of an ISO produced non-ISO files, but I get the idea.

The live USB works a treat in my Lenovo T500 but fails to start on the Dell 505 for which I wanted it.
The USB menu pops up, I click on “Try peppermint live usb” and the machine freezes. I left it for 10 minutes but no response so far.

Does USB Image Writer work only for Peppermint or for other Linux OSs as well?

(BTW: P8 is really good! Thanks to your good self, I believe. )

Is Peppermint 3 still on the 505 … if so, what’s the output from:

inxi -Fz

Here it is:
keith@D505 ~ $ inxi -Fz
System: Host: D505 Kernel: 3.2.0-126-generic i686 (32 bit) Desktop: LXDE (Openbox 3.5.0) Distro: Peppermint Three
Machine: System: Dell (portable) product: Latitude D505
Mobo: Dell model: N/A Bios: Dell version: A09 date: 04/13/2005
CPU: Single core Intel Pentium M (-UP-) cache: 2048 KB flags: (sse sse2) clocked at 1600.00 MHz
Graphics: Card: Intel 82852/855GM Integrated Graphics Device
X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2 GLX Version: 1.3 Mesa 8.0.4
Audio: Card: Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller driver: snd_intel8x0
Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network: Card-1: Intel PRO/Wireless 2915ABG [Calexico2] Network Connection driver: ipw2200
IF: eth1 state: up mac:
Card-2: Intel 82801DB PRO/100 VE (MOB) Ethernet Controller driver: e100
IF: eth0 state: down mac:
Drives: HDD Total Size: 50.0GB (52.3% used) 1: /dev/sda ST950212A 50.0GB
Partition: ID: / size: 45G used: 25G (58%) fs: ext4 ID: swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 41.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 127 Uptime: 1 min Memory: 256.2/1000.2MB Client: Shell inxi: 1.7.33

Try this…

Boot to the Peppermint LiveUSB, and as soon as you see the “Try Peppermint / Install Peppermint” screen, hit the Tab key.

You should see some white writing at the bottom of the screen

add forcepae TWICE both before and after the – delimiter … as in this image from Ubuntu

https://i.imgur.com/ckDc9dh.png

Then hit Enter to continue booting.

No go, Mark. I tried various combinations of space/no-space between “–” and the "forcepae"s but the machine just hangs as before and is unresponsive to any key-press.

Both the T500 and D505 recognise the Ubuntu Live USB but neither recognise the Peppermint one.

Correct!

The problem MAY be Unetbootin itself … use dd (or Etcher) (or even better mintstick as used in Linux Mint annd Peppermint itself)) to write the Peppermint ISO to the USB stick in Linux.

Or Rufus in Windows.

Unetbootin has been iffy with Peppermint for some time now, and the authors have shown a lack of interest in working with us to remedy the situation.

Etcher rings a bell though It doesn’t appear to be on my PC. But I’ve just found Mintstick (and I must have installed for a reason!) so it looks like I used that, but my memory isn’t what it used to be.
Best thing is for me to re-create the live USB using Minstick and come back to you. Might be a few days as I’ll have a visitor. Actually, it will be a few days as she has the laptop!

Cheers, Mark.

Mintstick (aka. USB Image Writer in the menu) has never failed for me.

Hence why we have it in Peppermint :slight_smile:

That’s the one! Your recommendation is enough for me.
Lady friend due today with the offending laptop - if she remembers. If not then I won’t be able to try it until March, but I’ll let you know.

My thanks as usual, Mark

Laptop arrived and Lady-friend departed.
Downloaded Peppermint 9 and checked MD5SUM - OK.
Used Mintstick (USB Image Writer) to create a live USB.
Everything was going well until I noticed that the USB device was no longer showing on file the manager.
At the end of the process (success message) I refreshed the file manager page but still no sign of the USB.
Removed USB and rebooted.
USB device still does not show on Nautilus or Nero. Knackered USB?

I may have screwed up things as I normally use Nero although plugging a USB automatically brings up Nautilus. Perhaps I closed the wrong window whilst waiting for things to end.
I shall need to buy a few more USBs before trying again.
Ah, me!

Not sure what you’re saying ?

Mintstick completed writing the LiveUSB ?

Did you use it to install ?

Have you tried using Gparted to format the USB stick ?

What OS are you using Mintstick in ?

When you say “doessn’t show up”, do you mean it doesn’t automount, or that it doesn’t display in the nautilus/nemo left hand pane ?

Mark,
I am using Ubuntu 16.04 on my main PC to create the Live USB.
The USB had already been formatted as I had been using it for other purposes.
Mintstick did complete writing the LiveUSB, and told me it was successful.
When I say “USB device still does not show on Nautilus or Nero” I mean it’s name will no longer display on the LH pane.

  • so I can’t even attempt to use it for an installation or, indeed, for anything else.

I think the problem was finger trouble - closing the wrong file manager (Nautilus rather than Nero) - during the process, so I shall buy a few USBs and try again. And try to be a little less impatient next time.
I’ll return next week to report progress.

Keith