Persistent menu how to cancel [SOLVED]

I have tried to install TEAMS (damn Microsoft!) for a business chat, then noticed it was already installed via the Linux repository. So I did not install it a second time, of course. BUT… I still have in the menu (under Internet) the box of the installing package.
How do I cancel that persistent menu? The file is not there anymore, so is of no use. Thanks.

You don’t mention anything about your computer/OS - please always do so as it helps us to help you.

In the absence of such info, try this: place your cursor over the offending icon, and hold down the right mouse-button. If this produces a drop-down menu scroll down to highlight “Move to Trash” (or similar), and release the mouse button.

Let us know the outcome.

First post so I hope this works!
Open your File Manager as root e.g. Open the terminal and type

sudo nemo
Then enter your password (I think your on Linux Mint from a previous post)

Then go to Filesystem root (listed on the LHS) then usr > share > applications
and find the icon you want, click on it with RMB and open with text editor.

Then if you scroll down to where it says Categories and remove Network from the list and save.

Note: I tried this with HexChat on my computer and it worked but not 100% on Teams.

PS. If there is no Categories listed you could try adding
NoDisplay=true at the bottom of the file.

If I follow follow your problem and take Gaz511s assumption of it being Mint - this may help - Linux Mint 19 How to edit Main Menu - Softhints

  • Right-click Menu
  • Configure
  • Tab Menu
  • Open the menu editor
  • You can use custom icon or change Menu name

Nb: That is an old post using Mint#19, I’m using 20.04 and right-light shows “Edit Menus” opposed to “Configure”, but I doubt if you’ll get lost…

Had a similar problem on MIYO linux (Devuan+openbox) which I use on my old laptop and the solution I suggested came from a video by guy who made that.
So although it will work I should have known that Mint would have an easier method ( i.e. Brian000 post ).

My apologies, just the second post, I forgot I should always specify the system - which is Linux Mint 20.2.
Teams has disappeared by itself (I suppose when I restarted), easier than I thought. In a previous occasion I had a problem with s Crossover icon which I could not get rid of forever, thought this was of the same kind.
Thanks to all the replies, this has now been solved.

Pleased that it’s all OK now - and many thanks for marking your post as solved.
Thanks also to Gaz & Brian for their contributions.