Hi, I have the latest version of Ubuntu and I have Firefox as my browser. I have an account with Private Internet Access (PIA) and what to install it on my desktop. For some reason Firefox will not take me to any of their web pages, I just get “page not found”, but I can access all other web pages. So I cannot get the download from their site, I managed to get the PIA add on for Firefox, but when I connect to PIA, it just stops me connecting to the internet. Any help would be very welcome.

Hello Jokerman - and welcome to the Forum.

If FF reports only “Page not found” rather than a security warning then it really can’t find it.
I am running Ubuntu 18.04 and can access:

Could it be something as simple as you not typing the base name correctly? Try clicking on one of the links above and let us know the result.

BTW: https://protonvpn.com/ provide a super-secure VPN service, both free and paid-for. Worth exploring


You might also try clearing the Firefox cache and browsing history in case it is picking up an incorrect entry. You can choose which elements to delete.

See here -


I have used PIA for a number of years and never had trouble with it. I downloaded from their website and just followed the steps provided and it connects automatically whenever I start the laptop, which can be changed via the icon on the tray. I am wondering if your problem lies with accessing it from Firefox as an add on and not directly from their website.

Other than that I can only agree with Keith & Rich J.

Hi Guys,

Thanks for the replies, when I searched for PIA via Google, all of the websites showed in the list, but clicking on the “page not found” (this was on my desktop and laptop) but clicking on the links you gave me, I can access them today! OK so I have completed the download and it is saved in downloads, how do I install it (Sorry I am new to Linux/Ubuntu).

I haven’t tried downloading PIA but the usual procedure is simply to double-click on it and it installs via the Software Centre. Occasionally, though, double clicking brings up the Archive Manager which asks you where to put the extracted files - which is a bit more troublesome.
Files from reputable sources almost always install by the former method.


Hi Keith,

I have double clicked on it and it has opened in text editor (hope this is correct) but it is taking forever to install, is it common for text editor to take a lot of time?
many thanks.

It looks as though you haven’t downloaded the right file as it ought not to be a text file.

The file you ought to have is pia-linux-2.6.1-05824.run - Is that what you have?. If so, follow the instructions at https://www.privateinternetaccess.com/installer/x/download_installer_linux.


Hi Keith,
Thank you once again, I now have PIA up and running.

Have a great day.

My pleasure, Mark.

As before: Please mark your first post on this topic as [SOLVED]. Thank you.