pics of SSD, ACER Aspire1 110 zg5

Does anyone have any good pics (or know links to) of the 8gig SSD on this beast? Mine is intermittently connected, sometimes doesn’t boot up + can’t see it, and I’m going to tear it open and try to fix it. Is it soldered in or removable chip??? Thanks. [email protected]

Part Number of the original Acer Aspire One (zg5) 8GB ZIF SSD =
P/N: P-SSD1800 8GB
MPN: GA5N5000018-0H0002

Pic of SSD with cable:

Pic of top showing ZIF (Zero Insertion Force) socket.

Pic of bottom.

Or Google P-SSD1800 for more pics.

Video showing disassembly

Removal of the keyboard can be tricky, so be careful.

Posted from an AA1 kindly donated by Kath C, to help other people with AA1 problems … thanks Kath :slight_smile:

acer aspire one zg5 disassembly]one video [url=]acer aspire one zg5 disassemblyThanks- so that whole card is the SSD + the bulky clip connector is just a connector- does that snap off straight up? Can you connect that to a HD without another cable or adapter? Maybe just have corrosion in the connector, he said optimistically. Course smashing the sides to establish a connection 20 times probably didn’t help, but did give me 2 months use, inc translating jobs. Watched [/url], but the guy had an HD. Those connectors are pretty fragile, eh? Have a bootable flash to recover beasty (done once when accidentally said do 136 updates at once), can I stick a little HD in it, and write OS on it with that flash? Saw one Japanese video where the guy used a Toshiba - “uses ZIF SSD, so thats means the Toshiba MK3008GAL 1.8’ HDD from one of my faulty iPod Video can be use on it.” Is that special low draw amp drive? 我是TJ, TJ是我: 21/09/08鸡场街灯笼比赛!!~

Can’t look at video just now- just doing mobile phone internet (40meg/day). Lost forum address since AA1 wasn’t booting up, but found it on saved pages. But I’m on my way- actually love tearing things apart, but only w service manual.

The HDD from an iPod is supposed to be fine … as long as it’s a 1.8" PATA with a ZIF connector (as used on the earlier iPods), there are plenty of videos on how to do just that on the web … including this page with links to pics and a video:

The black “bulky” part on the cable is a “ferrite core” there to protect against electromagnetic interference, it also acts as a cable holder so they can add a double-sided sticky pad underneath it that sticks to the chip with the white sticker on it … just to stop the cable floating around … though half the time the haven’t stuck them down, ie. the protective layer is still on the sticky pad … it is NOT the connector itself, that is another ZIF socket on the motherboard that the end of the cable is inserted into.

If you look at the second picture the little black “lip” on the ZIF connector just lifts up … then you insert the cable, and push that black part back down … same at the motherboard end.

Usually when an SSD fails you start getting write failures, so if the drive is disappearing altogether, and banging the AA1 on the side caused it to reappear, I’d say there’s a fair chance it is just a loose cable, as there are NO other moving parts to an SSD.

Another option would be to run another Linux distribution, such as PeppermintOS from a USB stick … it is MUCH slower booting from a USB stick than an HDD or SSD, but works OK once booted … but is useful as a stop gap measure (or even permanently if you can live with the slower boot times) … I’ve got PeppermintOS installed to the SSD where it’s just as quick as Linpus Lite, and as it’s based on Ubuntu 11.04 has a LOT more “up-to-date” software available.

If you want information on putting PeppermintOS (or any other Linux distribution) on a USB stick, let us know.

Well, I finally done it- ripped apart my AcerAspireOne 110 zg5, to try to fix the non-booting (cable connection on the SSD?), after studying a few videos and many pics. Not enough- you just cant be too careful- I tried to take off the top cover without detaching the ZIF ribbon cable to the twin batteries on the lower case (what are these for, and should I have replaced them) . Thought I ruined it- it looked canted so I tried it push it back in w a tweezer, damaging it more.

These cables are very confusing- the ZIFs have a black clip cover that pivots down to clamp the flimsy wires (where you dont even see metal)- you gently pry it up from the middle and it pops up, releasing the zero insertion force cable. Reattaching it is the crucial part though, the clamp crimps the wire- if you line it up 1/4mm wrong, and you are screwed- its got ridges that do guide it in there though. Where I had a hellish problem was the plug and slot connector on bottom middle of motherboard- that simply didn’t want to release rocking + putting an almost killing force on it. The display connector is also a metal plug and slot connector that can be rocked from either side- pretty standard, as is the connector between motherboard parts. The clip on the top of the SSD card is NOT hard attached to the cable- that slides freely through the slot. I pried this thing off the sticky pad with an almost killing force- glued it back w a drop f contact cement, all unnecessary.

Even after 3 years, it’s condition was almost virgin- no real dust or dirt accumulated and as far as I could see the connector to the SSD was perfect, but I took both sides apart and reattached em (never detached SSD from case).

The big news was there WAS NO RAM. We Opened the skull and THE BRAIN WAS MISSING- where the RAM is in the video that people upgrade was empty. I was stunned- guess it’s on the board but never figured out where and forgot to take a photo of that side. Since it was from Ukraine w Cyrillic also, thought maybe they stole it, but its been working for 3 years all over world so it must have the too little 512K. Mobile phone modem constantly freezing so couldnt study many pics + videos.

To prevent having to take apart that devilish layer cake again, I wrote a pattern on the bottom + cut a sloppy hatch with a hot knife to access RAM later, when it comes from Ebay, though might not have made it wide enough- didnt want to trash the vents screen. Can I add 1meg of RAM to it or only 512K and how fast- see some Ebay 800Mh that they claim works in ZG? With 1.5 gig, this thing would fly. Also the RAM clamp didn’t hinge flip up like I saw on the video- looked solidly attached and one just pushes RAM straight in and make sure metal clip encloses ends. While you have it off, clean the keyboard well and wash off dust on top cover. Mine was so clean (I only use clean hard surfaces)- I never even took off the fan, which had no dust.

Everyone puts a HD in it, but I like the shock resistance and simplicity of SSD- if this one is so lousy, is there a better faster bigger one that anyone recommends?? 16-32g? Will anything work that takes that ZIF cable?

Was hot too see if it worked (without which further improvements were moot) , so reassembled it in 7 hour marathon till 10:30am. Was sure it was toast, but seems to work beautiful. Wifi is so much better than big lappy that I can share my neighbors Wifi, if they accept my payment. In a separate house, so no one will wire it here (only apartment bdgs), and roommate owes $150 on phone bill - so no DSL

Yes there are larger SSD’s, but make SURE it has a 40pin ZIF socket, and is an IDE (PATA) SSD … such as

Yes the 512MB module is soldered directly onto the motherboard, and there is a standard (empty) 200pin SODIMM socket which cam take a 1GB SODIMM.

Specs: DDR2 PC2-5300 • CL=5 • Unbuffered • NON-ECC • DDR2-667 • 1.8V • 128Meg x 64

Thanks. Which chip is the onboard RAM? Does the RAM have a hinging housing, or does it push straight in flush with the motherboard?

Will this one work- it looks to be 6400 (800Mh?), but the label is almost illegible. The guy got it from some Acer One, doesn’t remember which (probably junked)

This one claims to fit 110 ZG5 and is also 800Mh.
Would that cause conflict with on-board memory, or just run at lower speed (533Mh). Does the AAO run the onboard first and then the additional RAM, or will it start a bigger strip first

First I have to say I haven’t upgraded (added) any RAM yet to mine.

Secondly I won’t specifically comment on the 2 (ebay) modules you’ve linked to, as I don’t know enough about them … I’ve had problems with cheap high density modules bought from ebay in the past, so I’m not going to say they are OK for the AA1 or not.
(pictures on ebay are NOT always representative of what you get)

AFAIK, the RAM socket on the AA1 is a standard SODIMM socket, so the module will probably be inserted at roughly a 45 degree angle, then pushed down till parallel with the socket so the metal clips hold it in place) … see step 6 here:

The 2 modules you’ve linked to are BOTH PC2-6400 (800mhz) … the AA1 uses PC2-5300 (667mhz) … usually fitting higher rated (bus speed) RAM is ok, as the RAM will just be run at the speed of the memory bus.

it’s the bus speed that governs the speed of the RAM, not the other way round, so fitting faster (bus speed) RAM will NOT speed up a PC

Think fo it like this … the AA1’s memory bus runs at 667mhz, so it needs RAM that can handle that frequency … but if you chuck in a module rated to 800mhz, it will still only run at the frequency of the bus, which is still 667mhz.

Personally I’d look for a DDR2 PC2-5300 (aka. DDR2-667) 1GB SODIMM

The decision to purchase either of those is YOURS … all I’m willing to say is IF they are low density modules, they will PROBABLY be OK.

Any particular reason you don’t want to order directly from Crucial ? … at least it then comes with a guarantee.

BTW, is it just me, or does the second hand Kingston module you linked to here:
look damaged in the second picture, by the guide slot ?

They have a lifetime warrantee. Youza. Well that used 800Mh one claims it only was used for an hour and is almost free. Just got 6 cell battery, MP3 player, and a bunch of stuff and recharging PP is a problem. Faster RAM can’t damage a system, can it, just be unstable with onboard units.

Faster RAM can't damage a system, can it, just be unstable with onboard units.

See above :wink:

“Faster” (in this case) is the wrong word to be using … the RAM you linked to is rated at a higher frequency (ie. the clock cycle of the memory bus).

Sticking a DDR2-800 module on a DDR2 bus that runs at 667mhz wont cause any damage at all.

Now if it was the other way round, you’d probably damage the RAM module.

But before you consider buying that Kingston module … see the picture in my last posting.

and “lifetime warrantee” … well read into that what you will, the small print usually make it meaningless.

Thought that was a flash anomaly, but think you talked me out of it with 12min to go. Dope doesn’t even know what he took it out off, since he “upgraded an hour later”. density is important; how about NON ECC (not European Community?), and unbuffered. If high-desity RAM is so useless, where does it come from? What uses it? The bluetooth mod does kernal module upgrades. but must apparently be set up one device at a time.

Well IF he’s talking about an AA1 (at least the AOA110), he’s lying as you can’t put a 2GB module in it … well you can but it will either not work at all, only 1GB will get used, or most likely it will throw up a ton of errors

Anywho … ECC (and/or Parity) memory … oh, sod it, see Wikipedia :wink:

Same for Buffered (aka. Registered) memory:

Effectively you NEED an Unbuffered, NON-ECC module for the AA1 … besides the fact that it wouldn’t work Buffered ECC would cost you a LOT more :slight_smile:

That said I don’t know if anyone ever made Buffered ECC SODIMM’s ??

If high-desity RAM is so useless, where does it come from?
Cheap a** manufacturers trying to save a few pennies .. BTW, in this case the term "high density" is being used as a generic term to describe memory chip layouts that don't conform to the JEDEC standards .. so aren't guaranteed as supported by most memory controllers.
What uses it?
*Some* PC's memory controllers are fine with it (don't know about the AA1), but most aren't .. oddly enough I would doubt if that 1GB Kingston module is high density, but I'd steer clear of that because of the picture.

With RAM prices so low, I wouldn’t risk buying from anywhere that I may find it difficult to return it to … even new branded memory modules sometimes have bad chips.

I have a different model of Acer Aspire One, I think it is a D250, I picked it up as a parts machine and rebuilt it so I don’t have the label that tells what model it is.

At any rate this unit came with no ram, no hard drive, and for that matter no screws on the case. I had an old ddr2 2 gig module that would not work in my Gateway M285E, even though it’s exact sister did work, so I figured this module was garbage. With that in mind I decided to try the bad module in this machine, and to my total surprise, it works GREAT. I installed an old 120 GIG SATA hard drive that had been living in an external case and was used to transfer files into the unit, and it booted from a bit of Vista that was left over from the last time the drive was used in a PC, however it didn’t work all that well since it wasn’t installed on this machine. So a quick setup with removing all partitions and starting the machine from an external USB DVD drive with a DVD with what the maker called a 48 in 1 Windows 7 DVD, and selecting Windows 7 Starter (that is what the sticker on the bottom with the SN said it took) I went through the setup and had a working computer. In fact it works GREAT! I am very happy with it, and because the machine was designed for Windows 7 Starter, there were no problems getting it validated by MS.

Then I looked through my substantial screw collection and located enough screws to put the machine together, purchased a 9 cell battery from Amazon as well as a charger/power pack so I didn’t have to use my all-in-one power supply I use to fix machines and I have myself a nice little netbook that runs as fast as most of my other machines which have twice the power processors. I am very satisfied with the machine.

At any rate, I was supposed to be commenting on the RAM, and my conclusion is, don’t toss those “bad” chips, they may work in another machine, even though I purchased these as NEW off Ebay.