Pixlr Photo Editor problem (Solved)

I am having problems with Pixlr Photo Editor. I open Peppermint 7 and when I try to get Pixlr to open it says that Flash plugin has crashed.
Is there something going on with Pixlr and will I need to abandon it and use Gimp.

Sounds more like a problem with flashplayer

What’s the output from:

dpkg -l | grep flash


locate libflashplayer.so

and does pixlr work or not … is it just the adverts that are crashing and not pixlr itself ?

Hi Mark,
Pixlr works. I have AdBlock Plus installed, could this be causing a problem ??

I ran the commands and got this
don@ldwatson ~ $ dpkg -l | grep flash
ii flashplugin-installer amd64 Adobe Flash Player plugin installer
don@ldwatson ~ $ locate libflashplayer.so

Unlikely because plugins in Firefox don’t carry over to Ice SSB’s

Ice SSB’s that use Firefox as the backend require plugins on a per SSB basis … so unless you specifically installed ABP in the Pixlr SSB it wouldn’t apply there.

In Firefox, can you go here:
and test flashplayer.

did it work ?

Hi Mark,
I went there and there was a jigsaw piece in the middle of the screen asking me to ‘Click to update’. I did so and the program worked ok.
It twisted and turned as it was supposed to do but not very fast, but I suppose ‘fast’ is very relevant in this test.
So yes it did work.

Okay try this … open a terminal and run these commands in sequence:

sudo apt-get remove --purge flashplugin-installer


sudo apt-get install adobe-flashplugin adobe-flash-properties-gtk

now close ALL running web browser instances (including any SSB’'s) … then reopen Firefox.

Now test the flashplayer here:

And let me know if pixlr is still giving you problems

Hi Mark,
When I open Firefox and carry out your suggestion the correct page opens but nothing comes up on the little screen.

When I choose Graphics>Editor by Pixlr it now shows a screen that says

Hi there,

We’re quite sure you have Flash Player installed on your computer. So no worries, just click anywhere on the page and a prompt will appear for you to enable Flash.

If you have not downloaded Flash, you can click here to get it installed. :slight_smile:

When I click on the page it warns me that I haven’t saved anything and I will lose it I continue ??
If I leave the page nothing happens. I am losing the will…

Can you post the output from:

dpkg -l | grep fresh


Stop worrying my mate, we’ll fix this :wink:

Hi Mark,
A bit strange this one

don@ldwatson ~ $ dpkg -l | grep fresh
don@ldwatson ~ $

EDIT I have just been to the page from Graphics>Editor by Pxlr and when I ‘Leave’ the page it takes me to an Adobe Flash Player ‘Download’ page. Is this any help.

You will get that error if you have flash installed but disabled.Check in your firefox browser >tools>addons>plugins .Adobe flashplayer should be installed there .Check its not disabled.

I don’t have Flash Player in tools>addons>plugins ??

I wonder if the problem is firefox and other browsers is apparently abandoning flash?. According to the article below flash in firefox in 2017 will be click to activate on flash pages.Maybe your adblocker is blocking the activate flash popup?If not try installing/reinstalling flash here…

The article below seems to apply to android though its has started in pc browsers too.

I f all that fails you might like to try palemoon browser which is a fork of firefox and shares most of firefox addons .Im currently running that and flash works fine with it at present.

Strange… there’s nothing in there called “Shockwave Flash” ?

If not, can you run:

sudo updatedb

then post the output from:

locate flash


dpkg -l | grep flash

Hi Mark,
I carried out those suggestions, what next ??
locate flash delivers a couple of pages of info. do you want to see it. ??

dpkg -l | grep flash returns nothing.

You must have forgotten to run this then:

sudo apt-get install adobe-flashplugin adobe-flash-properties-gtk

then close ALL web browser instances (including SSB’s) and reopen Firefox.


Tools > Addons > Plugins

now show “Shockwave Flash” ?

Sorry Mark,
Still no sign of Flash Player in there.
All it says is
OpenH264 Video Codec provided by Cisco Systems, Inc.

the other command still shows
don@ldwatson ~ $ dpkg -l | grep flash
don@ldwatson ~ $

Ah right, my mistake … I forgot to tell you to enable the “partner” repo first … sorry about that :-[

Go to

Menu > Preferences > Software & Updates

Choose the “Other Software” tab

Put a tick in the box labelled “Canonical Partners” … you’ll probably be prompted to enter your password.

When there’s a tick in “Canonical Partners”, click the “Close” button … then the “Reload” button.

Once that Window has closed, open a terminal and run:

sudo apt-get update


sudo apt-get install adobe-flashplugin adobe-flash-properties-gtk

now see if you get output from:

dpkg -l | grep flash

and if Firefox shows Shockwave Flash

and if Pixlr works.

Hi Mark,
I get this
don@ldwatson ~ $ dpkg -l | grep flash
ii adobe-flash-properties-gtk 1:20171010.1-0ubuntu0.16.04.1 amd64 GTK+ control panel for Adobe Flash Player plugin
ii adobe-flashplugin 1:20171010.1-0ubuntu0.16.04.1 amd64 Adobe Flash Player plugin
don@ldwatson ~ $

tools>addons>plugins show Shockwave Flash 27.0r0

When I go to Graphics>Editor by Pixlr it opens with the usual page and when I choose Open Image from Computer it says that Flash has crashed

Okay this seems to be an issue with Firefox 56 because I’ve downloaded the Firefox 57 beta and Pixlr works perfectly with it. So until they release 57 about the only way around this I can see would be to install Google Chrome, then rebuild the Pixlr SSB using Chrome as the backend.

Do you want instructions ?


Well there is another option, which would be to add the Firefox Next PPA, which will install the Firefox 57 beta ?

Thanks Mark,
I can use Gimp in the meantime. I can wait until Firefox 57 is released.
I also have access to a Win 10 computer and can manipulate pictures there.
I will mark this solved if that is ok ?

Don W
EDIT I am finding some odd problems with this site at the minute.
When I post a reply it takes me back to the first page and there is a banner headline in red saying someone has posted another comment would I like to review my post ?? Also it sometimes takes me back to a different page from the normal one ??