Please tell me I'm doing something wrong...

Ok, so I’ve been having a bit of trouble using WINE. Please tell me I’m doing something but I can never seem to get .exe files to run. It always tells me that it’s blocked because it’s untrusted :o I’m adding the programs to the applications list and placing the files in the virtual program files folder, so I don’t understand what I’m doing wrong…

Please help :frowning: ?

Have you marked the .exe as executable ? <— Linux disables the execute bit of files that don’t come from a known source by default, as a security feature.

chmod +x /path/to/file.exe

then try running it.


Right-click on the .exe file, select Properties, select the Permissions (tab) and put a tick in “Allow executing file as program”. Then hit the Close button.


There is another solution… you can change the default launch behaviour of ALL WINE applications… if you want to know how, just ask.
(ie. remove WINE’s cautious approach to launching .exe’s)

So how do I remove WINE’s cautious approach to launching .exe’s? :stuck_out_tongue:

sudo gedit /usr/share/applications/wine.desktop

Find the line:

Exec=cautious-launcher %f wine start /unix

and change it to:

Exec=wine start /unix %f

SAVE, and exit gedit.

BE AWARE - you are removing a Linux security feature by doing this… ie. Linux doesn’t set the executable bit of .exe’s that have just arrived on the system, so they cannot be executed (at least the first time) without your express intervention… effectively, the only way a malicious .exe could run is if you give it permission to.

Although oddly enough this seems to be the default setting for WINE 1.3 in Natty ::slight_smile: