PM3 wont shutdown

Hi Guys

This is not really a serious problem and I’ve been putting up with it for a while, but my old Dell D600 laptop wont shutdown, during shutdown it get as far as stopping print spooler: lpd then an endless flashing cursor, after a while I just press the power button and it shuts off

Any help would be much appreciated


Further to my last post I’ve since realised it can stop at various stages as well as stopping at print spooler as per my first post it has on another occasion stopped at stopping webmin server and btsync instance on another occasion

Will it shutdown with this command:

sudo shutdown -P now


yep that shutdown properly

Has it ever shut down properly ? … is this a new problem ?

Has it ever shut down properly ? .. is this a new problem ?

Yeah it’s a new problem it used to shutdown fine the problem seems to have coincided with btsync not working but i honestly can’t remember the series of events that led to this so I’m just guessing.

the problem is a wee bit elusive because in an attempt to nail it down to one application I completely uninstalled btsync and it shutdown immediately after that fine
then I reinstalled to confirm that was the problem and sure enough the problem came back, but any attempts to uninstall btsync since doesn’t help

I hate shutdown problems, they’re always hard to diagnose.

What’s the output from

ls -a /etc/rc0.d
graeme@Linux-Laptop ~ $ ls -a /etc/rc0.d
.                       K10webmin   README  S60umountroot
..                      K20hddtemp  S20sendsigs  S35networking    S90halt
K10unattended-upgrades  K20lpd      S30urandom   S40umountfs
graeme@Linux-Laptop ~ $ 

If you boot an earlier kernel does it shut down cleanly ?

If you boot an earlier kernel does it shut down cleanly ?

Makes no difference :frowning:

Do you get any errors if you run:

sudo apt-get update

or if you attempt to install something from the comand line … say leafpad

sudo apt-get install leafpad

(you can remove it later)

I tried updating and no problems were reported and installing leafpad also reported no problems, so I just bit the bullet and reinstalled because I felt this was gonna be a nightmare to sort out, apart from the shutdown problem, I couldn’t get btsync to work properly, and the final straw was when I tried to sign into Ubuntu One with my password everytime I pressed the No2 key (which is part of the password) the laptop instantly shutdown, the only way I could enter my password was to copy and paste it from the text editor

Reinstalling really takes no time at all, all done in a couple of hours including updating, installing software and generally setting it up the way I want, I have one issue which is auto mounting my network shares from my NAS but I’ll start another thread for that if I can’t figure it out myself.

Many thanks for your help


Okey dokey … sometimes that’s the quickest solution (and one I occasionally choose) … even if it does smack of the Windows way of problem solving :slight_smile: