Printer Problem(Solved)

Hi Guys,
Having a problem again with my HP Photosmart 5520 All-in One, cant get it to print on either my Laptop or Desktop.
Laptop is running Peppermint 4 64 bit, and the printer has worked in the past. Desktop running Ubuntu 12.04, again been able to print and scan etc in the past now get the same error on both machines as follows:
HPLIP Device Status. Photosmart_5520_series Printer (
Device Communication Error (5012)
The printer is connected wirelessly, and just for info, prints no problem from my iPad2.

Your help and input, as always would be much appreciated.

Many thanks in advance,

Hi Everyone,
Very pleased to say that I Have managed to sort this problem out now, it was as simple as setting up the Printer again in Device Manager, though why this went awry in the first place I just don’t know, anyway the outcome is satisfactory and I am now able to print again from the Laptop. I assume the problem will be solved in the same way on the Desktop, just haven’t had time to try iot yet.

Thanks again, Degsy

Is this a networked printer … if so the IP address it gets from the router may have changed … give it a static IP address :wink:

It is network printer, how do I give it a static address please Mark?

OK to do it properly, you’ll need to know -

a) your routers IP address
b) the start and finishing addresses of the routers DHCP pool
c) how to change the printers IP address from the printers own control panel

Do you know these things ?

Hi Mark, to answer your questions in a word, No, I don’t know these things.

OK, right-click the networkmanager icon in the system tray, and select “Connection Information” … what does it say next to

IP Address: ??.??.??.??
Default Route: ??.??.??.??

IP Address:, and
Default Route:

Hope this is alright,

OK, your routers IP is likely to be

What is the make/model of your router ? … was it supplied by your ISP ? … and have you changed it’s default login password at any stage ?

Hi Mark,
The router is Huawei Echolife HG520s and was supplied by talktalk, my ISP. I have not changed the login password, only the Security Password.


So if you enter this into your web browsers address bar:

then hit enter … are you prompted for the router login/password … and are you able to log into the router ?

I assume that you meant and yes can log in to the router,


Opps … bear with me, half way into a bottle of 12 year old Appleton Estate Rum :slight_smile:

Yeah that’s what I meant.

OK. log into the router and see if you can find anything that references “DHCP Pool” or DHCP range" which gives you an IP range similar to —>

And let me know what those starting and finishing addresses are.

Hi Mark,
Logged in and hopefully this is the info you asked for:
Client IP Pool Starting Address:
Size of Client Pool: 253

Does that look like the right thing?


Yeah that looks right :slight_smile: … if a bit weird (normally they’d give the starting snd ending IP rather than the number of IP’s.

But who cares … is it possible to change the

"Size of client pool" to say 200
(which I figure will represent → [inclusive])


Yes, the box containing the figure does allow me to delete and reinsert a different number.

Keep looking in the router settings then … somewhere in there there must be a setting that allows you to change the DHCP pool size/range

So on this screen you cannot change
Size of Client IP Pool: 253
Size of Client IP Pool: 200
and click submit ?

Yes, I can do that, sorry, thought that was what I had said originally, it was certainly what I meant.


Should I go ahead and change to 200 and submit?

YES :slight_smile: