Printers [SOLVED]

Asus UX301, Peppermint 9. Looking for a new printer and cosidering hp desk jet 2630. Is this one compatible with Peppermint? Alternative suggestions?
G R Hyde Solved

Hi Osmond.

HP supports Linux very well, in particular with the HPLIP printer management software which is excellent. If you search the web for Linux-compatible printers, HP always comes out on top.
The hp desk jet 2630 is a cheap & cheerful printer that should work well, but it will be rather slow, and expensive to run, because of it’s multi-colour cartridge. It appears to be obsolete now, as far as I can tell.

I wouldn’t recommend Canon printers as Linux is not well supported except (according to the web) via 3rd party software. I have run a Canon on Linux but it was a pain.
Epson printers can be a bit fiddly to install, but the quality is good, like HP.
I’ve seen some good reports of Brother printers on Linux, but I’ve not tried one.

Overall I would recommend the best HP printer that you can afford, particularly one with duplex printing and separate colour cartridges. Have a look through here: I wasn’t particularly impressed with the HP Envy series but I’m fussy. By and large I find that a £100 printer provides best value for money, although many people on a tight budget might struggle with that.


Hi Osmond
I agree with Keith HP have by far the best support on Linux, I’ve also found Samsung are also well supported

Here’s a useful site that may by of help to you

Good luck


Hi Osmond,
For what its worth, would agree with keith and Emegra, I have used HP Printer with Peppermint, 6,8, 9 and now 10, and also with Linux Lite and Windows 10, no major problems.


Many thanks to you all. Have installed an HP Desk Jet 2620 which will be adequate for my modest needs. However having difficulty setting it up. Downloaded HPLIP 3.21.2 and connected WI-FI. Cannot get HPLIP tp run Any thought?


And getting the message: Failed to execute command “/user/bin/hp-print settings” Sorry about that.


Sorry to be picky:

“Connected wifi”…I take this to mean that you have set up the printer to connect to the router wifi - true?
If you go to System Settings/Printers, is your new printer listed?

You say you have downloaded HPLIP…and did it install without errors?
Try this command:

ls /usr/bin/hp-print

This should tell you if symbolic link is present or not.


By Wi-Fi I assume this is between computer and printer. The Wi-Fi setting is made using settings at the printer.
The reply to your piece of code is: No such file or directory.


It looks as though you have downloaded HPLIP but not installed it.

ls /usr/bin/hp-*

There ought to be about 20 files. If there aren’t any then you definitely haven’t installed HPLIP.


Reply to your code: No such file or directory. But I have “hplip-3.21.2” on my desk top and when accessed a large number of files comes up. There is a second “” which produces: "Do you want to run, or display its contents? When run is entered “HPLIP 3-21-2 Self Extracting Archive” comes up. There are no “buttons” to press on this display.


OK. This is just the compressed downloaded file that needs to be “extracted”.
What is the extension of the file? (eg .deb).
As Peppermint is Ubuntu (Debian) based, the *.deb version will probably be OK.
Go to HP Developers Portal | Installer Walkthrough and follow the installation instructions.


Went well until I got to connecting the printer. Probably because the printer was set to Wi-Fi. Now set to wireless. However I’m told “…set-up failed. Please run hp-setup manually”. I’m a bit wary of this. Can I do it automatically?


Hi Osmond.

Printer set to wi-fi is fine - it’s the same as “wireless”.
Just start a terminal session (Ctrl+Alt+T) and enter the command:


as suggested and report back.


hp-setup completed. Had to use USB connection. The printer appears to be connected to the computer but when attempt to print a personal document a sheet of clear paper emerges from the printer. It would appear that the document is not being fed to the printer.


Start the HPLIP Toolbox from the menus. It will take ten seconds or so to get printer information.
Select the “Actions” tab.
Click on “Print test page”.

Does that work?

While you are there you can set up your desired printer default operation in “Print Settings”.


Test page printed successfully. Set as default printer


So can you now print documents?


Test print was successful. Selected default.

Yes, you said earlier; but can you print a document of your own?

First try failed. In the “Print” window there are the following printers listed :
DeskJet 2600, HP_DeskJet_2600_series_C8A2E5, HP-DeskJet-2600-series, hpdeskjet2600all-in-one. First try was with the third listed. I moved to the second listed and printing was successful on a personal document. Is it possible to delete all printer names except the one that worked?