Problems creating a new user on Peppermint 3

I have a Dell Latitude D505 that I want to give to a friend. It’s running Peppermint 3 very well and here’s the uname info:
Linux D505 3.2.0-126-generic #169-Ubuntu SMP Fri Mar 31 14:16:01 UTC 2017 i686 i686 i386 GNU/Linux

I kept my account as administrator and added my friend as a “custom user”; both with “enter password on login” status.
When I rebooted, the machine went straight to my account without asking for my password. Just to check that the new account was present I did ls -l home/olwen which showed no files but no error. Trying ls -al home/olwen showed that the account was there (a few hidden files) but nothing else, although I was expecting the usual Desktop, Documents, etc. Hmmm!

I would be grateful for advice.

(p.s. Why haven’t tried the latest Peppermint? We tried and failed:

What’s the contents of

gedit /etc/lightdm/lightdm.conf


Here it is:


Interesting that it says autologin-session=lightdm-autologin. I’ve just checked the user accounts again and they are definitely set to ask for passwords.

if you run:


then select the “Logout” option.

Are you able to log into the new account from the login screen ?
(ie. Is this just a problem because the “keith” account is set to autologin ?)

If so, run:

sudo gedit /etc/lightdm/lightdm.conf

and change the line




SAVE the file, and reboot to test you now end up at the login screen

I was able to login as the other user after logging out then back in again, and changing the .conf file now shows the proper login screen. Thank you.

An interesting effect is that I can’t shut down the computer by clicking on “shutdown” at the login screen, so had to hard-stop it. But I shall try a few times and report back.
By the way: how do I add a user to the sudoer list?

In “users and groups”, make the account an “Administrator”.

I did that to start with, Mark, but checking just now shows it has been reset. Perhaps editing the *.conf file reset it.
Anyway, everything seems to be working well - many thanks.

As an aside, I still haven’t been able to persuade the machine to accept a Peppermint 8 live usb, so I’ll have to give it to my friend until it dies a natural death.

My thanks again,

Peppermint 9 is out.

AFAIK the D505 should work with Peppermint 8 or 9 (32bit) … though you might need to add the forcepae kernel boot parameter.

Yeah, we tried that in but the system didn’t respond. Just sat and looked at me.

If you have any other ideas about that perhaps we should go back to that post and try again?