Problems with Mint 13 Freezing.

Only recently I posted a comment that Mint was a slick operating system in these forums…I wish I had kept quiet!

Problems with peppermint on my netbook have been resolved to a degree. This time my Toshibia Equium 2gb using Mint 13 is freezing. this happens when for instance I try to save a file in Libre spreadsheet and more recently when trying to edit an Ebay listing. The only way to un-freeze is to keep my finger on the power button and switch off all together and if that does not work, pulling the power cable and removing battery.

Anybody else had any problems?

Is there any USB devices connected to it?

If you’re sometimes having to pull the plug and remove the battery, I’d guess it’s a hardware problem.

or maybe an overheating problem … and removing the battery etc. is just giving it time to cool ? … have you noticed it feel warmer since Mint 13 ? … Does the fan come on ?

And now for the compulsory lecture :wink:

NEVER (repeat NEVER) turn off a PC by holding the power button unless totally necessary … one day you’ll regret it, and end up with a screwed up file system … ALWAYS try this first:-

Hold Alt+SysRq and whilst holding them type R E I S U B leaving a few seconds between keystrokes … this will SAFELY reboot a Linux PC in ALL cases other than a kernel panic (or a hardware lockup).

REISUB can be remembered with:-
Reboot Even If System Utterly Broken

Other info - SysRq is commonly also the same key as PrtSc (printscreen) … and on some laptops only the AltGr button works for this, on others only the Alt key will do the trick.

If you want to know what’s going on in the background when you type R E I S U B … here’s an explanation courtesy of Kirrus:

R = Take control of the keyboard
E = Tell all running programs except from the master control system to terminate
I = Forceably kills any programs which didn’t shut down from the last command
S = Force any unwritten, cached data to be written to the hard-drives. Some files, when they’re written to your hard-drive are cached in RAM, which is wiped when it looses power, in order to speed things up. This command makes sure they’re all written to the drive OK.
U = Remount the drives read-only, makes sure nothing can write to your hard-drive(s)
B = Restart the system

one last thing …
R E I S U B = Reboot the PC
R E I S U O = Power OFF the PC

@BKS I have a 7 port usb hub installed.

@ Mark That’s me told then. :wink:

It’s not over heating it’s a dual boot Pepermint 13 and MS Windows setup. No problems in Windows. Just when saving a spreadsheet file and when using ebay. Currently using latest Firefox, but that would not affect Libre office would it?

No it wouldn’t … but what might is some bad sectors on the hard drive …

If you start “Disk Utility”, and check the drives SMART data … does it indicate any problems ?

Try doing the same with the USB hub (and other USB devices) removed from the equation … does that make a difference ?

Which version of Mint 13 are you using ? … MATE or Cinnamon ?

Cinnamon. I am away from the computer at the moment. Will check disk when I get back.

I found that my Logitech webcam would lock-up my system when using Gnome 3, so I just unplug it whenever I boot into GS. That way I get rid of the problem.

Could be a similar problem for you, seeing as Cinnamon uses Gnome 3 libraries.


Smart data says
Relocated sector count (Warning in red.)

Type: Failure is a sign of imminent disk failure (pre-fail)
Updates: Every time data is collected (on line)
Raw 0x50000000000

In SMART Data … what is the “Overall Assessment” listed as ?

Also is there anything in the “Value” column for “Reallocated Sector Count” ?

and is there anything for “Current Pending Sector Count” ?

Pre-fail under “Reallocated Sector Count” is not necessarily (and on its own) something to worry about … these sectors have ALREADY been remapped (to a small spare part of the drive that’s set aside for this exact purpose) … but if there is a value greater than zero, and it continues to rise … eventually you’ll run out of spare sectors for data to be remapped to … also, a rapidly rising count could indicate an imminent disk failure … so keep your eye on that count.

Current Pending Sector Count” (pending remaps) are worse … they are sectors that couldn’t be read/written on the last attempt … if something is already written to them, and can’t be read, it cannot be remapped … if it’s something important, it could (possibly) cause a system lockup.

It reads.

Normalised: 100
Worst: 100
Threshold: 100
Value: 5 sectors

As I said keep an eye on that sector count (currently 5), unless it rises sharply, it’s not necessarily a problem in and of itself :slight_smile:

I repeat - is there anything listed under Current Pending Sector Count ?

Is it still freezing ?

if so, have you tried running fsck (file system check) by running:

sudo touch /forcefsck

Then rebooting

Have you tried doing whatever causes it to lock up … without the USB stuff attached ?

You might want to go back into the SMART Data, and run a disk analysis … eg. surface scan.

If it’s still doing it after that … we’ll have to see if there’s anything getting entered into the logs … but somehow I doubt it.

Current pending sector count says N/A

Message in smart data says there are a few bad sectors.

I have took it to work with me minus the usb hub and as yet it has not frozen. However I have just tried to open a spreadsheet and it had to recover it (successfully).

Was that the same spreadsheet that it crashed on before ?

No, different one.

If you ran a surface scan from the SMART Data section of Disk Utility … and it found some bad sectors … has the “reallocated Sector Count” changed" to reflect the were remapped ?

Has anything else changed in SMART Data ?

I tried your command line scan but it did nothing. I will run via the panel now and post the results.

Every thing is just the same. No more bad sectors etc.

And you did run the surface scan ? … if so was that what said there were bad sectors found ?

I ran the scan from Smart data. Was that correct?

Yes … where it offers “Quick” scan and another 2 options (which I can’t remember) … is that what reported that it found bad sectors ?

Have you also done the:

sudo touch /forcefsck

then rebooted to run the file system check ?