RALink rt5572sta wifi connectivity issue in openSUSE

I was recently able to a RALink dual band usb wifi adaptor working in Ubuntu with the help of this thread and Mark Greaves’ very neat solution:
The problem is that Ubuntu is on my desktop pc, and openSUSE and windows are on my laptop.
With the Ubuntu desktop, I got (by my experience) amazingly fast large file transfer speeds over the network at 20 MB/s. I’m really hoping I can get something comparable on the laptop.
When I tried the method described in the link on openSUSE, I got hardware and connectivity on the 5.8 GHz band and got IP very quickly, but i could barely get ping, even to the router, and I managed to get a webpage to load after 20 minutes of playing around with it. Depending on which kernel I booted with (desktop or default), I got system freezes after opening firefox. Desktop kernel seemed more susceptible to this.
After getting some advice, I tried the new RALink driver at :

and installed after editing the config.mk file appropriately.
This time I got a nifty new feature, as the LED light came on, and network manger reported good connectivity, but still no good TCP connectivity. I couldn’t ping at all.
I tired the manufacturer’s drivers with Windows 7 on the same laptop (incidentally, the same cd came with Linux drivers, and a readme that said the makefiles have to be configured manually, but no advice on how to do so.) I got impressive connectivity, although not as impressive as in Ubuntu: 9 MB/s+ with large file transfers over the network. Still, I’ll take that any day over the built-in Realtek adaptor.
I found a package in Packman (openSUSE) called rt5572sta, but installing this rpm didn’t appear to do anything , as none of the modinfo info had changed.

I would appreciate any help I could get in making this adaptor work. Thanks!

System info: Ubuntu 12.4 x86_64 3.2.0-38 generic on desktop, openSUSE 12.2 x86_64 latest kernel and Win8 on laptop

OK, couple of things to try …

Does it connect if you disable wireless security (or switch to WEP) in the router … just to test ?

What happens if you set IPv6 to “disabe” in your wireless connections profile in NetworkManager ?


if neither of those help, can you post the output from:







iwlist scanning

I’m just trying to work out if any of these patches need applying:

[EDIT 2]

You could try compiling/installing this one from my dropbox:

I’ve pre-patched that one with ALL the (openSUSE) patches mentioned at the build.opensuse.org link above.

Disabling wpa security didn’t help. IP6 isn’t an issue either, I keep that disabled by default.
Here’s the output of lsmod and iwconfig:

openSUSE-laptop:~ # lsmod
Module                  Size  Used by
des_generic            21415  0 
ecb                    12815  0 
md4                    12595  0 
xt_tcpudp              12884  26 
xt_pkttype             12504  5 
xt_LOG                 17471  10 
xt_limit               12711  10 
md5                    12627  2 
nls_utf8               12557  3 
cifs                  314953  4 
ip6t_REJECT            12939  3 
nf_conntrack_ipv6      14497  4 
nf_defrag_ipv6         18107  1 nf_conntrack_ipv6
ip6table_raw           12683  1 
ipt_REJECT             12541  3 
iptable_raw            12678  1 
xt_CT                  12717  4 
iptable_filter         12810  1 
ip6table_mangle        12700  0 
nf_conntrack_netbios_ns    12665  0 
af_packet              39358  4 
nf_conntrack_broadcast    12589  1 nf_conntrack_netbios_ns
nf_conntrack_ipv4      15005  4 
nf_defrag_ipv4         12729  1 nf_conntrack_ipv4
ip_tables              27239  2 iptable_raw,iptable_filter
xt_conntrack           12760  8 
nf_conntrack           97545  6 nf_conntrack_ipv6,xt_CT,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ipv4,xt_conntrack
ip6table_filter        12815  1 
cpufreq_conservative    13783  0 
ip6_tables             27207  3 ip6table_raw,ip6table_mangle,ip6table_filter
x_tables               33967  15 xt_tcpudp,xt_pkttype,xt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,ipt_REJECT,iptable_raw,xt_CT,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
cpufreq_userspace      13162  0 
cpufreq_powersave      12618  0 
fuse                   86852  7 
rt5572sta             843628  1 
snd_hda_codec_hdmi     36102  1 
snd_hda_codec_realtek    81862  1 
snd_hda_intel          33312  2 
snd_hda_codec         136135  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm_oss            57810  0 
snd_pcm               109282  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_pcm_oss
alx                    81619  0 
snd_seq                69746  0 
snd_timer              29370  2 snd_pcm,snd_seq
snd_seq_device         14497  1 snd_seq
snd_mixer_oss          22413  1 snd_pcm_oss
uvcvideo               76392  0 
fglrx                2706842  116 
snd                    87206  15 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_pcm,snd_seq,snd_timer,snd_seq_device,snd_mixer_oss
acpi_cpufreq           18857  1 
mperf                  12667  1 acpi_cpufreq
iTCO_wdt               17948  0 
sr_mod                 22295  0 
rts5139               369581  0 
videobuf2_core         32851  1 uvcvideo
videodev              111306  1 uvcvideo
videobuf2_vmalloc      13020  1 uvcvideo
coretemp               13444  0 
videobuf2_memops       13608  1 videobuf2_vmalloc
iTCO_vendor_support    13718  1 iTCO_wdt
sg                     36394  0 
amd_iommu_v2           19097  1 fglrx
i2c_i801               17779  0 
mei                    80083  0 
compat                 13099  1 alx
cdrom                  46687  1 sr_mod
battery                18691  0 
crc32c_intel           12901  0 
ghash_clmulni_intel    13180  0 
aesni_intel            51522  0 
cryptd                 16306  2 ghash_clmulni_intel,aesni_intel
aes_x86_64             17208  1 aesni_intel
button                 13906  1 fglrx
video                  19345  0 
ac                     13097  0 
soundcore              15047  1 snd
snd_page_alloc         18484  2 snd_hda_intel,snd_pcm
pcspkr                 12718  0 
joydev                 17457  0 
edd                    14503  0 
microcode              35772  0 
autofs4                42753  2 
thermal                22790  0 
xhci_hcd              141588  0 
fan                    12959  0 
processor              44907  1 acpi_cpufreq
thermal_sys            24703  4 video,thermal,fan,processor
scsi_dh_alua           17121  0 
scsi_dh_rdac           17408  0 
scsi_dh_hp_sw          12894  0 
scsi_dh_emc            17258  0 
scsi_dh                14554  4 scsi_dh_alua,scsi_dh_rdac,scsi_dh_hp_sw,scsi_dh_emc


ra0       Ralink STA  ESSID:"S*****"  Nickname:"RT2870STA"
          Mode:Managed  Frequency=5.805 GHz  Access Point: 20:4E:7F:xx:xx:xx:xx   
          Bit Rate=162 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=98/100  Signal level:-70 dBm  Noise level:-93 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

lo        no wireless extensions.

It seems signal-to-noise is worse than when I was running the adaptor from windows in the same location, about 5 m line-of-sight to the router.

Have you tried the pre-patched driver from the edit in my last response ?

Just got finished with that. “Make” seemed to process ok, then the final message was
“make: Warning: Clock skew detected. Your build may be incomplete.”
“Make install” ran abnormally quickly and put out the same message as above.
When I started the module, the adaptor didn’t pick up on it and I couldn’t see the MAC in network manager. Uninstall, repeat, same.
I uninstalled that one, went back to the unpatched version, and got a chance to run “iwlist scanning”. It picked up on nearly 10 local ssid’s, including both bands from my router. All the data returned seemed in order, except the signal ( -60-70 dB) seemed lower than it should have been.

Getting late here, I’ll have to pick this up again tomorrow. Thanks for all the help, and I hope I’ve given you enough to work with.

Have you tried (from the iwlist scanning output) checking the channels that are being used by all the other stations … then selecting one (in your router) that nobody else is using ?

Is it possible to disable the 5Ghz band in your router just to test if it’s the “dual” band that’s confusing things ?
(not that this would explain it working in Ubuntu … but give it a shot anyway)

Do you want me to upload a pre-patched driver, but leave out the “remove date time” patch ?

Or would you like instruction on how to apply the patches, so you can try different combinations ?

One more potentially useful thing:
“…config.mk has modification time 18528s in the future.”

…was part on the “make uninstall” output.

My router is the only one broadcasting in the 5Ghz band, which is why I wanted to switch to the higher band in the first place. You can see from iwconfig that it’s on channel 161. Everyone else is on 2.4 Ghz band, and it’s pretty crowded down there, with lots of 40Mhz channels broadcasting.

edit: Sorry, I guess the channel info isn’t in iwconfig! But yes, it’s set to 161 in the router, and when it’s working the adaptor picks up on channel 161.
I’ll have to pick this up tomorrow. Thanks for the help. Actually, since you mentioned it, I would like to know how to apply the patches. I’d be happy to know.

Yeh, but I was also trying to rule out 5Ghz as the issue.

Did you see the last part of my last posting ?

I’ll try to figure out which patch changed the time/date stamp of config.mk


Ok, see ya later … I’ll type up how to apply the patches :wink:

Applying the (diff) patches -

We’ll go through applying the first patch from here:

Lets assume your username is suseman

Lets also assume you’ve unpacked the original ( driver source (from the Ralink website) to a directory in your Home directory called DPO_RT5572_LinuxSTA_2.6.1.3_20121022

First you need to download the rt5572sta- file … but if you click the “download” icon, it wants to save it with the name rawsourcefile … you need to rename it to rt5572sta-

Now open a terminal and “change directory” to the root of the driver source:

cd /home/suseman/DPO_RT5572_LinuxSTA_2.6.1.3_20121022

(that’s IMPORTANT … the current directory MUST be DPO_RT5572_LinuxSTA_2.6.1.3_20121022)

Now apply the patch with:

patch -p0 < /full/path/to/rt5572sta-

EXAMPLE … if you downloaded the patch to your desktop:

patch -p0 < /home/suseman/Desktop/rt5572sta-

Obviously … for the other patches you’ll just need to download them with different names, and adjust the patch command accordingly :wink:


man patch

I hope that made sense ?

Hello were to able to sort out the issue… My own wifi is creating such disturbance so please can you tell the way to solve it…