Re: my last post

Thanks Mark for the explanation on the ‘Rootkit’ but iI still cannot update my Mint 15 distro. I checked out the Mint Homepage and noticed that a repository had shut down. I followed the instruction about gedit in terminal but nothing has changed and I still cannot update. Am I doing something wrong, if not would it be better to wait until the end of the month and upgrade to Mint 16?

It would be helpful if you could give a bit more detail than ‘cannot update’.
Please post the output from the following (run in terminal):

inxi -Sr
sudo apt-get update


sudo apt-get upgrade

Hi SeZo , the first part of your instruction shows as follows:-

dennis@dennis-System-Product-Name ~ $ inxi -Sr
System: Host: dennis-System-Product-Name Kernel: 3.8.0-19-generic x86_64 (64 bit)
Desktop: N/A Distro: Linux Mint 15 Olivia
Repos: Active apt sources in file: /etc/apt/sources.list
deb raring free non-free
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb olivia main upstream import #id:linuxmint_main
deb Index of /ubuntu raring main restricted universe multiverse
deb Index of /ubuntu raring-updates main restricted universe multiverse
deb Index of /ubuntu raring-security main restricted universe multiverse
deb Index of /ubuntu raring partner
dennis@dennis-System-Product-Name ~ $

I understand that Medibuntu repositories have now closed - where do I go from here?

OK. You will need to edit /etc/apt/sources.list

sudo gedit /etc/apt/sources.list

then change the line:
deb raring free non-free
#deb raring free non-free
by adding the # to comment that line out.
Save and close the file.
Then run:

sudo apt-get update

Report (if)any errors.
In none then proceed with the upgrade (update):

sudo apt-get upgrade

See if that will do the trick

Hi SeZo, I tried what you suggested but got the following:-

Reading package lists… Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/packages.medibuntu.org_dists_raring_non-free_i18n_Translation-en%5fGB
E: The package lists or status file could not be parsed or opened.

Any suggestions?


sudo mv -v /var/lib/apt/lists /var/lib/apt/lists-old


sudo mkdir -vp /var/lib/apt/lists/partial


sudo apt-get update

any errors ?

Fraid none of these commands worked.

I have managed to get my updates and package manager working at last !! My thanks goes to SeZo and to Mark for their valuable help.

Glad to hear that you managed to sort your updates.
It would help any future visitors to this topic, to detail how you managed to achieve that result.

I re-read your the mint homepage instructions, together with yours I then realised that I had maybe to type ‘pluma’ instead of ‘redit’. I tried this and, hey presto, it worked.