Re naming a portable HD-SOLVED

I have 2 portable HDs. They have a name when I plug them in. My bro gave them to me- had them awhile. My bro named one Spock as it originally had Star Trek vids on it. How can I change its name? I went into disk utility but couldn’t see how to do it.

Hi Melissa

There’s probably a simple command you can run in the terminal to do this but I wouldn’t know the syntax but it can be done easily in gparted

first with one of the drives plugged in can you post the output of

sudo fdisk -l


Thanks Graeme.

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ sudo fdisk -l
[sudo] password for melissa:

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders, total 78165360 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002c481

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 76724223 38361088 83 Linux
/dev/sda2 76726270 78163967 718849 5 Extended
/dev/sda5 76726272 78163967 718848 82 Linux swap / Solaris

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0944c949

Device Boot Start End Blocks Id System
/dev/sdb1 2 625142447 312571223 7 HPFS/NTFS/exFAT
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

It’s this one’s name I want to change.

Ok first of all you’ll need to install gparted

sudo apt-get install gparted 

once installed open gparted by going to Menu>Systems Tools> gparted

When gparted opens up click the small down arrow on the top right and post back the options please

I expect there to be 2 options similar to /dev/sda (40gb) & /dev/sdb (320gb) but I want to be sure before we go further


You could try (as it is a NTFS formatted drive) to use the ntfslabel command
First unmount it:

sudo umount /dev/sdb1

then check current name (label):

sudo ntfslabel /dev/sdb1

If it is the right one then change it (change my_drive to whatever name you want it to be):

sudo ntfslabel /dev/sdb1 my_drive

to see the full affects of the change you have to umount, remove, put back, mount again.

SeZo You iz da man

Thank you :slight_smile:

But I was nearly there


Please follow SeZo’s instructions

Good luck


Thank you guys. I did what SeZo said and it changed it to my drive a a name. I have tried several times to name it “Dark_Shadows” (which is the TV series on the drive) but it won’t let me:

elissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ sudo umount /dev/sdb1
[sudo] password for melissa:
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ sudo ntfslabel /dev/sdb1
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ sudo ntfslabel /dev/sdb1 Dark_ Shadows

Usage: ntfslabel [options] device [label]
-n, --no-action Do not write to disk
-f, --force Use less caution
–new-serial Set a new serial number
–new-half-serial Set a partial new serial number
-q, --quiet Less output
-v, --verbose More output
-V, --version Display version information
-h, --help Display this help

Developers’ email address:
News, support and information:

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

You have a space in the label title (after the underscore) in the command:-
sudo ntfslabel /dev/sdb1 Dark_ Shadows


sudo umount /dev/sdb1


sudo ntfslabel /dev/sdb1 Dark_Shadows

or maybe:

sudo umount /dev/sdb1


sudo ntfslabel /dev/sdb1 "Dark Shadows"

Thanks a lot Mark. That worked. My computers are driving me bonkers tonight. I am sat on the couch with my laptop on its usual table and the Mint netbook on a tray on my knee. You will soon see another post as to why… :frowning: