Reading an external HDD

I’ve been thinking of getting a 3 TB internal HDD as mentioned elsewhere and using the desktop as a media server.
The wife overheard this and bought me one, trouble is, she bought an external usb HDD.
It came formatted to NTFS but as the TV could not handle this I reformatted it to fat32. I can now read/write with the DT via USB then plug it into the TV and play the media files from it.
What I would like to know is, is there any way I can leave it plugged into the computer and have plex read from it.
I can create a file path to it but plex/USHARE/minidlna can’t read from it for some reason.
I know ultimately I can split the case and remove the HDD and put it in the computer but that seems a little disrespectful.
The drive is a Samsung D3 station.
Any help is much appreciated.

FAT32 isn’t good, as you might have files bigger than the maximum filesize limit of 4GB (an HD movie, for example). If your desktop PC/media station is Linux-based, I’d format the drive to ext4. Much better filesystem than FAT32 (which is so old that Microsoft hasn’t used it as their primary FS for over 10 years).

But I digress… I guess this is a smart TV running Plex? Plex Media Server is available for Linux, so you can run that on your desktop, configure it to point to the external drive, then connect to it from the TV. The fact the drive is external doesn’t matter to Linux, it’ll still mount it. If the PC isn’t on all the time, you can set up a mount in fstab so that the machine always mounts the drive on boot (only do this if the drive will ALWAYS be connected though!).

The only problem formatting the 3TbHd to ext4 is that you can’t partition the full 3TbHd as one, you’ll have to split it in half, as I found out as I have 2 3TbHd’s.
I too wanted to plug the Hd into my TV, a Samsung Series 4, which hasn’t got the capabilities of being networked :frowning:

Fat32 sucks, specially as a file system for media as you cannot have files larger than 4gb.

If it’s ever going to be directly connected to a windows PC, use NTFS

If it’s only ever going to be connected to a Linux machine, and act as storage for a media server … why not use XFS or JFS ?

That is not the fault of ext4. It is the limitation in the Master Boot Record (MBR).
Partitions greater than 2.2TB will need to utilize the GUID Partition Table (GPT) structure.
See here
Here is a guide to help you out.

Have you tried mounting it through fstab (or manually) rather than through gvfs ?

Or creating a symlink to the gvfs mountpoint say in your home directory … the point ushare, etc. at the symlink ?

Right, what I have done.
Re formatted to ext 4.

What I have discovered.
My TV will only read fat 32.
The dt will read and write to the drive without issue.
Plex will not read the drive but…
Mini dlna and ushare won’t read it either but they both return a lack of permission error.

I assume when you talk about mounting the drive you are just referring to being able to see it with the file manager?
I am afk for the weekend so trying things is not possible but any information to mull over would be appreciated.

SGS 2 and Tapatalk are awesome.

OK, now it’s ext4 …

Let’s assume the partition on the external drive is /dev/sdb1

Then you could create a mountpoint at say /media/storage:

sudo mkdir /media/storage

mount the external HDD with:

sudo mount /dev/sdb1 /media/storage

make it writeable by anyone:

sudo chmod -R 777 /media/storage

now the contents should be accessible at /media/storage … including by ushare, etc. as long as they’re properly configured.

Obviously the above will need modifying if the external drive is anything other than /dev/sdb1

You can get an idea of the partition device assignment with:

sudo fdisk -l

If that works as expected … you can add the drive/partition to be automounted at boot up from fstab.

Is this a smart TV capable of streaming over a network via a share? If not, and it can only access the drive by direct USB connection, then FAT32 is your only option. Not sure where Linux comes in here though? ???

Unless you’re purely asking about accessing the drive through Linux - this should be as simple as just plugging it in to the PC’s USB port…

It’s my understanding that he wants it permanently attached to the Linux PC and it’s media contents streamed through Ushare (or similar) to other devices including the TV.

Hence why he originally wanted an internal drive … so effectively he wants it mounting “normally” rather than through gvfs

Thanks for the info Chemicalfan.
I didn’t know that but had worked it out by trial and error but nice to have it confirmed.

@ Mark Greaves
Spot on with the analysis of my requirements.
Creating the mount point worked eventually.
Now to auto mount. The drive is named /dev/sdc1 so if I have understood what I have read I should…

sudo mkdir /mnt/3TBusb
sudo cp /etc/fstab /etc/fstab.bak
sudo gedit /etc/fstab

Then add

/dev/sdc1  /mnt/3tbusb auto auto,user,rw,exec 0 0


/dev/sdc1  /mnt/3tbusb ext4 auto,user,rw,exec 0 0

to fstab at the bottom, then save and re boot.

If all that is correct what will happen/needs to be done about the mount point we have already created?

I take it it’s formatted EXT4 now ?

As it’s an external HDD adding it to fstab by device assignment (/dev/sdc1) is probably unwise as if you insert a USB stick the device assignment may change … probably best to use UUID, so with the drive plugged in and mounted what’s the output from

sudo blkid

Yes it is ext4 now.

Output is

/dev/sda1: UUID="0227ff0d-2ed0-43af-af30-49aa0ef98919" TYPE="ext4" 
/dev/sda5: UUID="d94b9bb9-c04f-41e6-ac14-0d8e0abd1262" TYPE="swap" 
/dev/sdb1: LABEL="USB HDD" UUID="1EC4-1101" TYPE="vfat" 
/dev/sdb5: UUID="bec031a5-f620-43d5-b057-60797a8dbeaa" TYPE="swap" 
/dev/sdc1: LABEL="Samsung D3" UUID="9a4e4dd7-9702-4923-a2a6-2ae8f33ea3d3" TYPE="ext4" 

Ignore sdb1, I’ll deal with that later.
So I’m guessing I’ll need

UUID=9a4e4dd7-9702-4923-a2a6-2ae8f33ea3d3  /mnt/3tbusb auto auto,user,rw,exec 0 0