Redo Backup & Recovery and live USB

Hi guys

I’ve recently installed PM4 to my daughters laptop and before I hand it back over to her would like to take a system image in the inevitable event of her screwing it up completely (something she does almost as well as I do) however the laptop doesn’t have an optical drive but can boot from USB,

I’ve used Redo Backup & Restore in the past and it’s dead easy to use but according to their website there seems to be some issues using unebootin

2. Installing Directly to USB with Unetbootin

Sometimes, as with a netbook, you may not have easy access to a CD-ROM drive. Advanced users may then wish to use Unetbootin to install the ISO image directly to a USB stick, bypassing the step of burning a CD. If you use an older version of Unetbootin, it will not work. You must have the latest version of Unetbootin downloaded directly from their website.

Using Unetbootin is not recommended because it prevents the Redo Backup splash screen, help files, boot menu messages, and other features from being displayed or used. Please let the maintainers of Unetbootin know that you would like these issues to be fixed, and Redo Backup added to the list of built-in images! Just go to Bugs : UNetbootin and open a bug report to do so.

so my question is can I use the version of unebootin I downloaded from Synaptic in PM4 (my PC) or will I have to uninstall that and install directly from the unebootin website, or is there a better way to do this altogether

Many thanks


I do not know much about Redo Backup & Recovery, so cannot advise you on that but you could try Clonezilla Live on USB flash drive or USB hard drive instead if you just want to clone/backup the relevant partitions.

Hi SeZo

I really only wanted to do it with Redo because I’ve used it before and found it simple to use, I vaguely remember trying to use Clonezilla before an thought it was a bit more involved but I’ll have another look at it

Many thanks


No problem :smiley:
If you got a Redo Backup & Recovery a LiveCD then you could just create the Live USB from that:

1. Installing from CD to USB

Burn a CD, boot from it, and then use the “Install to USB Drive” tool from the start menu. This is the easiest and most straightforward way to put Redo on a USB stick.

I had no idea I could do that

definitely the way to go

Thanks so much


Redo Backup & Recovery sounds like a good bit of kit, have read up a bit about this and will certainly use this in future.
Many thanks for bringing it to my attention, Graeme.


you’re welcome Degsy,

It is a good tool and very easy to use, although I’m currently experiencing a couple of problems with it one is it won’t connect to my network so I can’t back up straight to a network drive and I can’t get it to install to a USB drive but that might be the USB drives I’m using

in case it’s of any interest to anyone or if anyone wants to install Redo Backup & Recovery to a live USB the install to a USB within Redo Backup & Recovery wouldn’t work for me, I tried several drives but although it appeared to install to them ok it wouldn’t boot the system, just a flashing cursor on the top left of the screen , I then tried unebootin, again it installed fine and it attempted to to boot, got as far as the Redo splash screen then went into tty mode asking for a username & password, finally I installed Startup Disk Creator from synaptic and it installed the iso to the USB drive and booted perfectly


Cool … another win for “Startup Disk Creator” :slight_smile:

I get the impression you’re pleased about that but dont you think it’s rather a bad thing that 2 out of 3 linux applications fail.?

also I might be wrong but isn’t the application within Redo Backup & Recovery actually Startup Disk Creator, if not it’s very similar ?

Well -

Unetbootin isn’t a “linux” application … it’s a multi platform app, that happens to have a Linux version.

As for the Redo one … I dunno, it probably is usb-creator-gtk as Redo is Ubuntu based … I’m just not 100% sure.

Maybe it was just a hiccup with the way it’s implemented in Redo … when you think about it, usb-creator-gtk (Startup Disk Creator) was designed to work with the full ISO image … not to clone a running OS to a USB stick.


Windows USB creators do weird things too … check out the Peppermint 3 tutorial (for the AA1) on here and you’ll see what I mean :wink:

This aint a Linux issue … you get problems in Windows too … I was just happy to see the one designed by/for Ubuntu does the job pretty much every time :slight_smile:

In reality it’s not a problem with ANY of them … it’s more likely the way your BIOS/hardware doesn’t 100% interpret the syslinux/isolinux bootloader correctly, and gets stuck on the differing menu structures.

I thought you’d pick me up on the “Linux applications” thing, but I wasn’t meaning to single out Linux as being the problem, only that 2 out 3 applications failed and that’s not a good thing whether they’re Linux applications or not they’re still running in Linux especially with an application like this that could be a potential newcomers first experience with Linux.

I understand your explanation about why Startup Disk Creator didn’t work in Redo Backup & Recovery but if it’s not designed to work in a live environment then why have it there, you wouldn’t install Redo Backup & Recovery to your hard drive as a full installation (would you ? ).

I know there are many technical reasons why it didn’t work in my scenario and it may well have worked in others and you’ll blow my argument out of the water, but i’m looking at this from non techie persons perspective who like me don’t fully understand these things. our logic is if it’s there it should work and if it doesn’t work it’s broken

OK, the LiveCD image contains “isolinux” as the bootloader, which isn’t really designed for USB sticks … the USB creator app should really replace it with “syslinux”, but it’s all down to the implementation how the menu structure gets written … some PC’s just don’t like certain implementations … simple as.

AFAIK, there’s no defined standard, so hardware manufacturers do what they want.

You’ll probably find the Redo one works on other PC’s … as obviously does Unetbootin.

You may also find that both of them (or one of them) works on a different USB stick

It’s not really the software’s fault … it’s the lack of a standard, and the hardware manufacturers.


There are also some NEW motherboards that flatly refuse to boot USB sticks with syslinux AT ALL (I’m looking at you Gigabyte) … so non of the creators work … the only way to get them to boot a LiveUSB is to dd/cat an isohybrid image to the USB stick so it’s still using isolinux, but in the new hybrid mode which allows isolinux to work on devices the system considers a HDD (including USB sticks) … therefore conning the system into booting a CDROM filesystem (ISO-9660) from a HDD/USB stick

It’s kind of an oddly complex issue (and as I’ve said, not one with a standard all the hardware manufacturers are sticking to) … see:

(which also contains info on the ISOLINUX new “hybrid” mode.