Restore Bootloader in Dual-Boot environement

Hey dear linux community, :slight_smile:
I face a pretty stupid issue right now. I have a dual-boot computer with Solus 4.1 and Windows 10. In the last time, i had different issues on Windows like bluescreens and failing updates.
I wanted to reinstall Windows. The reset option in Windows didn’t work. So i downloaded Windows 10 and installed it into the same partition as previously. I think that changed the bootloader.
The problem is now, that the computer directly boots into Windows without the choice of booting into Linux. But the Linux partition is still there with all the data in it (i will post the partition table output later).
My question is… Is there a way to restore the dual-boot? Or should i copy the data from the Linux partition and reinstall it?

Btw, i’m more or less of a beginner. So sorry if i don’t understand everything :wink:

Thanks in advance for your help!

sdb2 is the Windows partition, sdb4 the Linux partition

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 1187839 1185792 579M 7 HPFS/NTFS/exFAT
/dev/sdb2 * 1187840 1170699557 1169511718 557.7G 7 HPFS/NTFS/exFAT
/dev/sdb3 1170704745 1178512334 7807590 3.7G 82 Linux swap / Solaris
/dev/sdb4 1178512335 1953520064 775007730 369.6G 83 Linux

Hello Juli95 - and welcome to the Forum.

If you have data on the Linux partition that you want to save, then do that. Then I suggest that you simply re-install Linux.
The installation will probably find the old Linux and ask if you want to overwrite it - say “yes” - and that ought to be OK. The dual-boot facility will then re-appear.
I make no guarantees! and I am assuming that Windows is working. I merely offer this solution based upon my own experience. Caveat emptor

It might be wise to await further advice from other Members and choose what seems to be the best option.


Thank you :slight_smile:
The problem with that is, that all my programs and program settings would be gone then and setting that up would take a decent time. So i would be happy about a different solution.

Yep! That’s what’s happened. Windows bootloader does not ‘see’ other distros whereas Grub does. In a dual-boot scenario, Windows must always be installed first, then Linux. :wink:

Can you boot from your Solus medium? If so, go to ‘Try Solus’ (or similar instruction), open a terminal and enter

sudo fdisk -l

(copy/paste it into terminal to avoid errors - also same with the results into your reply)

Incidentally, why Solus? Is this your first foray into Linux? I ask only because other, more established distros will have potentially more support available?


It’s a bummer, that the Windows bootloader doesn’t recognize Linux. But isn’t it possible to just reinstall Grub somehow?

Actually, i’m not completely new to Linux. I’ve used Ubuntu and Linux Mint for the last 7 years. But i really like the design of Solus. And it has been even more comfortable in terms of avoiding to use the terminal. So that’s how it replaced Linux Mint for me (whose design is a little boring for me tbh).

Here’s the complete output:

Btw, sda is just a data HDD. sdb is the SSD on which i have my operating systems.

I actually fixed it by reinstalling Grub. It worked with the commands on this site:

Thank you so much for the help! :slight_smile:

Glad that you solved the problem,Juli - and thank you for providing the link. With my schoolboy German I can almost understand it.

Glad you found a solution @juli95. Please remember to edit your original post in this thread and append (SOLVED) at the end of the subject line. That way future forum users with similar problems will see that a solution was found.