Restoring Acer Aspire One's Linux operating system from disc - help please.


Some time ago I successfully recovered my netbook’s Linpus Lite operating system from the disc supplied with it by Acer. This time it failed.

Originally the process had taken about half an hour. This time, after copying data for about 1 hour it gave the message “Error, program cannot continue. Press OK to exit”. When I pressed OK it went back to the beginning to try again but this time it failed earlier in the process.

Before starting copying data it says “Select partition”. It used to give one option - whole disc. Now it usually gives no option and fails after I click on the arrow to continue.

I left a query about this on the Acer support site but they said they “do not have enough expertise in this regards” Do you have any idea how I could try to fix it?

This is a follow on query from the one I left here a few weeks ago “Firefox 6 on Acer Aspire One very slow or crashing”. It trashed my computer so badly I couldn’t try anything Mark had kindly suggested in his reply!



Are you saying you can’t create the USB installer from the DVD ? … or that the USB installer fails when attempting to install Linpus to the AA1’s internal drive ?

Hi Mark,

I have a USB optical disc drive so I can just plug the disc in directly and boot from it. It reads the disc OK and starts the installation to the internal drive.

Hmm… In that case it’s impossible to say if it’s the optical drive, the DVD, or the AA1’s internal hard drive/SSD that’s at fault.

My ‘instinct’ say’s it’s your AA1’s SSD… this is purely based on the fact that Firefox 6 screwed your system.

FF6 has been fine on everyone else’s… so I have a feeling the SSD is failing… that said, at this point that is pure speculation on my part… it could just as easily be the optical drive not reading the disk properly (and the FF6 issue purely coincidental)… this can be easily tested by either -

a) using another PC to create a USB stick installer, then attempting an install to the AA1 from the USB stick… as shown in this video:-


b) using the external optical drive (connected to another PC), and attempting to copy the ENTIRE contents of the DVD to a folder on that PC… you can delete it afterwards, this is just to test the optical drive can read the entire disk.

Personally I’d go with a) as even if the optical drive can read the DVD, it doesn’t necessarily mean it can install from it.

Hi Mark,

Thanks for such prompt and helpful replies.

I’ve tested out option (b) and all the files copied fine onto my boyfriend’s computer, so that suggests the disc and the optical drive are OK.

Apparently option (a) risks reformatting my boyfriend’s computer if I get it wrong. He needs it for work so we’re not too keen on that idea! Would it tell us anything useful if I tried using my own faulty AA1 to create the USB stick installer?

It’s looking more likely that you are right in thinking that the internal drive is the problem. If so, can I do anything about it?

No need to reply quickly this time - I need sleep now! Goodnight and thanks,


YES, and erm… YES :slight_smile:

I can see no reason see why you couldn’t use the optical drive on the AA1 to either -

a) create a USB stick installer for the AA1, on the AA1 itself.

If that then suggests the internal SSD is faulty… you have 2 options -

b) Get a new SSD and install it… For a load of links to pages that will explain how to take apart the AA1, and how to fit either a new SSD or a 1.8" PATA ZIF Hard drive, see here:
or check out the pics and links here

or this AA1 disassembly/modding video
There are also plenty of other Apire One disassembly videos on youtube.

c) Install another Linux distribution directly to a USB stick, and boot from that… you may even be able to get a bootable copy of Linpus Lite onto a USB stick

Hi Mark,

When I tried to create the USB stick installer on my AA1 it came up with “Error 39! Report to” just after the ‘Select a USB drive’ screen, although it had detected the USB drive and given it as the only option. The USB stick is 4GB and FAT32. Googling Error 39 suggests that it’s something to do with accessing memory on Windows machines anyway.

In messing around with it I was able to see another error message for long enough to write it down. I think it’s been coming up previously but flashing past before I could read it properly. It occurs on the second screen after power-up -

"Intel UNDI, PXE-2.1 (build 082)
Copyright (C) 1997-2000 Intel Corporation

For Realtek RTL8101E/8102E PCI-E Ethernet controller v1.09 (080602)
PXE-E61: Media test failure, check cable
PXE-M0F: Exiting PXE ROM"

Could this be relevant? I hope these errors tell you more than they tell me!



Yes it probably is relevant… when you attempt to boot your AA1 WITHOUT the USB stick inserted

Is that the error message you see ?

PXE-E61: Media test failure

If so, this is likely (but not definitely) to be caused by a failed SSD, as the machine will attempt to boot from the first boot device (SSD) then if it can’t it moves on to the next boot device (USB if inserted), then PXE network boot until it finds a bootable drive.

PXE-E61: Media test failure … is not a problem in and of itself, it just means you don’t have network boot set up… bu it DOES mean that either the boot device order is incorrect, or that it has arrived at the final boot device (PXE) without finding a bootable drive.

See here:!/

As for the “Error 39”, I’m fairly certain this is a hardware compatibility issue, maybe connected to the type of controller on the host PC… see here:

If I were you I’d download the 1.0.15E version (which I think was the original as installed on the ZG5) as an image:
(by the way, that is a torrent, so you’ll need something like uTorrent on your Windows PC to download the image)

Then follow the instructions here:
to create a USB stick installer on your Windows PC … that way you’re not risking booting the DVD on the Windows PC and borking that PC too.

This method has worked for at least 1 other person (that I know of) on this forum… read this topic:
and in particular, the last 3 messages, starting here:

It’s not going to help if it IS a failed SSD though… in that case your only options are to fit a new SSD, or install another Linux distribution on a USB stick (or USB hard drive), and boot to that.

Hi again, Mark

The more I do the worse it gets!

While I was checking out when I got the PXE-E61 error (yes, it does seem to be when it is looking for the internal drive first) it got to the point where the screen stays blank when I switch on and the 2nd LED from the left, which I think shows when the internal drive is active, never lights up at all. It was still the same when I tried it again later.

That still seems consistent with a failed SSD and presumably all I could do would be to install a new one?

Replacement SSDs look fairly expensive and a bit fiddly to get at and there’s always the chance that there’s something else wrong too / instead. As the netbook is nearly 3 years old and was fairly cheap in the first place, would I be better off wimping out and getting a new and up-to-date replacement netbook?

I’d be *fairly sure it’s the SSD, but without being able to test it, you might be right to just get another netbook just on the off-chance it’s something else… only you can decide that.

An SSD is about £50(ish)

You’d have to feel comfortable taking the thing apart, I can’t do much more than provide links to instructions… unless you’re in Cornwall.

If you do decide to get another netbook, how much would you want for that one “as is”… I could do with an AA1 to help people out on this forum… Linpus Lite won’t run in a virtual machine.
(not trying to talk you out of it, I’ll get one at some point anyway :wink: )

Or another option would be to run another Linux distribution (Ubuntu maybe) from a USB memory stick or USB hard drive… but you may (now) need to disconnect the SSD, which still means taking it apart.

Just as a matter of interest, does this cover give access to the SSD card ?


I am giving up and getting another netbook so you are welcome to the old one, if you’ll pay for the postage to get it to you. If it’ll make it easier for you to give other people helpful advice like this then that’s a great use for it! Would you like me to check how much the postage will be?

Since I last posted here, I’ve checked the cover you asked about (it’s empty - an expansion slot?) and my neighbour lent me a DVD which is supposed to boot on the external optical drive with Knoppix 4.0. He got it free with ‘Linux Format’. I don’t know whether it’s a version of Linux which is supposed to work on the AA1 but all that happened was that the drive powered up ok but the netbook didn’t seem to be trying to read it and the screen stayed blank as before. That may tell you more about what’s broken and help you decide whether you really want the netbook.

Acer Aspire One Disassembly. Upgrade SSD, RAM, Wi-Fi 802.11n
This shows the disassembly process to get at the SSD, among other components. It’s rather more complicated than just opening one cover - they’ve put it on fast forward so it won’t take too long! There are also videos on You Tube showing changing the SSD on other versions of the AA1 which only require you to open a cover on the base, so it was worth checking out.

If you don’t want the netbook I’ll probably take it apart to see if any of the components would make nice jewellery or ornaments. I’m particularly fond of coils of copper wire at the moment but heat sinks and small pcbs with gold pads look interesting and you never know what else you might find, so if you wanted to give me something in exchange, some broken components which you’ve swapped out might be nice.

Hi Kath.

I would very much appreciate it if you would check how much the postage would be so I can forward it to you.
(I’m in St Austell, Cornwall … if that makes any difference)

I also very much appreciate the gesture, and with a bit of luck so will others … we seem to get an awful lot of questions from people that have AA1’s and they can be very difficult to answer, normally if I get a question about a Linux distribution that I’m unfamiliar with I just load the OS into a Virtual Machine, but Linpus Lite (at least the version that comes with the AA1) flatly refuses to run in a VM.

If I can get it running I’ll be able to work out ways of installing the software that people ask about … as the vast majority of questions seem to be about installing recent applications.

Though I’d feel remiss if I didn’t point out that you could probably make some money from it if you sold it on Ebay for spares, as you are obviously a kind hearted individual, and I’d hate to feel like I took advantage :slight_smile:

Hi Mark,

The parcel weighs 2.5kg. The cheapest option seems to be standard parcel post at £7.62. Delivery takes 3 days and it includes up to £46 insurance. What do you think we should state as the value for the insurance? (No, I won’t suddenly decide you’re taking advantage of my good nature if you put a sensible value on it :wink: )

If you want faster delivery or higher insurance, check the options for first class, recorded or special delivery here

Thanks Kath,

£46 insurance seems fine to me, and if it didn’t arrive would probably be roughly what you’d get for it on Ebay and would compensate you for the gesture … maybe you could get a little more if you stripped it and sold the parts individually, but you get my drift (BTW, that option is still available to you) :slight_smile:

I’m also in no crazy rush, I’ll have to strip it down and see if I can at least get a BIOS screen to display before ordering a new drive anyway … I’d appreciate it if you could send me a personal message with your address or a PayPal account that I can forward the postage to.

or email me -

Thanks once again … if I can fix it and use it to help others, I’ll make sure the moniker “Kath C” becomes famous around these parts :wink:


I see from this thread that you are the kind person who donated your Acer to Mark! Thank you so much. He is such a whizz and he is investigating a fault which has really bugged me all the time I had my Acer.

It is a lovely little machine and you can’t beat that 15 sec start up, but upgrading to Firefox 6 (and then 7) and Flashplayer 11 was quite a daunting task - although made easy by Mark’s clear and well annotated step by step instructions!

I wonder if you had the same problem as I did with the keyboard? - see

Thanks again!

Hi Freddie,

No, I don’t think I ever noticed that problem on the AA1, however I’m having a similar problem with my new Asus Eee! As far as I can tell, the keyboard layout is slightly different and I’m missing the shift key and hitting the arrow keys instead! I don’t think changing to Ubuntu will fix that but hopefully I’ll get used to it soon.

Best of luck sorting out your problem. Mark says he’s got my old AA1 working again :slight_smile: so with any luck he might be able to replicate it.