Ripping a Video

I’ve had Ubuntu for a few weeks now and never encountered major problems - except this one, which I’ve been unable to solve since I first installed.
I’ve been trying to rip DVDs, but my DVD Drive is busted. Therefore I’ve copied the files from the Disc using another computer, then transferred across via a removable storage device and dumped an exact replica of the CD in a folder in /~/Videos. Then I used Thoggen DVD Rip, selecting to rip from the folder (the one whose contents are VIDEO_TS and AUDIO_TS) but it didn’t like it, requesting the files that are stored in VIDEO_TS. So I fed it the VIDEO_TS folder and it told me it was all fine, but then when I started the rip I just got a blue screen, no progress and no details. I also tried putting the contents of my DVD on a .iso using brasero, but brasero wouldn’t even load the files in, let alone create the .iso. Finally I installed AcidRip, who didn’t even like the VIDEO_TS directory.
I have no idea what’s going on (I have tried with multiple DVDs etc.) and would be very grateful for some help!

I’m a bit lost here… what are you trying to achieve ?

OK, I get it that your DVD is broken, and you’ve copued the VIDEO_TS and AUDIO_TS folders to the PC, but why are you trying to encode them ?

But if you must encode to say xvid (mp4) rather than just playing the film straight from the VIDEO_TS folder in something like VLC… use Handbrake, it can handle files stored in a VIDEO_TS folder (etc.VOB’s)

To install Handbrake, you’ll have to add a PPA repository, then install, so open a terminal and enter:

sudo add-apt-repository ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-gtk

You’ll now find Handbrake at: Applications>Sound & Video>Handbrake

Fire it up, select File>Source and point it at the VIDEO_TS folder.

Preset = Normal

Format = MP4

Video tab
Video codec = MPEG-4 (FFmpeg)
Framerate = Same as source
Target size = whatever you want (it will set the bitrate automatically to suit)

Audio tab
Track = English
Codec = MP3 (lame)
Bitrate = 192
Sample rate = 44.1
Mix = Stereo

Now you can change the output “Destination File:” film_name.mp4 extension to avi if you want.

Click “Start”.

Or you could try installing k9copy from the Ubuntu repos, then using the k9copy assistant.

sudo apt-get install k9copy

Then you’ll find it at:
Applications>Sound & Video>k9copy assistant

It’s ripping fine - but there are green blotches and fuzzy bits all over the picture and the sound is jerking and making popping sounds. Have you experienced this before?

Ripping in what ? … and with what settings ?

Steer clear of H.264 (x264) … use Xvid (MPEG-4 FFmpeg), and mp3

is this in the finished video, or in a preview ?

And yes, I’ve seen this before, when I used H.264, but it may be a different issue for you.

In handbrake, with the mpeg settings, finished video :frowning:

My original file is like that too (I’m thick, I know - I was judging the quality of the DVD based on the pre-menu film) so I’ll have to recheck the original video.

Try playing one of the .VOB files in VLC and see what the quality is like… if that is fine, try different settings

what did you select as the finished size, and what did the Bitrate change to ?

The quality wasn’t lost in the rip - somewhere along the transfer between the two computers (my DVD Drive is playing up so I’m transferring all the way) it’s getting damaged, which is really odd.

OK, you lost me there :slight_smile:

It’s giving me a headache - when I copy the files to a portable device and play them from there, they’re the same size as on the DVD , but when I play them it’s as if I’m playing a scratched disc.

I take it you have installed libdvdread4, then followed the instructions to install libdvdcss2 @

What player are you using ?

and how do they play on the other PC

ie. is this a problem with the DVD → USB copy, or a problem with the USB → Linux PC copy, or just a problem with playback on the Linux PC ?

All the copies are exactly the same size (I haven’t done a checksum but I’d be very suprised if that’s the issue).

Playing the DVD on the other PC (which isn’t a PC, it’s a Mac) has no problem, but I quicktime player doesn’t let me play DVD files not from the DVD Drive so as soon as it’s on the USB I have to play it on my Ubuntu.

Both from the USB and from the file on the Ubuntu PC it’s dodgy reading from VLC and from all my ripping applications - and Ubuntu’s never managed to play a DVD.
It’s worth noting that all the film before the main menu runs smoothly (VIDEO_TS.vob) but after that it gets dodgy.

No, i haven’t installed these libdvd packages - could that be the entire problem? I never realised this was necessary! (I will do that later - I don’t have my PC with me at the moment).


It's worth noting that all the film before the main menu runs smoothly (VIDEO_TS.vob) but after that it gets dodgy.

Sounds like a CSS issue… commercial DVD’s use CSS (Content Scrambling System) to prevent copying.

It could either be at the Mac end… ie. the DVD drive is being prevented from reading the content correctly, unless played through a player that has a CSS decoder.


At the Ubuntu end, you don’t have libdvdcss2 installed… follow the instructions at the link in my last post.

It looks like that’s done the trick… thanks again for your expertise and patience!

I have one niggling problem - when I run handbrake from command line:


Handbrake happily opens.
But when I try to open a directory with handbrake:

ghb /media/Terminator2

Handbrake opens but doesn’t source the DVD.
Wouldn’t it be logical for handbrake to have the source directory as it’s argument?
Am I doing it wrong (ghb is definitely handbrake and my disc is definitely called Terminator2)?

Erm… that works for me.

Are you SURE you are getting the “source” directory path/name correct (remembering Linux IS case sensitive) ?

both of these resulted in handbrake reading the DVD and offering to encode the contents.




Maybe try:

ghb /media/Terminator2/VIDEO_TS

BTW, that is NOT a reflection of my movie tastes, just the first DVD I laid my hands on :wink:

That’s not working, but i’m currently facing a slightly larger problem - when I put the ripped movies on my iPod they have no sound :frowning: I have formatted it in mp4 as instructed (although it does come out as m4v), do you know why this is happening?

Haven’t the foggiest… don’t have anything Apple, and never will… check online to see what the best audio settings are for an iPod

OK, Handbrake came with a preset for iPods :slight_smile:

I know it did… doesn’t mean the settings are correct though, does it ?

Does the audio work if played on the PC ? … If so, it MUST be in a format that the iPlod doesn’t like.

Try changing the audio to MP3 stereo, with the settings I gave above… the iPlod can handle MP3 can’t it ?

Or try changing it from AAC Dolby (5.1) to stereo.

The PC was happy with the sound, not the iPod - I’ve now got the audio working in AAC, with Dolby Pro Logic II mix. perhaps that was the problem.