Rockbox install

I’m trying to install the Rockbox utility, but at the ‘install’ stage I’m getting an error message “Could not open Ipod: permission denied”. I understand I need to get permission by using sudo or by logging in as root. I’ve searched the Rockbox site and forums but can’t find a relevant thread / answer – probably because it’s more of a simple linux issue… but still apparently too complex for me… I don’t know how to do this.

Would one of you chaps be good enough to point me in the right direction.


I take it you have rbutil installed ?

Which distro/version are you using ? … if Ubuntu/Mint …

try running it as root from a terminal:-

If it’s a command line utility:

sudo rbutil

if it’s a GUI application:

gksudo rbutil

If you haven’t already got rbutil installed (in Linux) … it’s in the getdeb repos.

If you’re using something other than Ubuntu/Mint … let us know what.

I have installed the relevant download from this page:

I’m able to start the ‘graphical interface’ – GraphicalInstall < Main < Wiki

I selected my media device manually because the ‘auto detect’ didn’t work – the guide says “If the Utility can’t find the player in linux, try running it as root”, I don’t know how to to this.

It’s then at the next ‘install’ stage that I get the error message “Could not open Ipod: permission denied”.

I’ve tried sudo RockboxUtility and now sudo rbutil and gksudo and get a ‘command not found’ message.

I’m using Ubuntu 12.04 32bit

I take it you’ve downloaded a tar.bz2 from the above links called RockboxUtility-v1.3.1.tar.bz2 ?

then unpacked a file called RockboxUtility ?

If that’s what you’ve done … to run the application as root …

Let’s say RockboxUtility is on your desktop.

Open a terminal (Ctrl+Alt+T) and run:

gksudo ~/Desktop/RockboxUtility

if it’s somewhere other than your desktop … either put it on the desktop, or adjust the path in the above command.


Another option would be to permanently install the Rockbox Utility, by downloading and installing the correct .deb for your architecture from here

32bit -

64bit -

But you may still have to run it as root.

Yep, that’s what I did, although I unpacked it into Home and was getting the ‘command not found’. I guess I was ‘looking’ in / from the wrong directory. Now unpacking it to desktop and following your instructions nothing happens in the terminal, it just returns the command line. :-\

By double clicking the RockboxUtility file the user interface opens, it was here I had the original permission error message.

I’ve just ejected the media device and reconnected it and now it says “Mountpoint does not exist”.

I’m now thinking it is an issue with Rockbox, or more likely something I’m doing wrong. I may start afresh point by point.

I’ll also have a look at your edit


What is the output from:

uname -a


First… I’ve installed the .deb and can open the ‘user interface’ from the icon in the side bar, but still have the same issue with ‘ipod permission’ and ‘mountpoint’ – I think identifying the mount point is the problem.

uname -a returns

Linux neil-Latitude-D810 3.2.0-39-generic #62-Ubuntu SMP Wed Feb 27 22:05:17 UTC 2013 i686 i686 i386 GNU/Linux

OK, first see if starting it with elevated privileges helps:

gksudo RockboxUtility

If that doesn’t help … do you know where it’s being mounted ?

With the iPlod plugged in … What’s the output from:



sudo fdisk -l


You are a star.

I had previously tried gksudo with no joy, but with the .deb version it worked fine, launched the utility, detected the ipod and installed successfully.

Yet it didn’t work from the icon launcher.

Can’t see why that would be.

Thanks for your perseverance in helping. I forget stuff quicker than I can learn it these days. :wink:

You’re welcome :slight_smile:

You can add “gksudo” to the launcher if you’d like ?

just run:

sudo gedit /usr/share/applications/rbutil.desktop

Find the line:-


and change it to:-

Exec=gksudo RockboxUtility

SAVE the file.

Now it should prompt for a password when launched.