RT3070 drivers for VM kali linux 2019.3 64bit Debian

Hello, I recently bought a network adapter on amazon, which uses the Ralink RT3070 chipset. I planned on using it for kali linux on the oracle VM virtualbox. I have normal linux as base OS for my laptop and there I can use the adapter without any problems, but on kali, it cant detect any networks for some reason. So i tried to install drivers but I get errors in the terminal and then I realized that those files that were on a mini cd ( it was included with the usb network adapter), were actually for the chipset RT2870.

I found this forum and saw that some people had kind of the same issue as I do and they got it fixed.

I hope that I will get help here in order to fix this problem :smiley:

I used following commands which might help to solve this problem faster.

See attachement for more information.

Best regards

a) please don’t post terminal output as a screenshot (in fact please don’t post any images as attachments unless asked to do so by forum admin) … TIA.

b) Is this a VM of Kali ? … if that’s the case, you shouldn’t need to install any drivers in Kali, the VM client will pass wireless through from the Host OS.
(if you’re attempting to use the adapter for wireless scanning/cracking in Kali, I’m afraid a VM won’t do it because there’s no way to access the drivers in the Linux client directly … but neither will I help you to do that, the Kali Linux forum would be your best bet)

a) sorry, I didn’t know that.

b) Yes it is kali linux on VM and I wanted to capture the traffic of my wlan at home, just for fun. As I am learning how to use wireshark at the university, I got curious about the program and so I did some research and found out that you can also caputure internet traffic from your entire wlan at home. I also found out that you need some special device for that, which is why I bought the network adapter. But as already said, it can’t detect any networks and idk why…

Actually, I found out why it cant detect any networks. In the VM settings, I had to go to USB and set it on 3.0 xHCI controller. ( It was previously on 2.0). But anyways, I am still struggling to update the drivers.

I found out that the Chipset is Ralink RT2870/RT3070 .

For the currently installed driver it says RT2800 usb.

Can you help me to install the most recent drivers for this network adapter? I tried your guide on how to install if certain errors occur, but that didnt work for me …

uname -r

You shoudn’t need to install any drivers for the network adapter in a VM … the network should be passed through from the host OS

Hence why I said this likely won’t work in a VM … and add that to the fact the drivers I hosted previously are highly unlikely to compile against the 5 series kernel.

And add to that I don’t know Kali well enough to give you instructions.

The Kali forum is your best bet.

I can give you a working link to the drivers I linked to in the old topic if you want ?, but I’m nearly 100% sure they won’t compile against recent kernels so you’d be wasting your time with them … beyond that I’m afraid I can’t help.

Oh okay, but what about normal linux with a kernel 5.0.0-31-generic? Do you have any drivers so I can install it there ?

I’m not convinced you’d need any.

What’s the output from


the output is

Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 001: ID  1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Kali is based on Debian … the 3070 chipset (with the IDvendor:IDdevice string 148f:3070) is covered by the rt2800usb driver.

Instructions for rt2800usb in Debian can be found here:

I doubt this driver will get you the ‘injection’ you’re probably after for aircrack-ng but it should get wireless working … if ‘injection’ is your goal, please take this matter up on the Kali forum.

If you want the driver I posted in the earlier topic, just ask … but again I seriously doubt it’ll compile against recent kernels … I’m happy to give you the source code, but I can no longer provide help compiling it because I:-
a) don’t have a 3070 based card.
b) am not running anything with an old kernel (where it’s liable to compile).
c) don’t run (or understand the weird repository structure used by) Kali Linux.
d) have no use for (or wish to help people with) aircrack-ng for wireless cracking.

Also please don’t report posts just to try get my attention … that forum function is for reporting posts that you think may breach forum rules and/or good forum etiquette.
(in short, I’ll attempt to help anyone on this forum where I can … using the forums ‘Report to Moderator’ function with the note “no more replies?” just to get my attention is unnecessary, annoying, and is in itself a breach of forum rules and good forum etiquette)